summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-12-28 12:39:11 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-12-28 12:39:11 +0000
commit51b49861ce3b21bb97d4479b56d98fa028a6ad3a (patch)
tree3caa395509630afed3a1e0ef3c3b6b1ae8574eb3 /www-servers/nginx
parentFix #116936. (diff)
downloadgentoo-2-51b49861ce3b21bb97d4479b56d98fa028a6ad3a.tar.gz
gentoo-2-51b49861ce3b21bb97d4479b56d98fa028a6ad3a.tar.bz2
gentoo-2-51b49861ce3b21bb97d4479b56d98fa028a6ad3a.zip
* bump
(Portage version: 2.1_pre2)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest4
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.181
-rw-r--r--www-servers/nginx/nginx-0.3.18.ebuild70
4 files changed, 80 insertions, 2 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 41088c1b8d32..124519471c77 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.62 2005/12/07 15:15:37 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.63 2005/12/28 12:39:11 voxus Exp $
+
+*nginx-0.3.18 (28 Dec 2005)
+
+ 28 Dec 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.18.ebuild:
+ Bump, closing bug #116270.
*nginx-0.3.14 (07 Dec 2005)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index dd8901f98f9a..0b198d972d24 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -1,8 +1,9 @@
-MD5 eef9dd778e852ae84b3449f07beca0fe ChangeLog 10660
+MD5 6f655df5fbd2e4f77d3b38fe4a3a52d4 ChangeLog 10795
MD5 e8474104898712edc8575c940152bbd3 files/digest-nginx-0.1.45 64
MD5 86fb37c347608004443f47aabae2fec7 files/digest-nginx-0.2.6 63
MD5 1bb0edeb44d5da60091b0c0d24e87c4f files/digest-nginx-0.3.12 64
MD5 676aa9e60aa117c23ab3a5af4c3c893b files/digest-nginx-0.3.15 64
+MD5 22e8fcae496dd0fd0a60aafb96f6e494 files/digest-nginx-0.3.18 64
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
MD5 fecedd05099122b1f8169152e5bc9462 files/nginx.conf 1400
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
@@ -10,3 +11,4 @@ MD5 62f46895e63da25c83512f589b9e61cb nginx-0.1.45.ebuild 1935
MD5 6460bce607f17843cd0c22395e6122e0 nginx-0.2.6.ebuild 1934
MD5 095ed1434baabf705fdbe6c4fbc92cf1 nginx-0.3.12.ebuild 1935
MD5 b24f35c96ef3f22c3c1e523ac45da59b nginx-0.3.15.ebuild 1937
+MD5 b24f35c96ef3f22c3c1e523ac45da59b nginx-0.3.18.ebuild 1937
diff --git a/www-servers/nginx/files/digest-nginx-0.3.18 b/www-servers/nginx/files/digest-nginx-0.3.18
new file mode 100644
index 000000000000..83935875007c
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.18
@@ -0,0 +1 @@
+MD5 b8cffdf85d251dd91baed9e67dafd828 nginx-0.3.18.tar.gz 360953
diff --git a/www-servers/nginx/nginx-0.3.18.ebuild b/www-servers/nginx/nginx-0.3.18.ebuild
new file mode 100644
index 000000000000..0e067252b685
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.18.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.18.ebuild,v 1.1 2005/12/28 12:39:11 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}