summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2008-06-28 19:12:54 +0000
committerThilo Bangert <bangert@gentoo.org>2008-06-28 19:12:54 +0000
commitadc3dfe7f03aa8b3ccd4f0750b48cb562e1b0d61 (patch)
tree255ed4dc8d8e8f7bc1dd9aef1f1e1a465f3cd3dd /www-servers/monkeyd
parentmoved to overlay (diff)
downloadgentoo-2-adc3dfe7f03aa8b3ccd4f0750b48cb562e1b0d61.tar.gz
gentoo-2-adc3dfe7f03aa8b3ccd4f0750b48cb562e1b0d61.tar.bz2
gentoo-2-adc3dfe7f03aa8b3ccd4f0750b48cb562e1b0d61.zip
version bump - bug #207306 - thanks Florian
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-servers/monkeyd')
-rw-r--r--www-servers/monkeyd/ChangeLog10
-rw-r--r--www-servers/monkeyd/monkeyd-0.9.1.ebuild24
-rw-r--r--www-servers/monkeyd/monkeyd-0.9.2.ebuild74
3 files changed, 94 insertions, 14 deletions
diff --git a/www-servers/monkeyd/ChangeLog b/www-servers/monkeyd/ChangeLog
index 3b7e089fdd98..60938366fc50 100644
--- a/www-servers/monkeyd/ChangeLog
+++ b/www-servers/monkeyd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/monkeyd
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.17 2007/02/23 19:39:50 bangert Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.18 2008/06/28 19:12:54 bangert Exp $
+
+*monkeyd-0.9.2 (28 Jun 2008)
+
+ 28 Jun 2008; Thilo Bangert <bangert@gentoo.org> monkeyd-0.9.1.ebuild,
+ +monkeyd-0.9.2.ebuild:
+ version bump - bug #207306
23 Feb 2007; Thilo Bangert <bangert@gentoo.org> monkeyd-0.9.1.ebuild:
fix ROOT misuse
diff --git a/www-servers/monkeyd/monkeyd-0.9.1.ebuild b/www-servers/monkeyd/monkeyd-0.9.1.ebuild
index 42e94a526911..6e69f5775e88 100644
--- a/www-servers/monkeyd/monkeyd-0.9.1.ebuild
+++ b/www-servers/monkeyd/monkeyd-0.9.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-0.9.1.ebuild,v 1.8 2007/02/23 19:39:50 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-0.9.1.ebuild,v 1.9 2008/06/28 19:12:54 bangert Exp $
inherit toolchain-funcs depend.php
@@ -26,7 +26,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i '/install -m 755 bin\/banana/d' configure || die "sed banana"
}
@@ -50,12 +50,12 @@ src_compile() {
src_install() {
make \
- PREFIX=${D}/usr \
- BINDIR=${D}/usr/bin \
- CGIBIN=${D}${WEBROOT}/cgi-bin \
- SYSCONFDIR=${D}/etc/${PN} \
- DATADIR=${D}${WEBROOT}/htdocs \
- LOGDIR=${D}/var/log/${PN} \
+ PREFIX="${D}"/usr \
+ BINDIR="${D}"/usr/bin \
+ CGIBIN="${D}"${WEBROOT}/cgi-bin \
+ SYSCONFDIR="${D}"/etc/${PN} \
+ DATADIR="${D}"${WEBROOT}/htdocs \
+ LOGDIR="${D}"/var/log/${PN} \
install \
|| die "make install failed"
@@ -65,10 +65,10 @@ src_install() {
fi
[[ -e ${WEBROOT}/htdocs/index.html ]] && \
- mv ${D}${WEBROOT}/htdocs/{index,index-monkey}.html
+ mv "${D}"${WEBROOT}/htdocs/{index,index-monkey}.html
dosed "s:/var/log/monkeyd/monkey.pid:/var/run/monkey.pid:" /etc/monkeyd/monkey.conf
- newinitd ${FILESDIR}/monkeyd.init.d monkeyd
- newconfd ${FILESDIR}/monkeyd.conf.d monkeyd
+ newinitd "${FILESDIR}"/monkeyd.init.d monkeyd
+ newconfd "${FILESDIR}"/monkeyd.conf.d monkeyd
dodoc README MODULES *.txt
}
diff --git a/www-servers/monkeyd/monkeyd-0.9.2.ebuild b/www-servers/monkeyd/monkeyd-0.9.2.ebuild
new file mode 100644
index 000000000000..4335d77af5f0
--- /dev/null
+++ b/www-servers/monkeyd/monkeyd-0.9.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-0.9.2.ebuild,v 1.1 2008/06/28 19:12:54 bangert Exp $
+
+inherit toolchain-funcs depend.php
+
+WEBROOT=/var/www/localhost
+
+MY_P="${PN/d}-${PV}"
+DESCRIPTION="fast, efficient, (REALLY) small, and easy to configure web server"
+HOMEPAGE="http://monkeyd.sourceforge.net/"
+SRC_URI="http://monkeyd.sourceforge.net/versions/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="php"
+
+RDEPEND="php? ( virtual/httpd-php )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use php && require_php_cgi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i '/install -m 755 bin\/banana/d' configure || die "sed banana"
+}
+
+src_compile() {
+ # monkey has it's own funky script ... cant use econf
+ env STRIP=true \
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --cgibin=${WEBROOT}/cgi-bin \
+ --sysconfdir=/etc/${PN} \
+ --datadir=${WEBROOT}/htdocs \
+ --logdir=/var/log/${PN} \
+ --lang=en \
+ || die
+ # Don't install the banana script, it is broken as is anyway and the
+ # functionality is provided by the ${FILESDIR}/monkeyd.init.d script.
+ sed -i '/install -m 755 bin\/banana/d' Makefile
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ make \
+ PREFIX="${D}"/usr \
+ BINDIR="${D}"/usr/bin \
+ CGIBIN="${D}"${WEBROOT}/cgi-bin \
+ SYSCONFDIR="${D}"/etc/${PN} \
+ DATADIR="${D}"${WEBROOT}/htdocs \
+ LOGDIR="${D}"/var/log/${PN} \
+ install \
+ || die "make install failed"
+
+ if use php ; then
+ dosed '/^#AddScript application\/x-httpd-php/s:^#::' /etc/monkeyd/monkey.conf
+ dosed 's:/home/my_home/php/bin/php:/usr/bin/php-cgi:' /etc/monkeyd/monkey.conf
+ fi
+
+ [[ -e ${WEBROOT}/htdocs/index.html ]] && \
+ mv "${D}"${WEBROOT}/htdocs/{index,index-monkey}.html
+
+ dosed "s:/var/log/monkeyd/monkey.pid:/var/run/monkey.pid:" /etc/monkeyd/monkey.conf
+ newinitd "${FILESDIR}"/monkeyd.init.d monkeyd
+ newconfd "${FILESDIR}"/monkeyd.conf.d monkeyd
+ dodoc README MODULES *.txt
+}