summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2012-11-27 03:20:00 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2012-11-27 03:20:00 +0000
commit8bbfd16618428f681024d9eb5cce04c43d6df99d (patch)
tree267ab063eac03c7b33a579ae495d5156278afebe /www-servers/gunicorn
parentStable channel bump. (diff)
downloadgentoo-2-8bbfd16618428f681024d9eb5cce04c43d6df99d.tar.gz
gentoo-2-8bbfd16618428f681024d9eb5cce04c43d6df99d.tar.bz2
gentoo-2-8bbfd16618428f681024d9eb5cce04c43d6df99d.zip
Version bump.
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/gunicorn')
-rw-r--r--www-servers/gunicorn/ChangeLog8
-rw-r--r--www-servers/gunicorn/gunicorn-0.16.1.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/www-servers/gunicorn/ChangeLog b/www-servers/gunicorn/ChangeLog
index 3ad3420705b5..f745494e100b 100644
--- a/www-servers/gunicorn/ChangeLog
+++ b/www-servers/gunicorn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/gunicorn
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.22 2012/10/24 00:39:44 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.23 2012/11/27 03:20:00 rafaelmartins Exp $
+
+*gunicorn-0.16.1 (27 Nov 2012)
+
+ 27 Nov 2012; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +gunicorn-0.16.1.ebuild:
+ Version bump.
*gunicorn-0.15.0 (24 Oct 2012)
diff --git a/www-servers/gunicorn/gunicorn-0.16.1.ebuild b/www-servers/gunicorn/gunicorn-0.16.1.ebuild
new file mode 100644
index 000000000000..fbf743eb341a
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-0.16.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-0.16.1.ebuild,v 1.1 2012/11/27 03:20:00 rafaelmartins Exp $
+
+EAPI="5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.1 *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setproctitle"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest )"
+
+DOCS="README.rst"
+
+src_prepare() {
+ # these tests requires an already installed version of gunicorn
+ rm tests/test_003-config.py
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ sphinx-build -b html source build || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/
+}