summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-02 20:00:27 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-02 20:00:27 +0000
commit4932d53ef0444bcb0985cd2e9b99b7656e9b7cda (patch)
treee3951034aa7b7377193b39ffe7522d0aed598280 /www-plugins
parentEAPI 5. Fix incorrect timeout reporting for domains that are available, revis... (diff)
downloadgentoo-2-4932d53ef0444bcb0985cd2e9b99b7656e9b7cda.tar.gz
gentoo-2-4932d53ef0444bcb0985cd2e9b99b7656e9b7cda.tar.bz2
gentoo-2-4932d53ef0444bcb0985cd2e9b99b7656e9b7cda.zip
Restore the live ebuild since some people prefer it.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/chrome-binary-plugins/ChangeLog8
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/www-plugins/chrome-binary-plugins/ChangeLog b/www-plugins/chrome-binary-plugins/ChangeLog
index c96a69045a73..fa318bf93e2c 100644
--- a/www-plugins/chrome-binary-plugins/ChangeLog
+++ b/www-plugins/chrome-binary-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/chrome-binary-plugins
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.12 2013/05/02 17:22:51 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.13 2013/05/02 20:00:27 floppym Exp $
+
+*chrome-binary-plugins-9999 (02 May 2013)
+
+ 02 May 2013; Mike Gilbert <floppym@gentoo.org>
+ +chrome-binary-plugins-9999.ebuild:
+ Restore the live ebuild since some people prefer it.
*chrome-binary-plugins-28.0.1490.2_alpha196983 (02 May 2013)
*chrome-binary-plugins-27.0.1453.73_beta197225 (02 May 2013)
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild
new file mode 100644
index 000000000000..1a05a1a41461
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild,v 1.9 2013/05/02 20:00:27 floppym Exp $
+
+EAPI=4
+
+inherit multilib unpacker
+
+DESCRIPTION="Binary plugins -- native API Flash and PDF -- from Google Chrome for use in Chromium."
+HOMEPAGE="http://www.google.com/chrome"
+SLOT="unstable"
+URI_BASE="https://dl.google.com/linux/direct/"
+URI_BASE_NAME="google-chrome-${SLOT}_current_"
+SRC_URI="" # URI is left blank on live ebuild
+
+LICENSE="google-chrome"
+KEYWORDS="" # KEYWORDS is also left blank on live ebuild
+IUSE="+flash +pdf"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="www-client/chromium"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/opt/google/chrome"
+QA_PREBUILT="*"
+
+src_unpack() {
+ # We have to do this inside of here, since it's a live ebuild. :-(
+
+ if use x86; then
+ G_ARCH="i386";
+ elif use amd64; then
+ G_ARCH="amd64";
+ else
+ die "This only supports x86 and amd64."
+ fi
+ wget "${URI_BASE}${URI_BASE_NAME}${G_ARCH}.deb"
+ unpack_deb "./${URI_BASE_NAME}${G_ARCH}.deb"
+}
+
+src_install() {
+ local version flapper
+
+ insinto /usr/$(get_libdir)/chromium-browser/
+
+ use pdf && doins libpdf.so
+
+ if use flash; then
+ doins -r PepperFlash
+
+ # Since this is a live ebuild, we're forced to, unfortuantely,
+ # dynamically construct the command line args for Chromium.
+ version=$(sed -n 's/.*"version": "\(.*\)",.*/\1/p' PepperFlash/manifest.json)
+ flapper="${ROOT}usr/$(get_libdir)/chromium-browser/PepperFlash/libpepflashplayer.so"
+ echo -n "CHROMIUM_FLAGS=\"\${CHROMIUM_FLAGS} " > pepper-flash
+ echo -n "--ppapi-flash-path=$flapper " >> pepper-flash
+ echo "--ppapi-flash-version=$version\"" >> pepper-flash
+
+ insinto /etc/chromium/
+ doins pepper-flash
+ fi
+}
+
+pkg_postinst() {
+ use flash || return
+
+ einfo
+ einfo "To enable Flash for Chromium, source ${ROOT}etc/chromium/pepper-flash"
+ einfo "inside ${ROOT}etc/chromium/default. You may run this as root:"
+ einfo
+ einfo " # echo . ${ROOT}etc/chromium/pepper-flash >> ${ROOT}etc/chromium/default"
+ einfo
+}