summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-10-13 16:44:36 +0000
committerJim Ramsay <lack@gentoo.org>2010-10-13 16:44:36 +0000
commit121d046392a82a6d2ddda31be6f2fcd706d9c863 (patch)
treee086ab6e990df21fee8ef9a9e1dd3daed6bbc2f7 /www-plugins
parentPass the arguments to the src_install to base_src_install. (diff)
downloadgentoo-2-121d046392a82a6d2ddda31be6f2fcd706d9c863.tar.gz
gentoo-2-121d046392a82a6d2ddda31be6f2fcd706d9c863.tar.bz2
gentoo-2-121d046392a82a6d2ddda31be6f2fcd706d9c863.zip
Version cleanup and fix for bug #334377
(Portage version: 2.1.9.14/cvs/Linux i686)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/adobe-flash/ChangeLog13
-rw-r--r--www-plugins/adobe-flash/adobe-flash-10.0.45.2-r2.ebuild181
-rw-r--r--www-plugins/adobe-flash/adobe-flash-10.1.82.76-r1.ebuild166
-rw-r--r--www-plugins/adobe-flash/adobe-flash-10.1.82.76.ebuild161
-rw-r--r--www-plugins/adobe-flash/adobe-flash-10.1.85.3.ebuild7
5 files changed, 16 insertions, 512 deletions
diff --git a/www-plugins/adobe-flash/ChangeLog b/www-plugins/adobe-flash/ChangeLog
index 59b37554d68f..10607b3d2608 100644
--- a/www-plugins/adobe-flash/ChangeLog
+++ b/www-plugins/adobe-flash/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for www-plugins/adobe-flash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.53 2010/10/13 11:29:43 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.54 2010/10/13 16:44:36 lack Exp $
+
+ 13 Oct 2010; Jim Ramsay <lack@gentoo.org>
+ adobe-flash-10.1.85.3.ebuild:
+ nsplugin should be in RDEPEND too (Bug #334377)
+
+ 13 Oct 2010; Jim Ramsay <lack@gentoo.org>
+ -adobe-flash-10.0.45.2-r2.ebuild, -adobe-flash-10.1.82.76.ebuild,
+ -adobe-flash-10.1.82.76-r1.ebuild:
+ Version cleanup: Removing 10.0 since 10.2 is the new more-secure release
+ with native 64-bit code, and removing 10.1.82.76 now that 10.1.85.3 is
+ stable
13 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
adobe-flash-10.1.85.3.ebuild:
diff --git a/www-plugins/adobe-flash/adobe-flash-10.0.45.2-r2.ebuild b/www-plugins/adobe-flash/adobe-flash-10.0.45.2-r2.ebuild
deleted file mode 100644
index 41c6c67d5f3a..000000000000
--- a/www-plugins/adobe-flash/adobe-flash-10.0.45.2-r2.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-10.0.45.2-r2.ebuild,v 1.1 2010/07/20 14:49:58 lack Exp $
-
-EAPI=1
-inherit nsplugins rpm multilib toolchain-funcs
-
-MY_32B_URI="http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-${PV}-release.i386.rpm"
-MY_64B_URI="http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-${PV}.linux-x86_64.so.tar.gz"
-
-DESCRIPTION="Adobe Flash Player"
-SRC_URI="x86? ( ${MY_32B_URI} )
-amd64? (
- multilib? (
- 32bit? ( ${MY_32B_URI} )
- 64bit? ( ${MY_64B_URI} )
- )
- !multilib? ( ${MY_64B_URI} )
-)"
-HOMEPAGE="http://www.adobe.com/"
-IUSE="multilib +32bit +64bit"
-SLOT="0"
-
-KEYWORDS="-* ~amd64 ~x86"
-LICENSE="AdobeFlash-10"
-RESTRICT="strip mirror"
-
-S="${WORKDIR}"
-
-NATIVE_DEPS="x11-libs/gtk+:2
- media-libs/fontconfig
- dev-libs/nss
- net-misc/curl
- >=sys-libs/glibc-2.4"
-
-EMUL_DEPS=">=app-emulation/emul-linux-x86-baselibs-20100220
- app-emulation/emul-linux-x86-gtklibs
- app-emulation/emul-linux-x86-soundlibs
- app-emulation/emul-linux-x86-xlibs"
-
-RDEPEND="x86? ( $NATIVE_DEPS )
- amd64? (
- multilib? (
- 64bit? ( $NATIVE_DEPS )
- 32bit? ( $EMUL_DEPS )
- )
- !multilib? ( $NATIVE_DEPS )
- )
- || ( media-fonts/liberation-fonts media-fonts/corefonts )"
-
-# Where should this all go? (Bug #328639)
-INSTALL_BASE="opt/Adobe/flash-player"
-
-# Ignore QA warnings in these binary closed-source libraries, since we can't fix
-# them:
-QA_EXECSTACK="${INSTALL_BASE}32/libflashplayer.so
- ${INSTALL_BASE}/libflashplayer.so"
-
-QA_DT_HASH="${INSTALL_BASE}32/libflashplayer.so
- ${INSTALL_BASE}/libflashplayer.so"
-
-pkg_setup() {
- if use x86; then
- export native_install=1
- elif use amd64; then
- # amd64 users may unselect the native 64bit binary, if they choose
- if ! use multilib || use 64bit; then
- export native_install=1
- # 64bit flash requires the 'lahf' instruction (bug #268336)
- # Also, check if *any* of the processors are affected (bug #286159)
- if grep '^flags' /proc/cpuinfo | grep -qv 'lahf_lm'; then
- export need_lahf_wrapper=1
- else
- unset need_lahf_wrapper
- fi
- else
- unset native_install
- fi
-
- if use multilib && ! use 32bit && ! use 64bit; then
- eerror "You must select at least one library USE flag (32bit or 64bit)"
- die "No library version selected [-32bit -64bit]"
- fi
- fi
-}
-
-src_compile() {
- if [[ $need_lahf_wrapper ]]; then
- # This experimental wrapper, from Maks Verver via bug #268336 should
- # emulate the missing lahf instruction affected platforms.
- $(tc-getCC) -fPIC -shared -nostdlib -lc -oflashplugin-lahf-fix.so \
- "${FILESDIR}/flashplugin-lahf-fix.c" \
- || die "Compile of flashplugin-lahf-fix.so failed"
- fi
-}
-
-src_install() {
- if [[ $native_install ]]; then
- # 32b RPM has things hidden in funny places
- use x86 && pushd "${S}/usr/lib/flash-plugin"
-
- exeinto /${INSTALL_BASE}
- doexe libflashplayer.so
- inst_plugin /${INSTALL_BASE}/libflashplayer.so
-
- use x86 && popd
-
- # 64b tarball has no readme file.
- use x86 && dodoc "${S}/usr/share/doc/flash-plugin-${PV}/readme.txt"
- fi
-
- if [[ $need_lahf_wrapper ]]; then
- # This experimental wrapper, from Maks Verver via bug #268336 should
- # emulate the missing lahf instruction affected platforms.
- exeinto /${INSTALL_BASE}
- doexe flashplugin-lahf-fix.so
- inst_plugin /${INSTALL_BASE}/flashplugin-lahf-fix.so
- fi
-
- if use amd64 && has_multilib_profile && use 32bit; then
- oldabi="${ABI}"
- ABI="x86"
-
- # 32b plugin
- pushd "${S}/usr/lib/flash-plugin"
- exeinto /${INSTALL_BASE}32/
- doexe libflashplayer.so
- inst_plugin /${INSTALL_BASE}32/libflashplayer.so
- dodoc "${S}/usr/share/doc/flash-plugin-${PV}/readme.txt"
- popd
-
- ABI="${oldabi}"
- fi
-
- # The magic config file!
- insinto "/etc/adobe"
- doins "${FILESDIR}/mms.cfg"
-}
-
-pkg_postinst() {
- if use amd64; then
- if has_version 'www-plugins/nspluginwrapper'; then
- if [[ $native_install ]]; then
- # TODO: Perhaps parse the output of 'nspluginwrapper -l'
- # However, the 64b flash plugin makes 'nspluginwrapper -l' segfault.
- local FLASH_WRAPPER="${ROOT}/usr/lib64/nsbrowser/plugins/npwrapper.libflashplayer.so"
- if [[ -f ${FLASH_WRAPPER} ]]; then
- einfo "Removing duplicate 32-bit plugin wrapper: Native 64-bit plugin installed"
- nspluginwrapper -r "${FLASH_WRAPPER}"
- fi
- if [[ $need_lahf_wrapper ]]; then
- ewarn "Your processor does not support the 'lahf' instruction which is used"
- ewarn "by Adobe's 64-bit flash binary. We have installed a wrapper which"
- ewarn "should allow this plugin to run. If you encounter problems, please"
- ewarn "adjust your USE flags to install only the 32-bit version and reinstall:"
- ewarn " ${CATEGORY}/$PN[+32bit -64bit]"
- fi
- else
- oldabi="${ABI}"
- ABI="x86"
- local FLASH_SOURCE="${ROOT}/usr/$(get_libdir)/${PLUGINS_DIR}/libflashplayer.so"
-
- einfo "nspluginwrapper detected: Installing plugin wrapper"
- nspluginwrapper -i "${FLASH_SOURCE}"
-
- ABI="${oldabi}"
- fi
- elif [[ ! $native_install ]]; then
- einfo "To use the 32-bit flash player in a native 64-bit firefox,"
- einfo "you must install www-plugins/nspluginwrapper"
- fi
- fi
-
- ewarn "Flash player is closed-source, and this version has a known major"
- ewarn "security vulnerability[1]. Please consider only running flash applets"
- ewarn "you know to be safe. The 'flashblock' extension may help for"
- ewarn "mozilla users:"
- ewarn " https://addons.mozilla.org/en-US/firefox/addon/433"
- ewarn
- ewarn "[1] http://www.adobe.com/support/security/advisories/apsa10-01.html"
-}
diff --git a/www-plugins/adobe-flash/adobe-flash-10.1.82.76-r1.ebuild b/www-plugins/adobe-flash/adobe-flash-10.1.82.76-r1.ebuild
deleted file mode 100644
index 57eb9dee5c1e..000000000000
--- a/www-plugins/adobe-flash/adobe-flash-10.1.82.76-r1.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-10.1.82.76-r1.ebuild,v 1.3 2010/08/13 12:47:22 lack Exp $
-
-EAPI=1
-inherit nsplugins rpm multilib toolchain-funcs
-
-MY_32B_URI="http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-${PV}-release.i386.rpm"
-
-DESCRIPTION="Adobe Flash Player"
-SRC_URI="${MY_32B_URI}"
-HOMEPAGE="http://www.adobe.com/"
-IUSE="multilib nspluginwrapper"
-SLOT="0"
-
-KEYWORDS="-* ~amd64 ~x86"
-LICENSE="AdobeFlash-10.1"
-RESTRICT="strip mirror"
-
-S="${WORKDIR}"
-
-NATIVE_DEPS="x11-libs/gtk+:2
- media-libs/fontconfig
- dev-libs/nss
- net-misc/curl
- >=sys-libs/glibc-2.4"
-
-EMUL_DEPS=">=app-emulation/emul-linux-x86-gtklibs-20100409-r1
- app-emulation/emul-linux-x86-soundlibs"
-
-RDEPEND="x86? ( $NATIVE_DEPS )
- amd64? ( $EMUL_DEPS )
- || ( media-fonts/liberation-fonts media-fonts/corefonts )"
-DEPEND="nspluginwrapper? ( www-plugins/nspluginwrapper )"
-
-# Where should this all go? (Bug #328639)
-INSTALL_BASE="opt/Adobe/flash-player"
-
-# Ignore QA warnings in these binary closed-source libraries, since we can't fix
-# them:
-QA_EXECSTACK="${INSTALL_BASE}32/libflashplayer.so
- ${INSTALL_BASE}/libflashplayer.so"
-
-QA_DT_HASH="${INSTALL_BASE}32/libflashplayer.so
- ${INSTALL_BASE}/libflashplayer.so"
-
-pkg_setup() {
- if use x86; then
- export native_install=1
- elif use amd64; then
- # As of 10.1, no more native 64b version *grumble grumble*
- unset native_install
- unset need_lahf_wrapper
- export amd64_32bit=1
- fi
-}
-
-src_compile() {
- if [[ $need_lahf_wrapper ]]; then
- # This experimental wrapper, from Maks Verver via bug #268336 should
- # emulate the missing lahf instruction affected platforms.
- $(tc-getCC) -fPIC -shared -nostdlib -lc -oflashplugin-lahf-fix.so \
- "${FILESDIR}/flashplugin-lahf-fix.c" \
- || die "Compile of flashplugin-lahf-fix.so failed"
- fi
-}
-
-src_install() {
- if [[ $native_install ]]; then
- # 32b RPM has things hidden in funny places
- use x86 && pushd "${S}/usr/lib/flash-plugin"
-
- exeinto /${INSTALL_BASE}
- doexe libflashplayer.so
- inst_plugin /${INSTALL_BASE}/libflashplayer.so
-
- use x86 && popd
-
- # 64b tarball has no readme file.
- use x86 && dodoc "${S}/usr/share/doc/flash-plugin-${PV}/readme.txt"
- fi
-
- if [[ $need_lahf_wrapper ]]; then
- # This experimental wrapper, from Maks Verver via bug #268336 should
- # emulate the missing lahf instruction affected platforms.
- exeinto /${INSTALL_BASE}
- doexe flashplugin-lahf-fix.so
- inst_plugin /${INSTALL_BASE}/flashplugin-lahf-fix.so
- fi
-
- if [[ $amd64_32bit ]]; then
- local oldabi="${ABI}"
- ABI="x86"
-
- # 32b plugin
- pushd "${S}/usr/lib/flash-plugin"
- exeinto /${INSTALL_BASE}32
- doexe libflashplayer.so
- inst_plugin /${INSTALL_BASE}32/libflashplayer.so
- dodoc "${S}/usr/share/doc/flash-plugin-${PV}/readme.txt"
- popd
-
- ABI="${oldabi}"
- fi
-
- # The magic config file!
- insinto "/etc/adobe"
- doins "${FILESDIR}/mms.cfg"
-}
-
-pkg_postinst() {
- if use amd64; then
- elog "Adobe has released 10.1 in only a 32-bit version and upgrading"
- elog "is required to close a major security vulnerability:"
- elog " http://bugs.gentoo.org/322855"
- elog
- if has_version 'www-plugins/nspluginwrapper'; then
- if [[ $native_install ]]; then
- # Note: This code branch is dead (no native 64-bit flash player
- # available yet for 10.1), but I'm keeping it around in the hope
- # that some day it will be back...
- # - Jim Ramsay <lack@gentoo.org>
-
- # TODO: Perhaps parse the output of 'nspluginwrapper -l'
- # However, the 64b flash plugin makes
- # 'nspluginwrapper -l' segfault.
- local FLASH_WRAPPER="${ROOT}/usr/lib64/nsbrowser/plugins/npwrapper.libflashplayer.so"
- if [[ -f ${FLASH_WRAPPER} ]]; then
- einfo "Removing duplicate 32-bit plugin wrapper: Native 64-bit plugin installed"
- nspluginwrapper -r "${FLASH_WRAPPER}"
- fi
- if [[ $need_lahf_wrapper ]]; then
- ewarn "Your processor does not support the 'lahf' instruction which is used"
- ewarn "by Adobe's 64-bit flash binary. We have installed a wrapper which"
- ewarn "should allow this plugin to run. If you encounter problems, please"
- ewarn "adjust your USE flags to install only the 32-bit version and reinstall:"
- ewarn " ${CATEGORY}/$PN[+32bit -64bit]"
- elog
- fi
- else
- einfo "nspluginwrapper detected: Installing plugin wrapper"
- local oldabi="${ABI}"
- ABI="x86"
- local FLASH_SOURCE="${ROOT}/${INSTALL_BASE}32/libflashplayer.so"
- nspluginwrapper -i "${FLASH_SOURCE}"
- ABI="${oldabi}"
- ewarn "Using adobe-flash-10.1 in a 64-bit browser is unstable:"
- ewarn " http://bugs.gentoo.org/324365"
- ewarn "The recommended configuration is to use the 32-bit plugin"
- ewarn "in a 32-bit browser such as www-client/firefox-bin"
- elog
- fi
- elif [[ ! $native_install ]]; then
- elog "To use the 32-bit flash player in a native 64-bit firefox,"
- elog "you must install www-plugins/nspluginwrapper, though this"
- elog "configuration is not recommended:"
- elog " http://bugs.gentoo.org/324365"
- elog
- fi
- fi
-
- ewarn "Flash player is closed-source, with a long history of security"
- ewarn "issues. Please consider only running flash applets you know to"
- ewarn "be safe. The 'flashblock' extension may help for mozilla users:"
- ewarn " https://addons.mozilla.org/en-US/firefox/addon/433"
-}
diff --git a/www-plugins/adobe-flash/adobe-flash-10.1.82.76.ebuild b/www-plugins/adobe-flash/adobe-flash-10.1.82.76.ebuild
deleted file mode 100644
index 5046dc65668f..000000000000
--- a/www-plugins/adobe-flash/adobe-flash-10.1.82.76.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-10.1.82.76.ebuild,v 1.3 2010/08/12 02:27:32 phajdan.jr Exp $
-
-EAPI=1
-inherit nsplugins rpm multilib toolchain-funcs
-
-MY_32B_URI="http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-${PV}-release.i386.rpm"
-
-DESCRIPTION="Adobe Flash Player"
-SRC_URI="${MY_32B_URI}"
-HOMEPAGE="http://www.adobe.com/"
-IUSE="multilib"
-SLOT="0"
-
-KEYWORDS="-* amd64 x86"
-LICENSE="AdobeFlash-10.1"
-RESTRICT="strip mirror"
-
-S="${WORKDIR}"
-
-NATIVE_DEPS="x11-libs/gtk+:2
- media-libs/fontconfig
- dev-libs/nss
- net-misc/curl
- >=sys-libs/glibc-2.4"
-
-EMUL_DEPS=">=app-emulation/emul-linux-x86-gtklibs-20100409-r1
- app-emulation/emul-linux-x86-soundlibs"
-
-RDEPEND="x86? ( $NATIVE_DEPS )
- amd64? ( $EMUL_DEPS )
- || ( media-fonts/liberation-fonts media-fonts/corefonts )"
-
-# Where should this all go? (Bug #328639)
-INSTALL_BASE="opt/Adobe/flash-player"
-
-# Ignore QA warnings in these binary closed-source libraries, since we can't fix
-# them:
-QA_EXECSTACK="${INSTALL_BASE}32/libflashplayer.so
- ${INSTALL_BASE}/libflashplayer.so"
-
-QA_DT_HASH="${INSTALL_BASE}32/libflashplayer.so
- ${INSTALL_BASE}/libflashplayer.so"
-
-pkg_setup() {
- if use x86; then
- export native_install=1
- elif use amd64; then
- # As of 10.1, no more native 64b version *grumble grumble*
- unset native_install
- unset need_lahf_wrapper
- export amd64_32bit=1
- fi
-}
-
-src_compile() {
- if [[ $need_lahf_wrapper ]]; then
- # This experimental wrapper, from Maks Verver via bug #268336 should
- # emulate the missing lahf instruction affected platforms.
- $(tc-getCC) -fPIC -shared -nostdlib -lc -oflashplugin-lahf-fix.so \
- "${FILESDIR}/flashplugin-lahf-fix.c" \
- || die "Compile of flashplugin-lahf-fix.so failed"
- fi
-}
-
-src_install() {
- if [[ $native_install ]]; then
- # 32b RPM has things hidden in funny places
- use x86 && pushd "${S}/usr/lib/flash-plugin"
-
- exeinto /${INSTALL_BASE}
- doexe libflashplayer.so
- inst_plugin /${INSTALL_BASE}/libflashplayer.so
-
- use x86 && popd
-
- # 64b tarball has no readme file.
- use x86 && dodoc "${S}/usr/share/doc/flash-plugin-${PV}/readme.txt"
- fi
-
- if [[ $need_lahf_wrapper ]]; then
- # This experimental wrapper, from Maks Verver via bug #268336 should
- # emulate the missing lahf instruction affected platforms.
- exeinto /${INSTALL_BASE}
- doexe flashplugin-lahf-fix.so
- inst_plugin /${INSTALL_BASE}/flashplugin-lahf-fix.so
- fi
-
- if [[ $amd64_32bit ]]; then
- oldabi="${ABI}"
- ABI="x86"
-
- # 32b plugin
- pushd "${S}/usr/lib/flash-plugin"
- exeinto /${INSTALL_BASE}32
- doexe libflashplayer.so
- inst_plugin /${INSTALL_BASE}32/libflashplayer.so
- dodoc "${S}/usr/share/doc/flash-plugin-${PV}/readme.txt"
- popd
-
- ABI="${oldabi}"
- fi
-
- # The magic config file!
- insinto "/etc/adobe"
- doins "${FILESDIR}/mms.cfg"
-}
-
-pkg_postinst() {
- if use amd64; then
- elog "Adobe has released 10.1 in only a 32-bit version and upgrading"
- elog "is required to close a major security vulnerability:"
- elog " http://bugs.gentoo.org/322855"
- elog
- elog "Furthermore, there are stability problems when running 10.1 in a"
- elog "64-bit browser with nspluginwrapper. The current recommended"
- elog "configuration is to use a 32-bit browser such as"
- elog "www-client/firefox-bin:"
- elog " http://bugs.gentoo.org/324365"
- elog
- # Temporarily skip automatic nspluginwrapper stuff, since it is fraught
- # with peril (Bug #324365):
- #
- #if has_version 'www-plugins/nspluginwrapper'; then
- # if [[ $native_install ]]; then
- # # TODO: Perhaps parse the output of 'nspluginwrapper -l'
- # # However, the 64b flash plugin makes 'nspluginwrapper -l' segfault.
- # local FLASH_WRAPPER="${ROOT}/usr/lib64/nsbrowser/plugins/npwrapper.libflashplayer.so"
- # if [[ -f ${FLASH_WRAPPER} ]]; then
- # einfo "Removing duplicate 32-bit plugin wrapper: Native 64-bit plugin installed"
- # nspluginwrapper -r "${FLASH_WRAPPER}"
- # fi
- # if [[ $need_lahf_wrapper ]]; then
- # ewarn "Your processor does not support the 'lahf' instruction which is used"
- # ewarn "by Adobe's 64-bit flash binary. We have installed a wrapper which"
- # ewarn "should allow this plugin to run. If you encounter problems, please"
- # ewarn "adjust your USE flags to install only the 32-bit version and reinstall:"
- # ewarn " ${CATEGORY}/$PN[+32bit -64bit]"
- # fi
- # else
- # oldabi="${ABI}"
- # ABI="x86"
- # local FLASH_SOURCE="${ROOT}/usr/$(get_libdir)/${PLUGINS_DIR}/libflashplayer.so"
- #
- # einfo "nspluginwrapper detected: Installing plugin wrapper"
- # nspluginwrapper -i "${FLASH_SOURCE}"
- #
- # ABI="${oldabi}"
- # fi
- #elif [[ ! $native_install ]]; then
- # einfo "To use the 32-bit flash player in a native 64-bit firefox,"
- # einfo "you must install www-plugins/nspluginwrapper"
- #fi
- fi
-
- ewarn "Flash player is closed-source, with a long history of security"
- ewarn "issues. Please consider only running flash applets you know to"
- ewarn "be safe. The 'flashblock' extension may help for mozilla users:"
- ewarn " https://addons.mozilla.org/en-US/firefox/addon/433"
-}
diff --git a/www-plugins/adobe-flash/adobe-flash-10.1.85.3.ebuild b/www-plugins/adobe-flash/adobe-flash-10.1.85.3.ebuild
index a8c570e34695..c0b971b7be9a 100644
--- a/www-plugins/adobe-flash/adobe-flash-10.1.85.3.ebuild
+++ b/www-plugins/adobe-flash/adobe-flash-10.1.85.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-10.1.85.3.ebuild,v 1.3 2010/10/13 11:29:43 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-10.1.85.3.ebuild,v 1.4 2010/10/13 16:44:36 lack Exp $
EAPI=1
inherit nsplugins rpm multilib toolchain-funcs
@@ -28,10 +28,11 @@ NATIVE_DEPS="x11-libs/gtk+:2
EMUL_DEPS=">=app-emulation/emul-linux-x86-gtklibs-20100409-r1
app-emulation/emul-linux-x86-soundlibs"
+DEPEND="nspluginwrapper? ( www-plugins/nspluginwrapper )"
RDEPEND="x86? ( $NATIVE_DEPS )
amd64? ( $EMUL_DEPS )
- || ( media-fonts/liberation-fonts media-fonts/corefonts )"
-DEPEND="nspluginwrapper? ( www-plugins/nspluginwrapper )"
+ || ( media-fonts/liberation-fonts media-fonts/corefonts )
+ ${DEPEND}"
# Where should this all go? (Bug #328639)
INSTALL_BASE="opt/Adobe/flash-player"