summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-13 19:47:57 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-13 19:47:57 +0000
commitd710cdbab5cb573244ea82ae62efd58df27aef23 (patch)
tree6b72ba1f04b13ad4f191d64b9abe5fca20130336 /www-plugins/lightspark
parentAdded the new armv4t-nanjit patch to stable xulrunner as well. (diff)
downloadgentoo-2-d710cdbab5cb573244ea82ae62efd58df27aef23.tar.gz
gentoo-2-d710cdbab5cb573244ea82ae62efd58df27aef23.tar.bz2
gentoo-2-d710cdbab5cb573244ea82ae62efd58df27aef23.zip
Add patch to respect LDFLAGS. Bug #332115. Thanks to Diego E. 'Flameeyes' Pettenò <flameeyes@gentoo.org> for reporting
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/lightspark')
-rw-r--r--www-plugins/lightspark/ChangeLog7
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.3-cmakelists.patch44
-rw-r--r--www-plugins/lightspark/lightspark-0.4.3.ebuild6
3 files changed, 55 insertions, 2 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 4a3cf0cbd64b..16627bce9160 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.13 2010/08/12 10:03:42 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.14 2010/08/13 19:47:56 hwoarang Exp $
+
+ 13 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ lightspark-0.4.3.ebuild, +files/lightspark-0.4.3-cmakelists.patch:
+ Add patch to respect LDFLAGS. Bug #332115. Thanks to Diego E. 'Flameeyes'
+ Pettenò <flameeyes@gentoo.org> for reporting
*lightspark-0.4.3 (12 Aug 2010)
diff --git a/www-plugins/lightspark/files/lightspark-0.4.3-cmakelists.patch b/www-plugins/lightspark/files/lightspark-0.4.3-cmakelists.patch
new file mode 100644
index 000000000000..f0f585dd580b
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.4.3-cmakelists.patch
@@ -0,0 +1,44 @@
+Index: lightspark-0.4.3/CMakeLists.txt
+===================================================================
+--- lightspark-0.4.3.orig/CMakeLists.txt
++++ lightspark-0.4.3/CMakeLists.txt
+@@ -199,7 +199,7 @@ ENDIF(${i386})
+ # liblightspark.so target
+ ADD_LIBRARY(spark SHARED ${LIBSPARK_SOURCES})
+ SET_TARGET_PROPERTIES(spark PROPERTIES OUTPUT_NAME lightspark)
+-TARGET_LINK_LIBRARIES(spark ${SOUND_LIBS_LIBRARIES} ${EXTRA_LIBS_LIBRARIES} ${ZLIB_LIBRARIES} ${LLVM_LIBS_CORE} ${LLVM_LIBS_JIT} ${SDL_LIBRARY} ${OPTIONAL_LIBRARIES} ${GTK_LIBRARIES} ${lib_glew})
++TARGET_LINK_LIBRARIES(spark ${CMAKE_MODULE_LINKER_FLAGS} ${SOUND_LIBS_LIBRARIES} ${EXTRA_LIBS_LIBRARIES} ${ZLIB_LIBRARIES} ${LLVM_LIBS_CORE} ${LLVM_LIBS_JIT} ${SDL_LIBRARY} ${OPTIONAL_LIBRARIES} ${GTK_LIBRARIES} ${lib_glew})
+ SET_TARGET_PROPERTIES(spark PROPERTIES LINK_FLAGS "${LLVM_LDFLAGS} -Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/lightspark.expmap")
+ SET_TARGET_PROPERTIES(spark PROPERTIES LINK_INTERFACE_LIBRARIES "")
+
+@@ -214,7 +214,7 @@ ENDIF(UNIX)
+ IF(COMPILE_LIGHTSPARK)
+ ADD_EXECUTABLE(lightspark main.cpp)
+ TARGET_LINK_LIBRARIES(lightspark spark)
+- TARGET_LINK_LIBRARIES(lightspark ${SDL_LIBRARY})
++ TARGET_LINK_LIBRARIES(lightspark ${SDL_LIBRARY} ${CMAKE_MODULE_LINKER_FLAGS})
+
+ IF(UNIX)
+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lightspark.frag DESTINATION ${DATADIR}/lightspark)
+@@ -227,7 +227,7 @@ ENDIF(COMPILE_LIGHTSPARK)
+ # tightspark executable target
+ IF(COMPILE_TIGHTSPARK)
+ ADD_EXECUTABLE(tightspark tightspark.cpp)
+- TARGET_LINK_LIBRARIES(tightspark spark)
++ TARGET_LINK_LIBRARIES(tightspark spark ${CMAKE_MODULE_LINKER_FLAGS})
+
+ IF(UNIX)
+ INSTALL(TARGETS tightspark RUNTIME DESTINATION ${BINDIR})
+Index: lightspark-0.4.3/plugin-dir/CMakeLists.txt
+===================================================================
+--- lightspark-0.4.3.orig/plugin-dir/CMakeLists.txt
++++ lightspark-0.4.3/plugin-dir/CMakeLists.txt
+@@ -31,7 +31,7 @@ ENDIF(UNIX)
+
+ # Firefox plugin target
+ ADD_LIBRARY(lightsparkplugin SHARED np_entry.cpp npn_gate.cpp npp_gate.cpp plugin.cpp)
+-TARGET_LINK_LIBRARIES(lightsparkplugin spark ${MOZ_PLUGIN_LIBRARIES} ${GTK_LIBRARIES})
++TARGET_LINK_LIBRARIES(lightsparkplugin spark ${CMAKE_MODULE_LINKER_FLAGS} ${MOZ_PLUGIN_LIBRARIES} ${GTK_LIBRARIES})
+
+ IF(UNIX)
+ INSTALL(TARGETS lightsparkplugin LIBRARY DESTINATION ${PLUGIN_DIRECTORY})
diff --git a/www-plugins/lightspark/lightspark-0.4.3.ebuild b/www-plugins/lightspark/lightspark-0.4.3.ebuild
index b62634fd317e..695161c4f4a0 100644
--- a/www-plugins/lightspark/lightspark-0.4.3.ebuild
+++ b/www-plugins/lightspark/lightspark-0.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.3.ebuild,v 1.1 2010/08/12 10:03:42 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.3.ebuild,v 1.2 2010/08/13 19:47:56 hwoarang Exp $
EAPI=3
inherit cmake-utils nsplugins multilib
@@ -41,6 +41,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P/_rc*/}
+PATCHES=(
+ "${FILESDIR}"/${P}-cmakelists.patch
+)
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use nsplugin COMPILE_PLUGIN)