summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-03-20 22:08:23 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-03-20 22:08:23 +0000
commit5923095705e49786e2fb6555a42a4cebbf9ce721 (patch)
tree2499a88beac086d0faafaabc5ec8009270b3c899 /www-plugins/lightspark
parentAdd >=lightspark-0.4.6.1 to package.mask (diff)
downloadgentoo-2-5923095705e49786e2fb6555a42a4cebbf9ce721.tar.gz
gentoo-2-5923095705e49786e2fb6555a42a4cebbf9ce721.tar.bz2
gentoo-2-5923095705e49786e2fb6555a42a4cebbf9ce721.zip
Version bump, bug #359291
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/lightspark')
-rw-r--r--www-plugins/lightspark/ChangeLog8
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.6.1-cmakelists.patch30
-rw-r--r--www-plugins/lightspark/lightspark-0.4.6.1.ebuild81
3 files changed, 118 insertions, 1 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 15c4f88ebe0d..76f7f846d25f 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.25 2011/02/13 15:16:22 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.26 2011/03/20 22:08:23 chithanh Exp $
+
+*lightspark-0.4.6.1 (20 Mar 2011)
+
+ 20 Mar 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +lightspark-0.4.6.1.ebuild, +files/lightspark-0.4.6.1-cmakelists.patch:
+ Version bump, bug #359291
*lightspark-0.4.5.2 (13 Feb 2011)
diff --git a/www-plugins/lightspark/files/lightspark-0.4.6.1-cmakelists.patch b/www-plugins/lightspark/files/lightspark-0.4.6.1-cmakelists.patch
new file mode 100644
index 000000000000..cc260b626c72
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.4.6.1-cmakelists.patch
@@ -0,0 +1,30 @@
+diff -ur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2010-12-16 06:28:01.000000000 +0100
++++ b/CMakeLists.txt 2010-12-21 14:59:17.500027007 +0100
+@@ -332,7 +332,7 @@
+ ${Boost_LIBRARIES} ${LLVM_LIBS_CORE} ${LLVM_LIBS_JIT} ${SDL_LIBRARY}
+ ${OPTIONAL_LIBRARIES} ${GTK_LIBRARIES} ${FREETYPE_LIBRARIES}
+ ${OPENGL_LIBRARIES} ${FTGL_LIBRARIES} ${GLEW_LIBRARIES} ${PCRE_LIBRARIES}
+- ${Threads_LIBRARIES} ${XMLPP_LIBRARIES} ${CMAKE_DL_LIBS})
++ ${Threads_LIBRARIES} ${XMLPP_LIBRARIES} ${CMAKE_DL_LIBS} ${CMAKE_MODULE_LINKER_FLAGS})
+ SET_TARGET_PROPERTIES(spark PROPERTIES VERSION "${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}")
+ SET_TARGET_PROPERTIES(spark PROPERTIES SOVERSION "${MAJOR_VERSION}.${MINOR_VERSION}")
+
+@@ -344,7 +344,7 @@
+ IF(COMPILE_LIGHTSPARK)
+ ADD_EXECUTABLE(lightspark main.cpp)
+ TARGET_LINK_LIBRARIES(lightspark spark)
+- TARGET_LINK_LIBRARIES(lightspark ${SDL_LIBRARY} ${Boost_LIBRARIES})
++ TARGET_LINK_LIBRARIES(lightspark ${SDL_LIBRARY} ${Boost_LIBRARIES} ${CMAKE_MODULE_LINKER_FLAGS})
+
+ IF(UNIX)
+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lightspark.frag DESTINATION ${DATADIR}/lightspark)
+@@ -359,7 +359,7 @@
+ IF(COMPILE_TIGHTSPARK)
+ ADD_EXECUTABLE(tightspark tightspark.cpp)
+ TARGET_LINK_LIBRARIES(tightspark spark)
+- TARGET_LINK_LIBRARIES(tightspark ${Boost_LIBRARIES})
++ TARGET_LINK_LIBRARIES(tightspark ${Boost_LIBRARIES} ${CMAKE_MODULE_LINKER_FLAGS})
+
+ IF(UNIX)
+ INSTALL(TARGETS tightspark RUNTIME DESTINATION ${BINDIR})
diff --git a/www-plugins/lightspark/lightspark-0.4.6.1.ebuild b/www-plugins/lightspark/lightspark-0.4.6.1.ebuild
new file mode 100644
index 000000000000..de796606530c
--- /dev/null
+++ b/www-plugins/lightspark/lightspark-0.4.6.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.6.1.ebuild,v 1.1 2011/03/20 22:08:23 chithanh Exp $
+
+EAPI=3
+inherit cmake-utils nsplugins multilib versionator
+
+DESCRIPTION="High performance flash player"
+HOMEPAGE="http://lightspark.sourceforge.net/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PN}-$(get_version_component_range 1-3)/+download/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nsplugin pulseaudio"
+
+RDEPEND=">=dev-cpp/libxmlpp-2.33.1:2.6
+ >=dev-libs/boost-1.42
+ dev-libs/libpcre[cxx]
+ media-fonts/liberation-fonts
+ media-video/ffmpeg
+ media-libs/fontconfig
+ media-libs/ftgl
+ >=media-libs/glew-1.5.3
+ media-libs/libsdl
+ pulseaudio? (
+ media-sound/pulseaudio
+ )
+ net-misc/curl
+ >=sys-devel/gcc-4.4
+ >=sys-devel/llvm-2.8-r2
+ virtual/opengl
+ nsplugin? (
+ dev-libs/nspr
+ net-libs/xulrunner
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ )
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${P/_rc*/}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.6.1-cmakelists.patch
+ "${FILESDIR}"/${PN}-0.4.5-allow-disabling-pulseaudio.patch
+)
+
+src_configure() {
+ local audiobackends
+ use pulseaudio && audiobackends=pulse
+
+ local mycmakeargs=(
+ $(cmake-utils_use nsplugin COMPILE_PLUGIN)
+ -DAUDIO_BACKEND="${audiobackends}"
+ -DPLUGIN_DIRECTORY=/usr/$(get_libdir)/${PN}/plugins
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use nsplugin && inst_plugin /usr/$(get_libdir)/${PN}/plugins/liblightsparkplugin.so
+}
+
+pkg_postinst() {
+ if use nsplugin && ! has_version www-plugins/gnash; then
+ elog "Lightspark now supports gnash fallback for its browser plugin."
+ elog "Install www-plugins/gnash to take advantage of it."
+ fi
+ if use nsplugin && has_version www-plugins/gnash[nsplugin]; then
+ elog "Having two plugins installed for the same MIME type may confuse"
+ elog "Mozilla based browsers. It is recommended to disable the nsplugin"
+ elog "USE flag for either gnash or lightspark. For details, see"
+ elog "https://bugzilla.mozilla.org/show_bug.cgi?id=581848"
+ fi
+}