summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-05-20 12:59:17 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-05-20 12:59:17 +0000
commita4e579d5e080b8ec6f4e062d2eb87cf3136f82f3 (patch)
treefcd14f9b39f2bd1bbc9458066406cc25c0043892 /www-misc/reflector
parentVersion bump, bug #367791 thank Jeroen Roovers and Andrew Savchenko for repor... (diff)
downloadgentoo-2-a4e579d5e080b8ec6f4e062d2eb87cf3136f82f3.tar.gz
gentoo-2-a4e579d5e080b8ec6f4e062d2eb87cf3136f82f3.tar.bz2
gentoo-2-a4e579d5e080b8ec6f4e062d2eb87cf3136f82f3.zip
Fix python eclass usage: reflector doesn't work on <=python-2.5 and the Reflector class was not being optimized. Bug #367259.
(Portage version: 2.2.0_alpha31-r1/cvs/Linux x86_64)
Diffstat (limited to 'www-misc/reflector')
-rw-r--r--www-misc/reflector/ChangeLog7
-rw-r--r--www-misc/reflector/reflector-2011.05.13.1.ebuild8
2 files changed, 12 insertions, 3 deletions
diff --git a/www-misc/reflector/ChangeLog b/www-misc/reflector/ChangeLog
index 2a6a9af01aeb..cf39c744284a 100644
--- a/www-misc/reflector/ChangeLog
+++ b/www-misc/reflector/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-misc/reflector
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/reflector/ChangeLog,v 1.1 2011/05/13 18:28:19 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/reflector/ChangeLog,v 1.2 2011/05/20 12:59:17 binki Exp $
+
+ 20 May 2011; Nathan Phillip Brink <binki@gentoo.org>
+ reflector-2011.05.13.1.ebuild:
+ Fix python eclass usage: reflector doesn't work on <=python-2.5 and the
+ Reflector class was not being optimized. Bug #367259.
*reflector-2011.05.13.1 (13 May 2011)
diff --git a/www-misc/reflector/reflector-2011.05.13.1.ebuild b/www-misc/reflector/reflector-2011.05.13.1.ebuild
index 08eb80964956..b366962c9961 100644
--- a/www-misc/reflector/reflector-2011.05.13.1.ebuild
+++ b/www-misc/reflector/reflector-2011.05.13.1.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/reflector/reflector-2011.05.13.1.ebuild,v 1.1 2011/05/13 18:28:19 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/reflector/reflector-2011.05.13.1.ebuild,v 1.2 2011/05/20 12:59:17 binki Exp $
EAPI=3
DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES=1
-PYTHON_DEPEND="*"
+PYTHON_DEPEND="*:2.6"
+RESTRICT_PYTHON_ABIS="2.[45]"
SUPPORT_PYTHON_ABIS=1
+
inherit eutils distutils
DESCRIPTION="archlinux's take on mirrorselect"
@@ -22,6 +24,8 @@ RDEPEND="dev-python/argparse"
S=${WORKDIR}/${PN}
+PYTHON_MODNAME="Reflector.py"
+
src_prepare() {
distutils_src_prepare