summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2015-07-29 20:14:14 +0000
committerIan Stakenvicius <axs@gentoo.org>2015-07-29 20:14:14 +0000
commitd6160f7bcd140393143f03ef5db6a0ce6f5bdfa6 (patch)
tree2d0ee2efad13cb6608434d44d67e2abc3fca3889 /www-client
parentKeyworded for *-solaris, *-macos (diff)
downloadgentoo-2-d6160f7bcd140393143f03ef5db6a0ce6f5bdfa6.tar.gz
gentoo-2-d6160f7bcd140393143f03ef5db6a0ce6f5bdfa6.tar.bz2
gentoo-2-d6160f7bcd140393143f03ef5db6a0ce6f5bdfa6.zip
Fix syntax errors causing hppa build failures (bug 556196)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 009C547C2B6559ED!)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/ChangeLog7
-rw-r--r--www-client/firefox/files/firefox-38-hppa-js-syntax-error.patch30
-rw-r--r--www-client/firefox/firefox-38.1.0.ebuild3
-rw-r--r--www-client/firefox/firefox-39.0.ebuild3
4 files changed, 40 insertions, 3 deletions
diff --git a/www-client/firefox/ChangeLog b/www-client/firefox/ChangeLog
index f480398d9a49..e11c2ab8b74d 100644
--- a/www-client/firefox/ChangeLog
+++ b/www-client/firefox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/firefox
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/ChangeLog,v 1.432 2015/07/29 14:10:24 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/ChangeLog,v 1.433 2015/07/29 20:14:14 axs Exp $
+
+ 29 Jul 2015; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +files/firefox-38-hppa-js-syntax-error.patch, firefox-38.1.0.ebuild,
+ firefox-39.0.ebuild:
+ Fix syntax errors causing hppa build failures (bug 556196)
29 Jul 2015; Mikle Kolyada <zlogene@gentoo.org> firefox-38.1.0.ebuild:
amd64 stable wrt bug #555416
diff --git a/www-client/firefox/files/firefox-38-hppa-js-syntax-error.patch b/www-client/firefox/files/firefox-38-hppa-js-syntax-error.patch
new file mode 100644
index 000000000000..719732e6ec0a
--- /dev/null
+++ b/www-client/firefox/files/firefox-38-hppa-js-syntax-error.patch
@@ -0,0 +1,30 @@
+# HG changeset patch
+# User Ian Stakenvicius <axs@gentoo.org>
+# Parent 2ee9895e032c492705adaf213706d4260ca172c8
+Fix JS_CHECK_STACK_SIZE define for stack-growing-up case (hppa)
+
+Upstream bug 1189011
+Gentoo bug 556196
+
+diff --git a/js/src/jsfriendapi.h b/js/src/jsfriendapi.h
+--- a/js/src/jsfriendapi.h
++++ b/js/src/jsfriendapi.h
+@@ -15,17 +15,17 @@
+ #include "jsbytecode.h"
+ #include "jspubtd.h"
+
+ #include "js/CallArgs.h"
+ #include "js/CallNonGenericMethod.h"
+ #include "js/Class.h"
+
+ #if JS_STACK_GROWTH_DIRECTION > 0
+-# define JS_CHECK_STACK_SIZE(limit, sp) (MOZ_LIKELY(((uintptr_t)(sp) < (limit)))
++# define JS_CHECK_STACK_SIZE(limit, sp) (MOZ_LIKELY((uintptr_t)(sp) < (limit)))
+ #else
+ # define JS_CHECK_STACK_SIZE(limit, sp) (MOZ_LIKELY((uintptr_t)(sp) > (limit)))
+ #endif
+
+ class JSAtom;
+ struct JSErrorFormatString;
+ class JSLinearString;
+ struct JSJitInfo;
diff --git a/www-client/firefox/firefox-38.1.0.ebuild b/www-client/firefox/firefox-38.1.0.ebuild
index 8ad1e4916832..f9dbb5e1be86 100644
--- a/www-client/firefox/firefox-38.1.0.ebuild
+++ b/www-client/firefox/firefox-38.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-38.1.0.ebuild,v 1.3 2015/07/29 14:10:24 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-38.1.0.ebuild,v 1.4 2015/07/29 20:14:14 axs Exp $
EAPI="5"
VIRTUALX_REQUIRED="pgo"
@@ -145,6 +145,7 @@ src_prepare() {
EPATCH_SUFFIX="patch" \
EPATCH_FORCE="yes" \
epatch "${WORKDIR}/firefox"
+ epatch "${FILESDIR}"/${PN}-38-hppa-js-syntax-error.patch #556196
# Allow user to apply any additional patches without modifing ebuild
epatch_user
diff --git a/www-client/firefox/firefox-39.0.ebuild b/www-client/firefox/firefox-39.0.ebuild
index 0c3a1196a0c0..2b2077605460 100644
--- a/www-client/firefox/firefox-39.0.ebuild
+++ b/www-client/firefox/firefox-39.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-39.0.ebuild,v 1.1 2015/07/07 17:59:46 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-39.0.ebuild,v 1.2 2015/07/29 20:14:14 axs Exp $
EAPI="5"
VIRTUALX_REQUIRED="pgo"
@@ -146,6 +146,7 @@ src_prepare() {
EPATCH_FORCE="yes" \
EPATCH_EXCLUDE="8010_bug114311-freetype26.patch" \
epatch "${WORKDIR}/firefox"
+ epatch "${WORKDIR}"/${PN}-38-hppa-js-syntax-error.patch
# Allow user to apply any additional patches without modifing ebuild
epatch_user