summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2012-08-13 07:11:05 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2012-08-13 07:11:05 +0000
commitd011a0d2f792c26fc7435d5003a10326e34f27fb (patch)
treed1497d622391a04ee74d86f66481e4ece7d1155f /www-client
parentx86 stable, see bug 418699 (diff)
downloadgentoo-2-d011a0d2f792c26fc7435d5003a10326e34f27fb.tar.gz
gentoo-2-d011a0d2f792c26fc7435d5003a10326e34f27fb.tar.bz2
gentoo-2-d011a0d2f792c26fc7435d5003a10326e34f27fb.zip
Use system libwebp. Link gsettings directly instead of using dlopen. Remove old.
(Portage version: 2.1.11.9/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog12
-rw-r--r--www-client/chromium/chromium-21.0.1180.77-r1.ebuild (renamed from www-client/chromium/chromium-21.0.1180.57.ebuild)14
-rw-r--r--www-client/chromium/chromium-22.0.1229.2-r1.ebuild (renamed from www-client/chromium/chromium-22.0.1221.1.ebuild)16
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild12
4 files changed, 37 insertions, 17 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 2c3e415d03e2..bd5e3620e135 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.689 2012/08/10 03:30:56 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.690 2012/08/13 07:11:05 phajdan.jr Exp $
+
+*chromium-22.0.1229.2-r1 (13 Aug 2012)
+*chromium-21.0.1180.77-r1 (13 Aug 2012)
+
+ 13 Aug 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ -chromium-21.0.1180.57.ebuild, +chromium-21.0.1180.77-r1.ebuild,
+ -chromium-22.0.1221.1.ebuild, +chromium-22.0.1229.2-r1.ebuild,
+ chromium-9999-r1.ebuild:
+ Use system libwebp. Link gsettings directly instead of using dlopen. Remove
+ old.
*chromium-22.0.1229.2 (10 Aug 2012)
*chromium-21.0.1180.77 (10 Aug 2012)
diff --git a/www-client/chromium/chromium-21.0.1180.57.ebuild b/www-client/chromium/chromium-21.0.1180.77-r1.ebuild
index 8eb6f909a3e9..572d9476c0c3 100644
--- a/www-client/chromium/chromium-21.0.1180.57.ebuild
+++ b/www-client/chromium/chromium-21.0.1180.77-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-21.0.1180.57.ebuild,v 1.4 2012/08/03 11:41:52 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-21.0.1180.77-r1.ebuild,v 1.1 2012/08/13 07:11:05 phajdan.jr Exp $
EAPI="4"
PYTHON_DEPEND="2:2.6"
@@ -18,7 +18,7 @@ SRC_URI="http://commondatastorage.googleapis.com/chromium-browser-official/${P}.
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="bindist cups gnome gnome-keyring kerberos pulseaudio selinux"
RDEPEND="app-arch/bzip2
@@ -41,6 +41,7 @@ RDEPEND="app-arch/bzip2
media-libs/flac
>=media-libs/libjpeg-turbo-1.2.0-r1
media-libs/libpng
+ >=media-libs/libwebp-0.2.0_rc1
media-libs/speex
pulseaudio? ( media-sound/pulseaudio )
sys-fs/udev
@@ -138,7 +139,6 @@ src_prepare() {
\! -path 'third_party/libsrtp/*' \
\! -path 'third_party/libusb/libusb.h' \
\! -path 'third_party/libvpx/*' \
- \! -path 'third_party/libwebp/*' \
\! -path 'third_party/libxml/chromium/*' \
\! -path 'third_party/libyuv/*' \
\! -path 'third_party/lss/*' \
@@ -208,8 +208,6 @@ src_configure() {
# TODO: use_system_ssl (http://crbug.com/58087).
# TODO: use_system_sqlite (http://crbug.com/22208).
# TODO: use_system_vpx
- # TODO: use_system_webp (https://chromiumcodereview.appspot.com/10496016
- # needs to become part of webp release)
myconf+="
-Duse_system_bzip2=1
-Duse_system_flac=1
@@ -218,6 +216,7 @@ src_configure() {
-Duse_system_libjpeg=1
-Duse_system_libpng=1
-Duse_system_libusb=1
+ -Duse_system_libwebp=1
-Duse_system_libxml=1
-Duse_system_speex=1
-Duse_system_v8=1
@@ -236,6 +235,11 @@ src_configure() {
$(gyp_use pulseaudio)
$(gyp_use selinux selinux)"
+ # Use explicit library dependencies instead of dlopen.
+ # This makes breakages easier to detect by revdep-rebuild.
+ myconf+="
+ -Dlinux_link_gsettings=1"
+
if ! use selinux; then
# Enable SUID sandbox.
myconf+="
diff --git a/www-client/chromium/chromium-22.0.1221.1.ebuild b/www-client/chromium/chromium-22.0.1229.2-r1.ebuild
index b06705350bf0..833f8870e49e 100644
--- a/www-client/chromium/chromium-22.0.1221.1.ebuild
+++ b/www-client/chromium/chromium-22.0.1229.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-22.0.1221.1.ebuild,v 1.1 2012/08/02 22:52:35 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-22.0.1229.2-r1.ebuild,v 1.1 2012/08/13 07:11:05 phajdan.jr Exp $
EAPI="4"
PYTHON_DEPEND="2:2.6"
@@ -41,6 +41,7 @@ RDEPEND="app-arch/bzip2
media-libs/flac
>=media-libs/libjpeg-turbo-1.2.0-r1
media-libs/libpng
+ >=media-libs/libwebp-0.2.0_rc1
media-libs/speex
pulseaudio? ( media-sound/pulseaudio )
sys-fs/udev
@@ -112,9 +113,6 @@ src_prepare() {
# Fix build without NaCl glibc toolchain.
epatch "${FILESDIR}/${PN}-ppapi-r0.patch"
- # Bug 427438.
- epatch "${FILESDIR}/${PN}-bison-2.6-r0.patch"
-
epatch_user
# Remove most bundled libraries. Some are still needed.
@@ -140,7 +138,6 @@ src_prepare() {
\! -path 'third_party/libusb/libusb.h' \
\! -path 'third_party/libva/*' \
\! -path 'third_party/libvpx/*' \
- \! -path 'third_party/libwebp/*' \
\! -path 'third_party/libxml/chromium/*' \
\! -path 'third_party/libXNVCtrl/*' \
\! -path 'third_party/libyuv/*' \
@@ -153,6 +150,7 @@ src_prepare() {
\! -path 'third_party/ots/*' \
\! -path 'third_party/protobuf/*' \
\! -path 'third_party/qcms/*' \
+ \! -path 'third_party/re2/*' \
\! -path 'third_party/scons-2.0.1/*' \
\! -path 'third_party/sfntly/*' \
\! -path 'third_party/skia/*' \
@@ -212,8 +210,6 @@ src_configure() {
# TODO: use_system_ssl (http://crbug.com/58087).
# TODO: use_system_sqlite (http://crbug.com/22208).
# TODO: use_system_vpx
- # TODO: use_system_webp (https://chromiumcodereview.appspot.com/10496016
- # needs to become part of webp release)
myconf+="
-Duse_system_bzip2=1
-Duse_system_flac=1
@@ -222,6 +218,7 @@ src_configure() {
-Duse_system_libjpeg=1
-Duse_system_libpng=1
-Duse_system_libusb=1
+ -Duse_system_libwebp=1
-Duse_system_libxml=1
-Duse_system_speex=1
-Duse_system_v8=1
@@ -240,6 +237,11 @@ src_configure() {
$(gyp_use pulseaudio)
$(gyp_use selinux selinux)"
+ # Use explicit library dependencies instead of dlopen.
+ # This makes breakages easier to detect by revdep-rebuild.
+ myconf+="
+ -Dlinux_link_gsettings=1"
+
if ! use selinux; then
# Enable SUID sandbox.
myconf+="
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index 7153245382d1..9f442d942bf8 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.126 2012/08/08 02:20:41 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.127 2012/08/13 07:11:05 phajdan.jr Exp $
EAPI="4"
PYTHON_DEPEND="2:2.6"
@@ -41,6 +41,7 @@ RDEPEND="app-arch/bzip2
media-libs/flac
>=media-libs/libjpeg-turbo-1.2.0-r1
media-libs/libpng
+ >=media-libs/libwebp-0.2.0_rc1
media-libs/speex
pulseaudio? ( media-sound/pulseaudio )
sys-fs/udev
@@ -192,7 +193,6 @@ src_prepare() {
\! -path 'third_party/libusb/libusb.h' \
\! -path 'third_party/libva/*' \
\! -path 'third_party/libvpx/*' \
- \! -path 'third_party/libwebp/*' \
\! -path 'third_party/libxml/chromium/*' \
\! -path 'third_party/libXNVCtrl/*' \
\! -path 'third_party/libyuv/*' \
@@ -265,8 +265,6 @@ src_configure() {
# TODO: use_system_ssl (http://crbug.com/58087).
# TODO: use_system_sqlite (http://crbug.com/22208).
# TODO: use_system_vpx
- # TODO: use_system_webp (https://chromiumcodereview.appspot.com/10496016
- # needs to become part of webp release)
myconf+="
-Duse_system_bzip2=1
-Duse_system_flac=1
@@ -275,6 +273,7 @@ src_configure() {
-Duse_system_libjpeg=1
-Duse_system_libpng=1
-Duse_system_libusb=1
+ -Duse_system_libwebp=1
-Duse_system_libxml=1
-Duse_system_speex=1
-Duse_system_v8=1
@@ -293,6 +292,11 @@ src_configure() {
$(gyp_use pulseaudio)
$(gyp_use selinux selinux)"
+ # Use explicit library dependencies instead of dlopen.
+ # This makes breakages easier to detect by revdep-rebuild.
+ myconf+="
+ -Dlinux_link_gsettings=1"
+
if ! use selinux; then
# Enable SUID sandbox.
myconf+="