summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2013-02-02 04:51:17 +0000
committerAlex Alexander <wired@gentoo.org>2013-02-02 04:51:17 +0000
commitc2c917cb92305bb690aa5789f9c08b5b3d0130d2 (patch)
tree404ba2bc59ed8791a47c8844cb364f3d3447998a /www-client
parentversion bump (diff)
downloadgentoo-2-c2c917cb92305bb690aa5789f9c08b5b3d0130d2.tar.gz
gentoo-2-c2c917cb92305bb690aa5789f9c08b5b3d0130d2.tar.bz2
gentoo-2-c2c917cb92305bb690aa5789f9c08b5b3d0130d2.zip
version bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/uget/ChangeLog9
-rw-r--r--www-client/uget/uget-1.10.3.ebuild82
2 files changed, 89 insertions, 2 deletions
diff --git a/www-client/uget/ChangeLog b/www-client/uget/ChangeLog
index 36c73df8b541..fcaf24952d98 100644
--- a/www-client/uget/ChangeLog
+++ b/www-client/uget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/uget
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uget/ChangeLog,v 1.34 2012/12/02 17:09:06 eva Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/uget/ChangeLog,v 1.35 2013/02/02 04:51:17 wired Exp $
+
+*uget-1.10.3 (02 Feb 2013)
+
+ 02 Feb 2013; Alex Alexander <wired@gentoo.org> +uget-1.10.3.ebuild:
+ version bump
02 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org> uget-1.8.0.ebuild,
uget-1.10.2.ebuild, uget-9999.ebuild:
diff --git a/www-client/uget/uget-1.10.3.ebuild b/www-client/uget/uget-1.10.3.ebuild
new file mode 100644
index 000000000000..e46cbcd70f8b
--- /dev/null
+++ b/www-client/uget/uget-1.10.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/uget/uget-1.10.3.ebuild,v 1.1 2013/02/02 04:51:17 wired Exp $
+
+EAPI="4"
+
+IUSE="aria2 +curl gstreamer hide-temp-files libnotify nls"
+if [[ ${PV} == *9999* ]]; then
+ inherit autotools git-2
+ KEYWORDS=""
+ SRC_URI=""
+ EGIT_REPO_URI="git://urlget.git.sourceforge.net/gitroot/urlget/uget"
+else
+ KEYWORDS="~amd64 ~ppc ~x86"
+ SRC_URI="mirror://sourceforge/urlget/${P}.tar.gz"
+fi
+
+DESCRIPTION="Download manager using gtk+ and libcurl"
+HOMEPAGE="http://urlget.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+REQUIRED_USE="|| ( aria2 curl )"
+
+RDEPEND="
+ dev-libs/libpcre
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.4:3
+ curl? ( >=net-misc/curl-7.10 )
+ gstreamer? ( media-libs/gstreamer:0.10 )
+ libnotify? ( x11-libs/libnotify )
+ "
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ if [[ ${PV} == *9999* ]]; then
+ eautoreconf
+ intltoolize || die "intltoolize failed"
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf $(use_enable nls) \
+ $(use_enable curl plugin-curl) \
+ $(use_enable aria2 plugin-aria2) \
+ $(use_enable gstreamer) \
+ $(use_enable hide-temp-files hidden) \
+ $(use_enable libnotify notify)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # the build system forgets this :p
+ dobin uget-cmd/uget-cmd
+
+ if [[ ${PV} == *9999* ]]; then
+ dodoc AUTHORS ChangeLog README
+ else
+ dodoc AUTHORS ChangeLog NEWS README
+ fi
+}
+
+pkg_postinst() {
+ if use aria2; then
+ echo
+ elog "You've enabled the aria2 USE flag, so the aria2 plug-in has been"
+ elog "built. This allows you to control a local or remote instance of aria2"
+ elog "through xmlrpc. To use aria2 locally you have to emerge"
+ elog "net-misc/aria2 with the xmlrpc USE enabled manually."
+ echo
+ fi
+}