summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-09-10 23:08:04 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-09-10 23:08:04 +0000
commit75b240e4c0faa6ea63dc50a72c07225a4d4f61ba (patch)
treea51e26fedf5991a09789a5d98ef78970954dffff /www-client
parentKeyworded ~ia64 (diff)
downloadgentoo-2-75b240e4c0faa6ea63dc50a72c07225a4d4f61ba.tar.gz
gentoo-2-75b240e4c0faa6ea63dc50a72c07225a4d4f61ba.tar.bz2
gentoo-2-75b240e4c0faa6ea63dc50a72c07225a4d4f61ba.zip
Version bump, bug #145979. Add patch to fix linking with --as-needed by
drizzt@gufi.org, bug #144130. Security cleanup, bug #140556. (Portage version: 2.1.1)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/dillo/ChangeLog9
-rw-r--r--www-client/dillo/dillo-0.8.6.ebuild135
-rw-r--r--www-client/dillo/files/digest-dillo-0.8.5-r14
-rw-r--r--www-client/dillo/files/digest-dillo-0.8.5-r24
-rw-r--r--www-client/dillo/files/digest-dillo-0.8.5-r32
-rw-r--r--www-client/dillo/files/digest-dillo-0.8.69
-rw-r--r--www-client/dillo/files/dillo-asneeded.patch63
7 files changed, 223 insertions, 3 deletions
diff --git a/www-client/dillo/ChangeLog b/www-client/dillo/ChangeLog
index db94833daaad..88f6641de02c 100644
--- a/www-client/dillo/ChangeLog
+++ b/www-client/dillo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/dillo
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.45 2006/03/24 12:46:13 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.46 2006/09/10 23:08:04 exg Exp $
+
+*dillo-0.8.6 (10 Sep 2006)
+
+ 10 Sep 2006; Emanuele Giaquinta <exg@gentoo.org>
+ +files/dillo-asneeded.patch, -dillo-0.7.3-r7.ebuild, +dillo-0.8.6.ebuild:
+ Version bump, bug #145979. Add patch to fix linking with --as-needed by
+ drizzt@gufi.org, bug #144130. Security cleanup, bug #140556.
*dillo-0.8.5-r3 (24 Mar 2006)
diff --git a/www-client/dillo/dillo-0.8.6.ebuild b/www-client/dillo/dillo-0.8.6.ebuild
new file mode 100644
index 000000000000..242d5c28938f
--- /dev/null
+++ b/www-client/dillo/dillo-0.8.6.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-0.8.6.ebuild,v 1.1 2006/09/10 23:08:04 exg Exp $
+
+inherit flag-o-matic eutils
+
+S2=${WORKDIR}/dillo-gentoo-extras-patch4
+DILLO_I18N_P="${P}-i18n-misc-20060625"
+
+DESCRIPTION="Lean GTK+-based web browser"
+HOMEPAGE="http://www.dillo.org/"
+SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
+ mirror://gentoo/dillo-gentoo-extras-patch4.tar.bz2
+ http://teki.jpn.ph/pc/software/${DILLO_I18N_P}.diff.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+MISC_IUSE="nls truetype"
+IUSE="${MISC_IUSE} ipv6 ssl"
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/libpng-1.2.1
+ ssl? ( dev-libs/openssl )"
+DEPEND="sys-devel/autoconf
+ sys-devel/automake
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ../${DILLO_I18N_P}.diff || die
+ epatch "${FILESDIR}"/${PN}-asneeded.patch
+ sh autogen.sh || die
+
+ if [ "${DILLO_ICONSET}" = "kde" ]
+ then
+ einfo "Using Konqueror style icon set"
+ cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "gnome" ]
+ then
+ einfo "Using Ximian style icon set"
+ cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "mozilla" ]
+ then
+ einfo "Using Netscape style icon set"
+ cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "cobalt" ]
+ then
+ einfo "Using Cobalt style icon set"
+ cp ${S2}/pixmaps.cobalt.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "bold" ]
+ then
+ einfo "Using bold style icon set"
+ cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "trans" ]
+ then
+ einfo "Using transparent style icon set"
+ cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "trad" ]
+ then
+ einfo "Using the traditional icon set"
+ cp ${S2}/pixmaps.trad.h ${S}/src/pixmaps.h
+ else
+ einfo "Using default Dillo icon set"
+ fi
+}
+
+src_compile() {
+ replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
+ append-flags "-O"
+
+ local myconf
+
+ # misc features
+ myconf="$(use_enable nls)
+ $(use_enable truetype anti-alias)
+ --disable-gtktest
+ --disable-dlgui
+ --enable-tabs
+ --enable-meta-refresh"
+
+ myconf="${myconf}
+ $(use_enable ipv6)
+ $(use_enable ssl)"
+
+ econf ${myconf} || die
+ emake -j1 || die
+}
+
+src_install() {
+ dodir /etc /usr/share/icons/${PN}
+ make DESTDIR=${D} install || die
+
+ dosed /etc/dpidrc
+
+ dodoc AUTHORS COPYING ChangeLog* INSTALL README NEWS
+ docinto doc
+ dodoc doc/*.txt doc/README
+
+ cp ${S2}/icons/*.png ${D}/usr/share/icons/${PN}
+}
+
+pkg_postinst() {
+ einfo "This ebuild for dillo comes with different toolbar icons"
+ einfo "If you want mozilla style icons then try"
+ einfo " DILLO_ICONSET=\"mozilla\" emerge dillo"
+ einfo
+ einfo "If you prefer konqueror style icons then try"
+ einfo " DILLO_ICONSET=\"kde\" emerge dillo"
+ einfo
+ einfo "If you prefer ximian gnome style icons then try"
+ einfo " DILLO_ICONSET=\"gnome\" emerge dillo"
+ einfo
+ einfo "If you prefer cobalt style icons then try"
+ einfo " DILLO_ICONSET=\"cobalt\" emerge dillo"
+ einfo
+ einfo "If you prefer bold style icons then try"
+ einfo " DILLO_ICONSET=\"bold\" emerge dillo"
+ einfo
+ einfo "If you prefer transparent style icons then try"
+ einfo " DILLO_ICONSET=\"trans\" emerge dillo"
+ einfo
+ einfo "If you prefer the traditional icons then try"
+ einfo " DILLO_ICONSET=\"trad\" emerge dillo"
+ einfo
+ einfo "If the DILLO_ICONSET variable is not set, you will get the"
+ einfo "default iconset"
+ einfo
+ einfo "To see what the icons look like, please point your browser to:"
+ einfo "http://dillo.auriga.wearlab.de/Icons/"
+ einfo
+}
diff --git a/www-client/dillo/files/digest-dillo-0.8.5-r1 b/www-client/dillo/files/digest-dillo-0.8.5-r1
index 39b8ed6a85b9..5eae53a9ab74 100644
--- a/www-client/dillo/files/digest-dillo-0.8.5-r1
+++ b/www-client/dillo/files/digest-dillo-0.8.5-r1
@@ -1,3 +1,5 @@
+MD5 dfe4b882f2424d5eb4f9bc526df7019c dillo-0.8.5-i18n-misc-20050620.diff.bz2 244152
MD5 d0ab7fa1d40b310deb891388604188f8 dillo-0.8.5.tar.bz2 424795
MD5 0d0bc7cdd39dc66b80280f73d74bfeaf dillo-gentoo-extras-patch4.tar.bz2 98800
-MD5 dfe4b882f2424d5eb4f9bc526df7019c dillo-0.8.5-i18n-misc-20050620.diff.bz2 244152
+RMD160 2c04bf1b7f2763e748e2fc4d6848e0d82f680525 dillo-gentoo-extras-patch4.tar.bz2 98800
+SHA256 25871b318ffc046eebe9be100f5d1027e649b94dd4d3e0bfb36ec6d139cded05 dillo-gentoo-extras-patch4.tar.bz2 98800
diff --git a/www-client/dillo/files/digest-dillo-0.8.5-r2 b/www-client/dillo/files/digest-dillo-0.8.5-r2
index 73bbdd1a1a25..74f1f4cc6bc6 100644
--- a/www-client/dillo/files/digest-dillo-0.8.5-r2
+++ b/www-client/dillo/files/digest-dillo-0.8.5-r2
@@ -1,3 +1,5 @@
+MD5 b4191226e7e3e5f1a6bf7e43004e26da dillo-0.8.5-i18n-misc-20051010.diff.bz2 247058
MD5 d0ab7fa1d40b310deb891388604188f8 dillo-0.8.5.tar.bz2 424795
MD5 0d0bc7cdd39dc66b80280f73d74bfeaf dillo-gentoo-extras-patch4.tar.bz2 98800
-MD5 b4191226e7e3e5f1a6bf7e43004e26da dillo-0.8.5-i18n-misc-20051010.diff.bz2 247058
+RMD160 2c04bf1b7f2763e748e2fc4d6848e0d82f680525 dillo-gentoo-extras-patch4.tar.bz2 98800
+SHA256 25871b318ffc046eebe9be100f5d1027e649b94dd4d3e0bfb36ec6d139cded05 dillo-gentoo-extras-patch4.tar.bz2 98800
diff --git a/www-client/dillo/files/digest-dillo-0.8.5-r3 b/www-client/dillo/files/digest-dillo-0.8.5-r3
index 23ecbc8772bf..dcb761aee813 100644
--- a/www-client/dillo/files/digest-dillo-0.8.5-r3
+++ b/www-client/dillo/files/digest-dillo-0.8.5-r3
@@ -1,3 +1,5 @@
MD5 fabc2fa5a657701a23930c510d001a95 dillo-0.8.5-i18n-misc-20060104.diff.bz2 248425
MD5 d0ab7fa1d40b310deb891388604188f8 dillo-0.8.5.tar.bz2 424795
MD5 0d0bc7cdd39dc66b80280f73d74bfeaf dillo-gentoo-extras-patch4.tar.bz2 98800
+RMD160 2c04bf1b7f2763e748e2fc4d6848e0d82f680525 dillo-gentoo-extras-patch4.tar.bz2 98800
+SHA256 25871b318ffc046eebe9be100f5d1027e649b94dd4d3e0bfb36ec6d139cded05 dillo-gentoo-extras-patch4.tar.bz2 98800
diff --git a/www-client/dillo/files/digest-dillo-0.8.6 b/www-client/dillo/files/digest-dillo-0.8.6
new file mode 100644
index 000000000000..93004cf40dba
--- /dev/null
+++ b/www-client/dillo/files/digest-dillo-0.8.6
@@ -0,0 +1,9 @@
+MD5 16464a819242822c4d76d78de2d8c7bc dillo-0.8.6-i18n-misc-20060625.diff.bz2 258290
+RMD160 b158236c62f80d7df1273863ef958704fdd7e340 dillo-0.8.6-i18n-misc-20060625.diff.bz2 258290
+SHA256 872accdc2828eb564f4e30d9471e0c52ce48d957a196d1671cd3067b7a454de3 dillo-0.8.6-i18n-misc-20060625.diff.bz2 258290
+MD5 b65233d368bbd265a55effcf2c17f84b dillo-0.8.6.tar.bz2 441739
+RMD160 062cff85b330a5b443ddc81a356e81f930677cbb dillo-0.8.6.tar.bz2 441739
+SHA256 47e695a5d370eb656f5e41eeb917ad6281b1559bf60172c9eca89b5518a9f9b9 dillo-0.8.6.tar.bz2 441739
+MD5 0d0bc7cdd39dc66b80280f73d74bfeaf dillo-gentoo-extras-patch4.tar.bz2 98800
+RMD160 2c04bf1b7f2763e748e2fc4d6848e0d82f680525 dillo-gentoo-extras-patch4.tar.bz2 98800
+SHA256 25871b318ffc046eebe9be100f5d1027e649b94dd4d3e0bfb36ec6d139cded05 dillo-gentoo-extras-patch4.tar.bz2 98800
diff --git a/www-client/dillo/files/dillo-asneeded.patch b/www-client/dillo/files/dillo-asneeded.patch
new file mode 100644
index 000000000000..2fd89db76849
--- /dev/null
+++ b/www-client/dillo/files/dillo-asneeded.patch
@@ -0,0 +1,63 @@
+--- configure.in.old 2006-08-18 14:05:40.000000000 +0200
++++ configure.in 2006-08-18 14:05:17.000000000 +0200
+@@ -52,10 +52,10 @@
+ dnl
+ ALL_LINGUAS="ja zh_CN zh_TW"
+ AM_GNU_GETTEXT([external])
+-LDFLAGS="$LDFLAGS $INTLLIBS"
++LIBS="$LIBS $INTLLIBS"
+ AC_CHECK_LIB(iconv, iconv, haslibiconv=yes, haslibiconv=no)
+ if test "x$haslibiconv" = "xyes"; then
+- LDFLAGS="$LDFLAGS $LIBICONV"
++ LIBS="$LIBS $LIBICONV"
+ fi
+ localedir='${prefix}/share/locale'
+ AC_SUBST(localedir)
+@@ -311,10 +311,10 @@
+
+ *)
+ AC_MSG_CHECKING(whether threads work with -pthread)
+- LDSAVEFLAGS=$LDFLAGS
+- LDFLAGS="$LDFLAGS -pthread"
++ LIBSSAVE=$LIBS
++ LIBS="$LIBS -pthread"
+ AC_TRY_LINK_FUNC(pthread_create, pthread_ok=yes, pthread_ok=no)
+- LDFLAGS=$LDSAVEFLAGS
++ LIBS=$LIBSSAVE
+
+ if test "x$pthread_ok" = "xyes"; then
+ AC_MSG_RESULT(yes)
+@@ -349,20 +349,20 @@
+ case $target in
+ *-*-solaris*)
+ AC_MSG_CHECKING(whether SunOS has -lrt )
+- LDSAVEFLAGS="$LDFLAGS"
+- LDFLAGS="$LDFLAGS -lrt"
++ LIBSSAVE="$LIBS"
++ LIBS="$LIBS -lrt"
+ AC_TRY_LINK_FUNC(nanosleep, rt_ok=yes, rt_ok=no)
+ if test "x$rt_ok" = "xyes"; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ AC_MSG_CHECKING(whether SunOS has -lposix4 )
+- LDFLAGS="$LDSAVEFLAGS -lposix4"
++ LIBS="$LIBSSAVE -lposix4"
+ AC_TRY_LINK_FUNC(nanosleep, posix_ok=yes, posix_ok=no)
+ if test "x$posix_ok" = "xyes"; then
+ AC_MSG_RESULT(yes)
+ else
+- LDFLAGS=$LDSAVEFLAGS
++ LIBS=$LIBSSAVE
+ AC_MSG_RESULT(no)
+ AC_MSG_WARN([*** Try setting LIBS or LDFLAGS manually to point to the library with nanosleep()***])
+ fi
+@@ -406,7 +406,7 @@
+ fi
+ else
+ CFLAGS="$CFLAGS `$XFT_CONFIG --cflags`"
+- LDFLAGS="$LDFLAGS `$XFT_CONFIG --libs`"
++ LIBS="$LIBS `$XFT_CONFIG --libs`"
+ fi
+ fi
+ if test "x$enable_cookies" = "xno" ; then