summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-13 22:03:23 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-13 22:03:23 +0000
commit12e2e2b74ab80e6347b510b08841beda7914c093 (patch)
tree541d9a4870ad4af055a308a40a870936c25bc05b /www-client
parentBump alpha branch (diff)
downloadgentoo-2-12e2e2b74ab80e6347b510b08841beda7914c093.tar.gz
gentoo-2-12e2e2b74ab80e6347b510b08841beda7914c093.tar.bz2
gentoo-2-12e2e2b74ab80e6347b510b08841beda7914c093.zip
New snapshot, fixes bug 497024. Assign default for MOZ_PLUGIN_PATH in wrapper script, fixes bug 497070. Thanks to Jauhien Piatlicki <piatlicki@gmail.com>.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/conkeror/ChangeLog9
-rw-r--r--www-client/conkeror/conkeror-1.0_pre20140212.ebuild59
-rw-r--r--www-client/conkeror/files/conkeror-r2.sh14
3 files changed, 81 insertions, 1 deletions
diff --git a/www-client/conkeror/ChangeLog b/www-client/conkeror/ChangeLog
index 38e39a406dc9..79b37eee80d7 100644
--- a/www-client/conkeror/ChangeLog
+++ b/www-client/conkeror/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/conkeror
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/ChangeLog,v 1.38 2014/01/04 22:28:16 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/ChangeLog,v 1.39 2014/02/13 22:03:23 ulm Exp $
+
+*conkeror-1.0_pre20140212 (13 Feb 2014)
+
+ 13 Feb 2014; Ulrich Müller <ulm@gentoo.org>
+ +conkeror-1.0_pre20140212.ebuild, +files/conkeror-r2.sh:
+ New snapshot, fixes bug 497024. Assign default for MOZ_PLUGIN_PATH in wrapper
+ script, fixes bug 497070. Thanks to Jauhien Piatlicki <piatlicki@gmail.com>.
04 Jan 2014; Ulrich Müller <ulm@gentoo.org> conkeror-1.0_pre20120223.ebuild,
-conkeror-1.0_pre20130711.ebuild, conkeror-1.0_pre20131017.ebuild:
diff --git a/www-client/conkeror/conkeror-1.0_pre20140212.ebuild b/www-client/conkeror/conkeror-1.0_pre20140212.ebuild
new file mode 100644
index 000000000000..b2d2f2dbcd6c
--- /dev/null
+++ b/www-client/conkeror/conkeror-1.0_pre20140212.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/conkeror-1.0_pre20140212.ebuild,v 1.1 2014/02/13 22:03:23 ulm Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs fdo-mime
+
+DESCRIPTION="A Mozilla-based web browser whose design is inspired by GNU Emacs"
+HOMEPAGE="http://conkeror.org/"
+# snapshot from http://repo.or.cz/w/conkeror.git
+# conkeror.png is derived from http://commons.wikimedia.org/wiki/File:Conker.jpg
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.gz
+ http://dev.gentoo.org/~ulm/distfiles/${PN}.png"
+
+# CC-BY-SA-3.0 for conkeror.png
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 ) CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="|| ( >=www-client/firefox-5.0 >=www-client/firefox-bin-23.0 )"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cp "${DISTDIR}/${PN}.png" . || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r branding chrome components content defaults help locale modules \
+ search-engines style tests
+ doins application.ini *.manifest Info.plist
+
+ exeinto /usr/libexec/${PN}
+ doexe conkeror-spawn-helper
+ dosym ../../libexec/${PN}/conkeror-spawn-helper \
+ /usr/share/${PN}/conkeror-spawn-helper
+
+ newbin "${FILESDIR}/conkeror-r2.sh" conkeror
+ domenu "${FILESDIR}/conkeror.desktop"
+ doicon "${WORKDIR}/conkeror.png"
+
+ doman contrib/man/conkeror.1
+ dodoc CREDITS
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/www-client/conkeror/files/conkeror-r2.sh b/www-client/conkeror/files/conkeror-r2.sh
new file mode 100644
index 000000000000..9b46d5bb0c07
--- /dev/null
+++ b/www-client/conkeror/files/conkeror-r2.sh
@@ -0,0 +1,14 @@
+#!/bin/bash
+# Wrapper script for conkeror
+
+for cmd in firefox firefox-bin; do
+ xr=$(type -p ${cmd})
+ if [[ -n ${xr} ]]; then
+ : ${MOZ_PLUGIN_PATH:=/usr/lib/nsbrowser/plugins} #497070
+ export MOZ_PLUGIN_PATH
+ exec "${xr}" -app /usr/share/conkeror/application.ini "$@"
+ fi
+done
+
+echo "$0: firefox required, but not found." >&2
+exit 1