summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-05-31 15:56:15 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-05-31 15:56:15 +0000
commite5efd2e312836fc1d97c5d9df1cac2770d403f23 (patch)
treee08d69bdb0050fb66c782f355a1e8455ef311fc3 /www-client/w3m
parentStable for HPPA (bug #171107). (diff)
downloadgentoo-2-e5efd2e312836fc1d97c5d9df1cac2770d403f23.tar.gz
gentoo-2-e5efd2e312836fc1d97c5d9df1cac2770d403f23.tar.bz2
gentoo-2-e5efd2e312836fc1d97c5d9df1cac2770d403f23.zip
Version bumped.
(Portage version: 2.1.2.7)
Diffstat (limited to 'www-client/w3m')
-rw-r--r--www-client/w3m/ChangeLog8
-rw-r--r--www-client/w3m/files/digest-w3m-0.5.23
-rw-r--r--www-client/w3m/w3m-0.5.2.ebuild109
3 files changed, 119 insertions, 1 deletions
diff --git a/www-client/w3m/ChangeLog b/www-client/w3m/ChangeLog
index 20b5d5752763..f783c95b63fa 100644
--- a/www-client/w3m/ChangeLog
+++ b/www-client/w3m/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/w3m
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/w3m/ChangeLog,v 1.32 2007/02/18 10:12:47 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/w3m/ChangeLog,v 1.33 2007/05/31 15:56:15 matsuu Exp $
+
+*w3m-0.5.2 (31 May 2007)
+
+ 31 May 2007; MATSUU Takuto <matsuu@gentoo.org> +w3m-0.5.2.ebuild:
+ Version bumped.
+ Clean up ebuild.
18 Feb 2007; Fabian Groffen <grobian@gentoo.org> w3m-0.5.1-r4.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/www-client/w3m/files/digest-w3m-0.5.2 b/www-client/w3m/files/digest-w3m-0.5.2
new file mode 100644
index 000000000000..8abdf183948a
--- /dev/null
+++ b/www-client/w3m/files/digest-w3m-0.5.2
@@ -0,0 +1,3 @@
+MD5 ba06992d3207666ed1bf2dcf7c72bf58 w3m-0.5.2.tar.gz 1906812
+RMD160 09ce72d8ef5e621a2e49496b63e22f2773edbe79 w3m-0.5.2.tar.gz 1906812
+SHA256 5ff3e5a1f50a4a8e6ddbfdeefbe13d3a7f63538595a8e29f5da504ea46eda646 w3m-0.5.2.tar.gz 1906812
diff --git a/www-client/w3m/w3m-0.5.2.ebuild b/www-client/w3m/w3m-0.5.2.ebuild
new file mode 100644
index 000000000000..b051c07f9354
--- /dev/null
+++ b/www-client/w3m/w3m-0.5.2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/w3m/w3m-0.5.2.ebuild,v 1.1 2007/05/31 15:56:15 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Text based WWW browser, supports tables and frames"
+HOMEPAGE="http://w3m.sourceforge.net/
+ http://www.page.sannet.ne.jp/knabe/w3m/w3m.html"
+PATCH_PATH="http://www.page.sannet.ne.jp/knabe/w3m/"
+SRC_URI="mirror://sourceforge/w3m/${P}.tar.gz"
+
+LICENSE="w3m"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X fbcon gpm gtk imlib lynxkeymap migemo nls nntp ssl unicode xface linguas_ja"
+
+# We cannot build w3m with gtk+2 w/o X because gtk+2 ebuild doesn't
+# allow us to build w/o X, so we have to give up framebuffer w3mimg....
+DEPEND=">=sys-libs/ncurses-5.2-r3
+ >=sys-libs/zlib-1.1.3-r2
+ >=dev-libs/boehm-gc-6.2
+ X? ( x11-libs/libXext x11-libs/libXdmcp )
+ gtk? ( >=x11-libs/gtk+-2 )
+ !gtk? ( imlib? ( >=media-libs/imlib2-1.1.0 ) )
+ xface? ( media-libs/compface )
+ gpm? ( >=sys-libs/gpm-1.19.3-r5 )
+ migemo? ( >=app-text/migemo-0.40 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+PROVIDE="virtual/w3m"
+
+src_compile() {
+
+ local myconf migemo_command imagelibval imageval
+
+ if use gtk ; then
+ imagelibval="gtk2"
+ elif use imlib ; then
+ imagelibval="imlib2"
+ fi
+
+ if [ ! -z "${imagelibval}" ] ; then
+ use X && imageval="${imageval}${imageval:+,}x11"
+ use X && use fbcon && imageval="${imageval}${imageval:+,}fb"
+ fi
+
+ if use migemo ; then
+ migemo_command="migemo -t egrep /usr/share/migemo/migemo-dict"
+ else
+ migemo_command="no"
+ fi
+
+ # emacs-w3m doesn't like "--enable-m17n --disable-unicode,"
+ # so we better enable or disable both. Default to enable
+ # m17n and unicode, see bug #47046.
+ if use linguas_ja ; then
+ if use unicode ; then
+ myconf="${myconf} --enable-japanese=U"
+ else
+ myconf="${myconf} --enable-japanese=E"
+ fi
+ elif use unicode ; then
+ myconf="${myconf} --with-charset=UTF-8"
+ else
+ myconf="${myconf} --with-charset=US-ASCII"
+ fi
+
+ # lynxkeymap IUSE flag. bug #49397
+ if use lynxkeymap ; then
+ myconf="${myconf} --enable-keymap=lynx"
+ else
+ myconf="${myconf} --enable-keymap=w3m"
+ fi
+
+ econf \
+ --with-editor=/usr/bin/vi \
+ --with-mailer=/bin/mail \
+ --with-browser=/usr/bin/firefox \
+ --with-termlib=curses \
+ --enable-image=${imageval:-no} \
+ --with-imagelib="${imagelibval:-no}" \
+ --with-migemo="${migemo_command}" \
+ --enable-m17n \
+ --enable-unicode \
+ $(use_enable gpm mouse) \
+ $(use_enable nls) \
+ $(use_enable nntp) \
+ $(use_enable ssl digest-auth) \
+ $(use_with ssl) \
+ $(use_enable xface) \
+ ${myconf} || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ insinto /usr/share/${PN}/Bonus
+ doins Bonus/*
+ dodoc README NEWS TODO ChangeLog
+ docinto doc-en ; dodoc doc/*
+ if use linguas_ja ; then
+ docinto doc-jp ; dodoc doc-jp/*
+ else
+ rm -rf "${D}"/usr/share/man/ja
+ fi
+}