summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-08-21 18:59:50 +0000
committerTim Harder <radhermit@gentoo.org>2012-08-21 18:59:50 +0000
commit99bcdc8b6f5078649031c38c283a36a6fe663aaa (patch)
treead1119553e8ff3182e66a428e2f4f6395fe96fab /www-client/vimprobable2/vimprobable2-9999.ebuild
parentStable for HPPA (bug #432018). (diff)
downloadgentoo-2-99bcdc8b6f5078649031c38c283a36a6fe663aaa.tar.gz
gentoo-2-99bcdc8b6f5078649031c38c283a36a6fe663aaa.tar.bz2
gentoo-2-99bcdc8b6f5078649031c38c283a36a6fe663aaa.zip
Initial import. Ebuild by me.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'www-client/vimprobable2/vimprobable2-9999.ebuild')
-rw-r--r--www-client/vimprobable2/vimprobable2-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/www-client/vimprobable2/vimprobable2-9999.ebuild b/www-client/vimprobable2/vimprobable2-9999.ebuild
new file mode 100644
index 000000000000..96dd6be3911b
--- /dev/null
+++ b/www-client/vimprobable2/vimprobable2-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/vimprobable2/vimprobable2-9999.ebuild,v 1.1 2012/08/21 18:59:50 radhermit Exp $
+
+EAPI=4
+
+inherit toolchain-funcs git-2
+
+EGIT_REPO_URI="git://git.code.sf.net/p/vimprobable/code"
+
+DESCRIPTION="A minimal web browser that behaves like the Vimperator plugin for Firefox"
+HOMEPAGE="http://www.vimprobable.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="net-libs/libsoup:2.4
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1 vimprobablerc.5
+}