summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-04-10 23:38:38 +0000
committerAlex Alexander <wired@gentoo.org>2011-04-10 23:38:38 +0000
commite7161ee3dfde378c0e4a11495d96073c7eda9ed1 (patch)
tree6ab263a2b499671c2178693abaddbddd9cfa0056 /www-client/uget
parentUpdated to 1.5 source/target and added performance patch for findbugs. (diff)
downloadgentoo-2-e7161ee3dfde378c0e4a11495d96073c7eda9ed1.tar.gz
gentoo-2-e7161ee3dfde378c0e4a11495d96073c7eda9ed1.tar.bz2
gentoo-2-e7161ee3dfde378c0e4a11495d96073c7eda9ed1.zip
version bump
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'www-client/uget')
-rw-r--r--www-client/uget/ChangeLog7
-rw-r--r--www-client/uget/uget-1.7.4.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/www-client/uget/ChangeLog b/www-client/uget/ChangeLog
index a121970653b7..7d8dc4a8ad2b 100644
--- a/www-client/uget/ChangeLog
+++ b/www-client/uget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/uget
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uget/ChangeLog,v 1.21 2011/03/30 10:56:23 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/uget/ChangeLog,v 1.22 2011/04/10 23:38:38 wired Exp $
+
+*uget-1.7.4 (10 Apr 2011)
+
+ 10 Apr 2011; Alex Alexander <wired@gentoo.org> +uget-1.7.4.ebuild:
+ version bump
30 Mar 2011; Christoph Mende <angelos@gentoo.org> uget-1.7.0.ebuild:
Stable on amd64 wrt bug #360943
diff --git a/www-client/uget/uget-1.7.4.ebuild b/www-client/uget/uget-1.7.4.ebuild
new file mode 100644
index 000000000000..02899dba3896
--- /dev/null
+++ b/www-client/uget/uget-1.7.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/uget/uget-1.7.4.ebuild,v 1.1 2011/04/10 23:38:38 wired Exp $
+
+EAPI="4"
+
+inherit base
+
+DESCRIPTION="Download manager using gtk+ and libcurl"
+HOMEPAGE="http://urlget.sourceforge.net/"
+SRC_URI="mirror://sourceforge/urlget/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="aria2 +curl gstreamer hide-temp-files libnotify nls"
+
+REQUIRED_USE="|| ( aria2 curl )"
+
+RDEPEND="
+ dev-libs/libpcre
+ >=dev-libs/glib-2:2
+ >=x11-libs/gtk+-2.18:2
+ curl? ( >=net-misc/curl-7.10 )
+ gstreamer? ( media-libs/gstreamer )
+ libnotify? ( x11-libs/libnotify )
+ "
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ echo
+ ewarn "Be warned that the configuration file has been split into smaller"
+ ewarn "files in Uget >= 1.5.9 and Uget will not attempt to import your"
+ ewarn "old settings."
+ ewarn
+ ewarn "In other words, you will lose your current download lists."
+ echo
+}
+
+src_configure() {
+ econf $(use_enable nls) \
+ $(use_enable curl plugin-curl) \
+ $(use_enable aria2 plugin-aria2) \
+ $(use_enable gstreamer) \
+ $(use_enable hide-temp-files hidden) \
+ $(use_enable libnotify notify) || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # the build system forgets this :p
+ dobin uget-cmd/uget-cmd || die "uget-cmd install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if use aria2; then
+ echo
+ elog "You've enabled the aria2 USE flag, so the aria2 plug-in has been"
+ elog "built. This allows you to control a local or remote instance of aria2"
+ elog "through xmlrpc. To use aria2 locally you have to emerge"
+ elog "net-misc/aria2 with the xmlrpc USE enabled manually."
+ echo
+ fi
+}