summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-06-26 05:59:53 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-06-26 05:59:53 +0000
commite939c5a79ead10d09d088daad55295a54fb41e40 (patch)
treedc0bde296402fe0a765c20ad049a3b7652154e17 /www-client/firefox/firefox-5.0.ebuild
parentFinally fix the brain-dead configuration checks for libnotify, thanks to detr... (diff)
downloadgentoo-2-e939c5a79ead10d09d088daad55295a54fb41e40.tar.gz
gentoo-2-e939c5a79ead10d09d088daad55295a54fb41e40.tar.bz2
gentoo-2-e939c5a79ead10d09d088daad55295a54fb41e40.zip
Fix bug 372843, and avoid exporting XAUTHORITY as well
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'www-client/firefox/firefox-5.0.ebuild')
-rw-r--r--www-client/firefox/firefox-5.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/www-client/firefox/firefox-5.0.ebuild b/www-client/firefox/firefox-5.0.ebuild
index 0aacdd95647a..f8176cebecde 100644
--- a/www-client/firefox/firefox-5.0.ebuild
+++ b/www-client/firefox/firefox-5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-5.0.ebuild,v 1.2 2011/06/25 14:24:38 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-5.0.ebuild,v 1.3 2011/06/26 05:59:53 nirbheek Exp $
EAPI="3"
VIRTUALX_REQUIRED="pgo"
@@ -123,9 +123,11 @@ pkg_setup() {
# Avoid PGO profiling problems due to enviroment leakage
# These should *always* be cleaned up anyway
unset DBUS_SESSION_BUS_ADDRESS \
- XDG_SESSION_COOKIE \
+ DISPLAY \
ORBIT_SOCKETDIR \
- SESSION_MANAGER
+ SESSION_MANAGER \
+ XDG_SESSION_COOKIE \
+ XAUTHORITY
if ! use bindist ; then
einfo
@@ -183,6 +185,9 @@ src_prepare() {
-i "${S}"/nsprpub/configure{.in,} \
|| die
+ # https://bugs.gentoo.org/372843
+ epatch "${FILESDIR}/${P}-fix-title.patch"
+
eautoreconf
cd js/src