summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2006-10-13 12:59:21 +0000
committerMart Raudsepp <leio@gentoo.org>2006-10-13 12:59:21 +0000
commitc9be46b5d95d164b5e3443145248ce36a9a438f8 (patch)
tree352843f4bbf1ca7e8f6dff73b89a1ab550b9ee73 /www-client/epiphany-extensions
parentUpdate to rel.2. Cleanup. (diff)
downloadgentoo-2-c9be46b5d95d164b5e3443145248ce36a9a438f8.tar.gz
gentoo-2-c9be46b5d95d164b5e3443145248ce36a9a438f8.tar.bz2
gentoo-2-c9be46b5d95d164b5e3443145248ce36a9a438f8.zip
Version bump; correct deps
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'www-client/epiphany-extensions')
-rw-r--r--www-client/epiphany-extensions/ChangeLog8
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-2.16.1.ebuild52
-rw-r--r--www-client/epiphany-extensions/files/digest-epiphany-extensions-2.16.13
3 files changed, 62 insertions, 1 deletions
diff --git a/www-client/epiphany-extensions/ChangeLog b/www-client/epiphany-extensions/ChangeLog
index ce805504b09b..5fea1e779efd 100644
--- a/www-client/epiphany-extensions/ChangeLog
+++ b/www-client/epiphany-extensions/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany-extensions
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.41 2006/10/06 21:46:34 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.42 2006/10/13 12:59:21 leio Exp $
+
+*epiphany-extensions-2.16.1 (13 Oct 2006)
+
+ 13 Oct 2006; Mart Raudsepp <leio@gentoo.org>
+ +epiphany-extensions-2.16.1.ebuild:
+ Version bump; correct deps
06 Oct 2006; Daniel Gryniewicz <dang@gentoo.org>
-files/epiphany-extensions-2.16.0-sessionsaver-v4.patch.gz,
diff --git a/www-client/epiphany-extensions/epiphany-extensions-2.16.1.ebuild b/www-client/epiphany-extensions/epiphany-extensions-2.16.1.ebuild
new file mode 100644
index 000000000000..f6f29fdbf539
--- /dev/null
+++ b/www-client/epiphany-extensions/epiphany-extensions-2.16.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.16.1.ebuild,v 1.1 2006/10/13 12:59:21 leio Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Extensions for the Epiphany web browser"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="debug pcre python"
+
+RDEPEND=">=www-client/epiphany-2.16
+ >=dev-libs/libxml2-2.6
+ >=dev-libs/glib-2.12
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libglade-2
+ app-text/opensp
+ >=www-client/mozilla-firefox-1.0.2-r1
+ pcre? ( >=dev-libs/libpcre-3.9-r2 )
+ >=sys-apps/dbus-0.34
+ python? ( >=dev-lang/python-2.3 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ local extensions="actions auto-reload auto-scroller certificates
+ error-viewer extensions-manager-ui gestures java-console livehttpheaders
+ page-info permissions push-scroller rss sample sample-mozilla
+ select-stylesheet sidebar smart-bookmarks tab-groups tab-states"
+
+ use pcre && extensions="${extensions} greasemonkey adblock"
+
+ use python && extensions="${extensions} python-console sample-python \
+ favicon"
+
+ local list_exts=""
+ for ext in $extensions; do
+ [ "x${list_exts}" != "x" ] && list_exts="${list_exts},"
+ list_exts="${list_exts}${ext}"
+ done
+
+ G2CONF="${G2CONF} --with-extensions=${list_exts} --with-mozilla=firefox"
+}
+
diff --git a/www-client/epiphany-extensions/files/digest-epiphany-extensions-2.16.1 b/www-client/epiphany-extensions/files/digest-epiphany-extensions-2.16.1
new file mode 100644
index 000000000000..30ea03a2358b
--- /dev/null
+++ b/www-client/epiphany-extensions/files/digest-epiphany-extensions-2.16.1
@@ -0,0 +1,3 @@
+MD5 93a8d37175dc1f173c0185c254de5c38 epiphany-extensions-2.16.1.tar.bz2 810858
+RMD160 95e11ed5b39bc1662fa606797c32c413c08326b3 epiphany-extensions-2.16.1.tar.bz2 810858
+SHA256 315ef2eeaf2943830bdf04958af613dce62574aa6697acfab335a0b9e4f699c5 epiphany-extensions-2.16.1.tar.bz2 810858