summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-09-01 16:46:52 +0000
committerAlex Alexander <wired@gentoo.org>2009-09-01 16:46:52 +0000
commit37afc012eaacc211fe07fd5487b072507f3e5802 (patch)
tree955f8e5644398dc674f85c05fd7eecb4a8088cd7 /www-client/arora
parentAdd missing metadata, as it is new package in 4.3.1 and bump script doesn't a... (diff)
downloadgentoo-2-37afc012eaacc211fe07fd5487b072507f3e5802.tar.gz
gentoo-2-37afc012eaacc211fe07fd5487b072507f3e5802.tar.bz2
gentoo-2-37afc012eaacc211fe07fd5487b072507f3e5802.zip
version bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'www-client/arora')
-rw-r--r--www-client/arora/ChangeLog7
-rw-r--r--www-client/arora/arora-0.9.0.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/www-client/arora/ChangeLog b/www-client/arora/ChangeLog
index e244ec914223..5d04e0b0cf5c 100644
--- a/www-client/arora/ChangeLog
+++ b/www-client/arora/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/arora
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.22 2009/07/22 22:26:48 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.23 2009/09/01 16:46:52 wired Exp $
+
+*arora-0.9.0 (01 Sep 2009)
+
+ 01 Sep 2009; Alex Alexander <wired@gentoo.org> +arora-0.9.0.ebuild:
+ version bump
*arora-0.8.0 (22 Jul 2009)
diff --git a/www-client/arora/arora-0.9.0.ebuild b/www-client/arora/arora-0.9.0.ebuild
new file mode 100644
index 000000000000..b330cab97277
--- /dev/null
+++ b/www-client/arora/arora-0.9.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/arora-0.9.0.ebuild,v 1.1 2009/09/01 16:46:52 wired Exp $
+
+EAPI=2
+inherit eutils qt4
+
+DESCRIPTION="A cross-platform Qt4 WebKit browser"
+HOMEPAGE="http://arora.googlecode.com/"
+SRC_URI="http://arora.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="x11-libs/qt-gui
+ x11-libs/qt-sql
+ x11-libs/qt-webkit"
+DEPEND="$RDEPEND"
+
+ARORA_LANGS="ast ca es es_CR et_EE fr_CA gl ms nb_NO pt_BR sr@latin sr_CS uk
+zh_CN zh_TW"
+ARORA_NOLONGLANGS="cs_CZ da_DK de_DE el_GR fi_FI fr_FR he_IL hu_HU it_IT ja_JP
+nl_NL pl_PL ru_RU sk_SK tr_TR"
+
+for L in $ARORA_LANGS; do
+ IUSE="$IUSE linguas_$L"
+done
+for L in $ARORA_NOLONGLANGS; do
+ IUSE="$IUSE linguas_${L%_*}"
+done
+
+src_prepare() {
+ # use Gentoo lingua designations
+ mv src/locale/sr_RS@latin.ts src/locale/sr@latin.ts
+ mv src/locale/sr_RS.ts src/locale/sr_CS.ts
+
+ # process linguas
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $ARORA_LANGS; then
+ langs="$langs ${lingua}.ts"
+ else
+ for a in $ARORA_NOLONGLANGS; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs ${a}.ts"
+ fi
+ done
+ fi
+ done
+
+ # remove all translations, then add only the ones we want
+ sed -i '/ts/d' src/locale/locale.pri || die 'sed failed'
+ sed -i "/^TRANSLATIONS/s:\\\:${langs}:" src/locale/locale.pri \
+ || die 'sed failed'
+
+ if ! use doc ; then
+ sed -i 's|QMAKE_EXTRA|#QMAKE_EXTRA|' arora.pro || die 'sed failed'
+ fi
+}
+
+src_configure() {
+ eqmake4 arora.pro PREFIX=/usr
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ # don't pre-strip
+ sed -i "/strip/d" src/Makefile || die 'sed failed'
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'make install failed'
+ dodoc AUTHORS ChangeLog README
+}