summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-28 14:47:44 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-28 14:47:44 +0000
commitec978c8674c958e4a905519713209df6b3aa5964 (patch)
tree30e0310a872b66514fc26fd372de3a00b64d93e0 /www-apps
parentkeyword ~x86-fbsd, bug #247076 (diff)
downloadgentoo-2-ec978c8674c958e4a905519713209df6b3aa5964.tar.gz
gentoo-2-ec978c8674c958e4a905519713209df6b3aa5964.tar.bz2
gentoo-2-ec978c8674c958e4a905519713209df6b3aa5964.zip
Version bump, added some fixes from upstream. Remove unsed version.
(Portage version: 2.2_rc16/cvs/Linux 2.6.26-openvz.git-35f41f1 i686)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mantisbt/ChangeLog10
-rw-r--r--www-apps/mantisbt/files/mantisbt-1.1.5-caching.patch41
-rw-r--r--www-apps/mantisbt/files/mantisbt-1.1.5-extensions.patch21
-rw-r--r--www-apps/mantisbt/mantisbt-1.1.5.ebuild (renamed from www-apps/mantisbt/mantisbt-1.1.4-r3.ebuild)12
4 files changed, 75 insertions, 9 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index 96369a685be5..3e3fb5734808 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.75 2008/11/07 12:28:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.76 2008/11/28 14:47:44 pva Exp $
+
+*mantisbt-1.1.5 (28 Nov 2008)
+
+ 28 Nov 2008; Peter Volkov <pva@gentoo.org>
+ +files/mantisbt-1.1.5-caching.patch,
+ +files/mantisbt-1.1.5-extensions.patch, -mantisbt-1.1.4-r3.ebuild,
+ +mantisbt-1.1.5.ebuild:
+ Version bump, added some fixes from upstream. Remove unsed version.
*mantisbt-1.1.4-r3 (07 Nov 2008)
diff --git a/www-apps/mantisbt/files/mantisbt-1.1.5-caching.patch b/www-apps/mantisbt/files/mantisbt-1.1.5-caching.patch
new file mode 100644
index 000000000000..aa8b83e42204
--- /dev/null
+++ b/www-apps/mantisbt/files/mantisbt-1.1.5-caching.patch
@@ -0,0 +1,41 @@
+From: John Reese <jreese@leetcode.net>
+Date: Mon, 24 Nov 2008 14:11:42 +0000 (-0500)
+Subject: Revert 4ee424e1, fix #9754, #9869, #9323 by adding Last-Modified headers to match...
+X-Git-Url: http://git.mantisbt.org/?p=mantisbt.git;a=commitdiff_plain;h=161a677ee2b986507a06dbb65a9dfe848bd21935
+
+Revert 4ee424e1, fix #9754, #9869, #9323 by adding Last-Modified headers to match Expires.
+
+Commit has been tested on:
+ FF 2.0.14
+ FF 3.0.4
+ IE 8.0.6001.18241
+ IE 6.0.2900.5122
+ GC 0.4.154.23
+ Opera 9.51.10081
+---
+
+diff --git a/core.php b/core.php
+index 32fb66f..03c13c6 100644
+--- a/core.php
++++ b/core.php
+@@ -159,9 +159,9 @@
+
+ if ( isset( $g_allow_browser_cache ) && ON == $g_allow_browser_cache ) {
+ switch ( $t_browser_name ) {
+- #case 'IE':
+- # header( 'Cache-Control: private, proxy-revalidate' );
+- # break;
++ case 'IE':
++ header( 'Cache-Control: private, proxy-revalidate' );
++ break;
+ default:
+ header( 'Cache-Control: private, must-revalidate' );
+ break;
+@@ -172,6 +172,7 @@
+ }
+
+ header( 'Expires: ' . gmdate( 'D, d M Y H:i:s \G\M\T', time() ) );
++ header( 'Last-Modified: ' . gmdate( 'D, d M Y H:i:s \G\M\T', time() ) );
+
+ # SEND USER-DEFINED HEADERS
+ foreach( config_get( 'custom_headers' ) as $t_header ) {
diff --git a/www-apps/mantisbt/files/mantisbt-1.1.5-extensions.patch b/www-apps/mantisbt/files/mantisbt-1.1.5-extensions.patch
new file mode 100644
index 000000000000..3e13e8007a25
--- /dev/null
+++ b/www-apps/mantisbt/files/mantisbt-1.1.5-extensions.patch
@@ -0,0 +1,21 @@
+From: John Reese <jreese@leetcode.net>
+Date: Tue, 25 Nov 2008 19:54:32 +0000 (-0500)
+Subject: Fix #9890: improper comparison of file extensions in file_download.php
+X-Git-Url: http://git.mantisbt.org/?p=mantisbt.git;a=commitdiff_plain;h=99903fda7b565afc30a9ae9e37f9cae2053430ff
+
+Fix #9890: improper comparison of file extensions in file_download.php
+---
+
+diff --git a/file_download.php b/file_download.php
+index 067b03a..8074cc4 100644
+--- a/file_download.php
++++ b/file_download.php
+@@ -91,7 +91,7 @@
+ header( 'Content-Length: ' . $v_filesize );
+ $t_filename = file_get_display_name( $v_filename );
+ $t_inline_files = explode(',', config_get('inline_file_exts', 'gif'));
+- if ( in_array( file_get_extension($t_filename), $t_inline_files ) ) {
++ if ( in_array( strtolower( file_get_extension($t_filename) ), $t_inline_files ) ) {
+ $t_disposition = ''; //'inline;';
+ } else {
+ $t_disposition = ' attachment;';
diff --git a/www-apps/mantisbt/mantisbt-1.1.4-r3.ebuild b/www-apps/mantisbt/mantisbt-1.1.5.ebuild
index 95b25dec88eb..22b1d65ec015 100644
--- a/www-apps/mantisbt/mantisbt-1.1.4-r3.ebuild
+++ b/www-apps/mantisbt/mantisbt-1.1.5.ebuild
@@ -1,15 +1,12 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.1.4-r3.ebuild,v 1.1 2008/11/07 12:28:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.1.5.ebuild,v 1.1 2008/11/28 14:47:44 pva Exp $
inherit eutils webapp depend.php
-MY_P=mantis-${PV}
-
DESCRIPTION="PHP/MySQL/Web based bugtracking system"
HOMEPAGE="http://www.mantisbt.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
- mirror://gentoo/${P}-r5687:5752.patch.bz2"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
@@ -20,8 +17,6 @@ RDEPEND="
virtual/httpd-cgi
dev-php/adodb"
-S=${WORKDIR}/${MY_P}
-
pkg_setup() {
webapp_pkg_setup
has_php
@@ -32,7 +27,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
rm -r "${S}/core/adodb/" # We use external adodb
- epatch "${WORKDIR}/${P}-r5687:5752.patch"
+ epatch "${FILESDIR}/${P}-caching.patch"
+ epatch "${FILESDIR}/${P}-extensions.patch"
}
src_install() {