summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2014-02-27 23:47:41 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2014-02-27 23:47:41 +0000
commit9ba0cb1b961cea5715afb38cd16ad5d66beab2e9 (patch)
treedd752240d4f41cf4374d53f1237aa33ce947ae87 /www-apps
parentVersion bump to 3.4.48 (diff)
downloadgentoo-2-9ba0cb1b961cea5715afb38cd16ad5d66beab2e9.tar.gz
gentoo-2-9ba0cb1b961cea5715afb38cd16ad5d66beab2e9.tar.bz2
gentoo-2-9ba0cb1b961cea5715afb38cd16ad5d66beab2e9.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/cgit/ChangeLog7
-rw-r--r--www-apps/cgit/cgit-0.10.1.ebuild94
2 files changed, 100 insertions, 1 deletions
diff --git a/www-apps/cgit/ChangeLog b/www-apps/cgit/ChangeLog
index c3535e7c5441..631c710fa99f 100644
--- a/www-apps/cgit/ChangeLog
+++ b/www-apps/cgit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/cgit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/ChangeLog,v 1.22 2014/02/05 16:32:50 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/ChangeLog,v 1.23 2014/02/27 23:47:41 zx2c4 Exp $
+
+*cgit-0.10.1 (27 Feb 2014)
+
+ 27 Feb 2014; Jason A. Donenfeld <zx2c4@gentoo.org> +cgit-0.10.1.ebuild:
+ Version bump.
05 Feb 2014; Jason A. Donenfeld <zx2c4@gentoo.org> -cgit-0.9.2.ebuild,
cgit-0.10.ebuild:
diff --git a/www-apps/cgit/cgit-0.10.1.ebuild b/www-apps/cgit/cgit-0.10.1.ebuild
new file mode 100644
index 000000000000..922b5eb4fb1e
--- /dev/null
+++ b/www-apps/cgit/cgit-0.10.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/cgit-0.10.1.ebuild,v 1.1 2014/02/27 23:47:41 zx2c4 Exp $
+
+EAPI="4"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+inherit webapp eutils multilib user
+
+[[ -z "${CGIT_CACHEDIR}" ]] && CGIT_CACHEDIR="/var/cache/${PN}/"
+
+GIT_V="1.9.0"
+
+DESCRIPTION="a fast web-interface for git repositories"
+HOMEPAGE="http://git.zx2c4.com/cgit/about"
+SRC_URI="mirror://kernel/software/scm/git/git-${GIT_V}.tar.xz
+ http://git.zx2c4.com/cgit/snapshot/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +highlight +lua +jit"
+
+RDEPEND="
+ dev-vcs/git
+ sys-libs/zlib
+ dev-libs/openssl
+ virtual/httpd-cgi
+ highlight? ( || ( dev-python/pygments app-text/highlight ) )
+ lua? ( jit? ( dev-lang/luajit ) !jit? ( dev-lang/lua ) )
+"
+# ebuilds without WEBAPP_MANUAL_SLOT="yes" are broken
+DEPEND="${RDEPEND}
+ !<www-apps/cgit-0.8.3.3
+ doc? ( app-text/docbook-xsl-stylesheets
+ >=app-text/asciidoc-8.5.1 )
+"
+
+pkg_setup() {
+ webapp_pkg_setup
+ enewuser "${PN}"
+}
+
+src_prepare() {
+ rmdir git || die
+ mv "${WORKDIR}"/git-"${GIT_V}" git || die
+
+ echo "prefix = ${EPREFIX}/usr" >> cgit.conf
+ echo "libdir = ${EPREFIX}/usr/$(get_libdir)" >> cgit.conf
+ echo "CGIT_SCRIPT_PATH = ${MY_CGIBINDIR}" >> cgit.conf
+ echo "CGIT_DATA_PATH = ${MY_HTDOCSDIR}" >> cgit.conf
+ echo "CACHE_ROOT = ${CGIT_CACHEDIR}" >> cgit.conf
+ echo "DESTDIR = ${D}" >> cgit.conf
+ if use lua; then
+ if use jit; then
+ echo "LUA_PKGCONFIG = luajit" >> cgit.conf
+ else
+ echo "LUA_PKGCONFIG = lua" >> cgit.conf
+ fi
+ else
+ echo "NO_LUA = 1" >> cgit.conf
+ fi
+}
+
+src_compile() {
+ emake
+ use doc && emake doc-man
+}
+
+src_install() {
+ webapp_src_preinst
+
+ emake install
+
+ insinto /etc
+ doins "${FILESDIR}"/cgitrc
+
+ dodoc README
+ use doc && doman cgitrc.5
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+
+ keepdir "${CGIT_CACHEDIR}"
+ fowners ${PN}:${PN} "${CGIT_CACHEDIR}"
+ fperms 700 "${CGIT_CACHEDIR}"
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ ewarn "If you intend to run cgit using web server's user"
+ ewarn "you should change ${CGIT_CACHEDIR} permissions."
+}