summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-10-14 11:55:08 +0000
committerPeter Volkov <pva@gentoo.org>2008-10-14 11:55:08 +0000
commit7cc40b0668c0a468b178cf7eb50f9206681be598 (patch)
tree422562097a69e0bf8c1c6e36f94b348cdd10456f /www-apps
parentEmacs support fixed (bug #241582), a typo introduced in the last revision fix... (diff)
downloadgentoo-2-7cc40b0668c0a468b178cf7eb50f9206681be598.tar.gz
gentoo-2-7cc40b0668c0a468b178cf7eb50f9206681be598.tar.bz2
gentoo-2-7cc40b0668c0a468b178cf7eb50f9206681be598.zip
Version bump.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-openvz.git-777e816 i686)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mantisbt/ChangeLog7
-rw-r--r--www-apps/mantisbt/mantisbt-1.1.3.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index ed9481b19111..5bafc197d173 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.64 2008/10/04 17:24:48 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.65 2008/10/14 11:55:08 pva Exp $
+
+*mantisbt-1.1.3 (14 Oct 2008)
+
+ 14 Oct 2008; Peter Volkov <pva@gentoo.org> +mantisbt-1.1.3.ebuild:
+ Version bump.
04 Oct 2008; Peter Volkov <pva@gentoo.org> -mantisbt-1.1.2.ebuild,
mantisbt-1.1.2-r1.ebuild:
diff --git a/www-apps/mantisbt/mantisbt-1.1.3.ebuild b/www-apps/mantisbt/mantisbt-1.1.3.ebuild
new file mode 100644
index 000000000000..58a264af308f
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.1.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.1.3.ebuild,v 1.1 2008/10/14 11:55:08 pva Exp $
+
+inherit eutils webapp depend.php
+
+MY_P=mantis-${PV}
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/httpd-php
+ virtual/httpd-cgi
+ dev-php/adodb"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ require_php_with_use pcre
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -r "${S}"/core/adodb/ # We use external adodb
+}
+
+src_install() {
+ webapp_src_preinst
+ rm doc/{LICENSE,INSTALL}
+ dodoc doc/*
+
+ rm -rf doc packages
+ mv config_inc.php.sample config_inc.php
+ cp -R . "${D}"/${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/config_inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-1.0.0.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ elog "Note, that this branch of mantisbt does not work with PostgreSQL."
+ elog "If really need mantisbt to work with PostgreSQL you'll have to"
+ elog "install it manually from upstream svn repository:"
+ elog "https://sourceforge.net/svn/?group_id=14963"
+}