summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-11-10 13:21:17 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-11-10 13:21:17 +0000
commit662991a4d88b39811887953ee8182ff890540119 (patch)
tree7b5ac0b9d62e8780d135c46ade068e7994c45ec2 /www-apps
parentCleanup old. (diff)
downloadgentoo-2-662991a4d88b39811887953ee8182ff890540119.tar.gz
gentoo-2-662991a4d88b39811887953ee8182ff890540119.tar.bz2
gentoo-2-662991a4d88b39811887953ee8182ff890540119.zip
Version bump to 2.8 branch
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/moodle/ChangeLog8
-rw-r--r--www-apps/moodle/files/config-r1.php36
-rw-r--r--www-apps/moodle/moodle-2.8.ebuild128
3 files changed, 171 insertions, 1 deletions
diff --git a/www-apps/moodle/ChangeLog b/www-apps/moodle/ChangeLog
index edd3b724e540..33fb0caacf6d 100644
--- a/www-apps/moodle/ChangeLog
+++ b/www-apps/moodle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/moodle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.63 2014/11/10 12:42:02 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.64 2014/11/10 13:21:17 blueness Exp $
+
+*moodle-2.8 (10 Nov 2014)
+
+ 10 Nov 2014; Anthony G. Basile <blueness@gentoo.org> +files/config-r1.php,
+ +moodle-2.8.ebuild:
+ Version bump to 2.8 branch
10 Nov 2014; Anthony G. Basile <blueness@gentoo.org> -moodle-2.5.8.ebuild,
-moodle-2.6.5.ebuild, -moodle-2.7.2.ebuild:
diff --git a/www-apps/moodle/files/config-r1.php b/www-apps/moodle/files/config-r1.php
new file mode 100644
index 000000000000..7eef454b7dfc
--- /dev/null
+++ b/www-apps/moodle/files/config-r1.php
@@ -0,0 +1,36 @@
+<?php
+unset($CFG); // Ignore this line
+global $CFG; // This is necessary here for PHPUnit execution
+$CFG = new stdClass();
+
+$CFG->dbtype = 'mydb'; // 'pgsql', 'mariadb', 'mysqli', 'mssql', 'sqlsrv' or 'oci'
+$CFG->dblibrary = 'native'; // 'native' only at the moment
+$CFG->dbhost = 'localhost'; // eg 'localhost' or 'db.isp.com' or IP
+$CFG->dbname = 'moodle'; // database name, eg moodle
+$CFG->dbuser = 'username'; // your database username
+$CFG->dbpass = 'password'; // your database password
+$CFG->prefix = 'mdl_'; // prefix to use for all table names
+$CFG->dboptions = array(
+ 'dbpersist' => false, // should persistent database connections be
+ // used? set to 'false' for the most stable
+ // setting, 'true' can improve performance
+ // sometimes
+ 'dbsocket' => false, // should connection via UNIX socket be used?
+ // if you set it to 'true' or custom path
+ // here set dbhost to 'localhost',
+ // (please note mysql is always using socket
+ // if dbhost is 'localhost' - if you need
+ // local port connection use '127.0.0.1')
+ 'dbport' => '', // the TCP port number to use when connecting
+ // to the server. keep empty string for the
+ // default port
+);
+
+$CFG->wwwroot = 'http://example.com/moodle';
+$CFG->dataroot = '/home/example/moodledata';
+$CFG->directorypermissions = 02777;
+
+$CFG->admin = 'admin';
+
+require_once(dirname(__FILE__) . '/lib/setup.php'); // Do not edit
+?>
diff --git a/www-apps/moodle/moodle-2.8.ebuild b/www-apps/moodle/moodle-2.8.ebuild
new file mode 100644
index 000000000000..e74095ae3e8a
--- /dev/null
+++ b/www-apps/moodle/moodle-2.8.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-2.8.ebuild,v 1.1 2014/11/10 13:21:17 blueness Exp $
+
+EAPI="5"
+
+inherit versionator webapp
+
+AVC=( $(get_version_components) )
+MY_BRANCH="stable${AVC[0]}${AVC[1]}"
+
+DESCRIPTION="The Moodle Course Management System"
+HOMEPAGE="http://moodle.org"
+SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+#SLOT empty due to webapp
+
+DB_FLAGS="mysqli?,mssql?,postgres?"
+DB_TYPES=${DB_FLAGS//\?/}
+DB_TYPES=${DB_TYPES//,/ }
+
+AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
+AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
+AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
+
+PHP_REQUIRED_FLAGS="ctype,curl,iconv,json,session,simplexml,xml,zip"
+PHP_OPTIONAL_FLAGS="gd,intl,soap,ssl,tokenizer,xmlrpc"
+PHP_FLAGS="${PHP_REQUIRED_FLAGS},${PHP_OPTIONAL_FLAGS}"
+
+IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
+REQUIRED_USE="|| ( ${DB_TYPES} )"
+
+# No forced dependency on
+# mssql? - lives on a windows server
+# mysql? ( virtual/mysql )
+# postgres? ( dev-db/postgresql-server-9* )
+# which may live on another server. These USE flags affect the configuration
+# file and the dependency on php. However other dbs are possible. See config.php
+# and the moodle documentation for other possibilities.
+DEPEND=""
+RDEPEND="
+ >=dev-lang/php-5.4.4[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS}]
+ virtual/httpd-php
+ virtual/cron"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ # How many dbs were selected? If one and only one, which one is it?
+ MYDB=""
+ DB_COUNT=0
+ for db in ${DB_TYPES}; do
+ if use ${db}; then
+ MYDB=${db}
+ DB_COUNT=$(($DB_COUNT+1))
+ fi
+ done
+
+ # REQUIRED_USE above guarantees that ${DB_COUNT} cannot be zero
+ #if [[ ${DB_COUNT} -eq 0 ]]; then
+ # eerror
+ # eerror "\033[1;31m**************************************************\033[00m"
+ # eerror "No database selected in your USE flags,"
+ # eerror "You must select at least one."
+ # eerror "\033[1;31m**************************************************\033[00m"
+ # eerror
+ # die
+ #fi
+
+ if [[ ${DB_COUNT} -gt 1 ]]; then
+ MYDB=""
+ ewarn
+ ewarn "\033[1;33m**************************************************\033[00m"
+ ewarn "Multiple databases selected in your USE flags,"
+ ewarn "You will have to choose your database manually."
+ ewarn "\033[1;33m**************************************************\033[00m"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ rm COPYING.txt
+ cp "${FILESDIR}"/config-r1.php config.php
+
+ # Moodle expect pgsql, not postgres
+ MYDB=${MYDB/postgres/pgsql}
+
+ if [[ ${DB_COUNT} -eq 1 ]] ; then
+ sed -i -e "s|mydb|${MYDB}|" config.php
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
+ dodir ${MOODLEDATA}
+ webapp_serverowned -R "${MOODLEDATA}"
+
+ local MOODLEROOT="${MY_HTDOCSDIR}"
+ insinto ${MOODLEROOT}
+ doins -r *
+
+ webapp_configfile "${MOODLEROOT}"/config.php
+
+ if [[ ${DB_COUNT} -eq 1 ]]; then
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ else
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
+ fi
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "\033[1;32m**************************************************\033[00m"
+ einfo
+ einfo "To see the post install instructions, do"
+ einfo
+ einfo " webapp-config --show-postinst ${PN} ${PVR}"
+ einfo
+ einfo "\033[1;32m**************************************************\033[00m"
+ einfo
+}