summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2005-10-20 19:38:39 +0000
committerRoy Marples <uberlord@gentoo.org>2005-10-20 19:38:39 +0000
commit6115b7e0e5ab292704b322b8303f8baf6778a02c (patch)
tree6f080e8799b33cca467fb6a836c5c9bbf4c475aa /www-apps
parentUse --enable-install-setuid instead of manually changing permissions. (diff)
downloadgentoo-2-6115b7e0e5ab292704b322b8303f8baf6778a02c.tar.gz
gentoo-2-6115b7e0e5ab292704b322b8303f8baf6778a02c.tar.bz2
gentoo-2-6115b7e0e5ab292704b322b8303f8baf6778a02c.zip
New version
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/websvn/ChangeLog7
-rw-r--r--www-apps/websvn/files/digest-websvn-1.70_beta11
-rw-r--r--www-apps/websvn/websvn-1.70_beta1.ebuild52
3 files changed, 59 insertions, 1 deletions
diff --git a/www-apps/websvn/ChangeLog b/www-apps/websvn/ChangeLog
index 108b700641d9..283263da03fb 100644
--- a/www-apps/websvn/ChangeLog
+++ b/www-apps/websvn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/websvn
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/ChangeLog,v 1.9 2005/10/18 16:08:44 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/ChangeLog,v 1.10 2005/10/20 19:38:39 uberlord Exp $
+
+*websvn-1.70_beta1 (20 Oct 2005)
+
+ 20 Oct 2005; Roy Marples <uberlord@gentoo.org> +websvn-1.70_beta1.ebuild:
+ New version.
18 Oct 2005; Roy Marples <uberlord@gentoo.org>
files/websvn-1.61-german.patch:
diff --git a/www-apps/websvn/files/digest-websvn-1.70_beta1 b/www-apps/websvn/files/digest-websvn-1.70_beta1
new file mode 100644
index 000000000000..fc70377e82d5
--- /dev/null
+++ b/www-apps/websvn/files/digest-websvn-1.70_beta1
@@ -0,0 +1 @@
+MD5 ca5dc1321413afbee4f1e1b0c43e111c WebSVN_170beta1.tar.gz 225497
diff --git a/www-apps/websvn/websvn-1.70_beta1.ebuild b/www-apps/websvn/websvn-1.70_beta1.ebuild
new file mode 100644
index 000000000000..69c6063b66cc
--- /dev/null
+++ b/www-apps/websvn/websvn-1.70_beta1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/websvn-1.70_beta1.ebuild,v 1.1 2005/10/20 19:38:39 uberlord Exp $
+
+inherit eutils webapp
+
+MY_PV="170beta1"
+DESCRIPTION="Web-based browsing tool for Subversion (SVN) repositories in PHP"
+HOMEPAGE="http://websvn.tigris.org/"
+SRC_URI="http://websvn.tigris.org/files/documents/1380/14334/WebSVN_${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+IUSE="enscript"
+KEYWORDS="~x86 ~amd64 ~sparc"
+
+RDEPEND="virtual/php
+ dev-util/subversion
+ sys-apps/sed
+ enscript? ( >=app-text/enscript-1.6.0 )"
+
+S="${WORKDIR}/WebSVN"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+}
+
+src_compile() {
+ mv "${S}/include/distconfig.inc" "${S}/include/config.inc"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local doc docs="changes.txt install.txt templates.txt"
+
+ dodoc ${docs}
+ for doc in ${docs}; do
+ rm -f "${doc}"
+ done
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r *
+ webapp_configfile "${MY_HTDOCSDIR}/include/config.inc"
+
+ # This is the multiview config file
+ webapp_configfile "${MY_HTDOCSDIR}/wsvn.php"
+
+ # The cache directory needs to be writeable
+ webapp_serverowned "${MY_HTDOCSDIR}/cache"
+
+ webapp_src_install
+}