summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-09-12 03:50:33 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-09-12 03:50:33 +0000
commit44035982fe71dab6eb0ce1a235ed5f77a9b7b7b7 (patch)
treead28dcf769225a7f95301980aa5677b8790e395b /www-apps
parentVersion bump (diff)
downloadgentoo-2-44035982fe71dab6eb0ce1a235ed5f77a9b7b7b7.tar.gz
gentoo-2-44035982fe71dab6eb0ce1a235ed5f77a9b7b7b7.tar.bz2
gentoo-2-44035982fe71dab6eb0ce1a235ed5f77a9b7b7b7.zip
Version bump; bug #145518, bug #145516.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mambo/ChangeLog8
-rw-r--r--www-apps/mambo/files/digest-mambo-4.5.4-r23
-rw-r--r--www-apps/mambo/mambo-4.5.4-r2.ebuild47
3 files changed, 57 insertions, 1 deletions
diff --git a/www-apps/mambo/ChangeLog b/www-apps/mambo/ChangeLog
index 48e85891e176..fcf55b20d3e3 100644
--- a/www-apps/mambo/ChangeLog
+++ b/www-apps/mambo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mambo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.24 2006/06/20 21:17:18 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.25 2006/09/12 03:50:33 rl03 Exp $
+
+*mambo-4.5.4-r2 (12 Sep 2006)
+
+ 12 Sep 2006; Renat Lumpau <rl03@gentoo.org> -mambo-4.5.4-r1.ebuild,
+ +mambo-4.5.4-r2.ebuild:
+ Version bump; bug #145518, bug #145516.
*mambo-4.5.4-r1 (20 Jun 2006)
diff --git a/www-apps/mambo/files/digest-mambo-4.5.4-r2 b/www-apps/mambo/files/digest-mambo-4.5.4-r2
new file mode 100644
index 000000000000..aaf224fcf861
--- /dev/null
+++ b/www-apps/mambo/files/digest-mambo-4.5.4-r2
@@ -0,0 +1,3 @@
+MD5 c82b69b239629cda3d595a4760575060 Mambov4.5.4_wSP2.tar.gz 1872234
+RMD160 37e9dacbb9e32f1e2577e9634487356c9e487921 Mambov4.5.4_wSP2.tar.gz 1872234
+SHA256 175a178998ad641c755ed9c4b42dc97e326cc3c61eee2e8c28f72a473d6465d7 Mambov4.5.4_wSP2.tar.gz 1872234
diff --git a/www-apps/mambo/mambo-4.5.4-r2.ebuild b/www-apps/mambo/mambo-4.5.4-r2.ebuild
new file mode 100644
index 000000000000..94d13318c870
--- /dev/null
+++ b/www-apps/mambo/mambo-4.5.4-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/mambo-4.5.4-r2.ebuild,v 1.1 2006/09/12 03:50:33 rl03 Exp $
+
+inherit webapp depend.php
+
+WEBAPP_MANUAL_SLOT="yes"
+SLOT=4.5.4
+MY_PN="${PN/m/M}"
+DESCRIPTION="Mambo is yet another CMS"
+HOMEPAGE="http://www.mamboserver.com/"
+SRC_URI="http://mamboxchange.com/frs/download.php/8203/${MY_PN}v${PV}_wSP2.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+S=${WORKDIR}
+
+IUSE="mysql"
+
+RDEPEND="mysql? ( dev-db/mysql )
+ virtual/httpd-php
+ net-www/apache"
+
+pkg_setup () {
+ webapp_pkg_setup
+ require_php_with_use mysql zlib
+}
+
+src_install () {
+ webapp_src_preinst
+ local files="administrator/backups administrator/components components
+ images images/banners images/stories mambots mambots/content mambots/search
+ media language administrator/modules administrator/templates cache modules
+ templates"
+
+ dodoc CHANGELOG.php INSTALL.php README
+
+ cp -R [^d]* ${D}/${MY_HTDOCSDIR}
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}