summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-02-14 14:14:29 +0000
committerSteve Dibb <beandog@gentoo.org>2007-02-14 14:14:29 +0000
commit3a9a6c55dbde1cea91ced54dcf235f8eb2d4c8fc (patch)
tree704b7247d743e7ee66ff3deee23756a6e3b3869b /www-apps/wordpress
parentadd a patch from cmus mailing list that allows building against media-libs/fa... (diff)
downloadgentoo-2-3a9a6c55dbde1cea91ced54dcf235f8eb2d4c8fc.tar.gz
gentoo-2-3a9a6c55dbde1cea91ced54dcf235f8eb2d4c8fc.tar.bz2
gentoo-2-3a9a6c55dbde1cea91ced54dcf235f8eb2d4c8fc.zip
Version bump, fix php deps bug 144585, security bug 163817
(Portage version: 2.1.2-r9)
Diffstat (limited to 'www-apps/wordpress')
-rw-r--r--www-apps/wordpress/ChangeLog7
-rw-r--r--www-apps/wordpress/files/digest-wordpress-2.0.83
-rw-r--r--www-apps/wordpress/wordpress-2.0.8.ebuild89
3 files changed, 98 insertions, 1 deletions
diff --git a/www-apps/wordpress/ChangeLog b/www-apps/wordpress/ChangeLog
index 229187aa3ef0..1251894be5ad 100644
--- a/www-apps/wordpress/ChangeLog
+++ b/www-apps/wordpress/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/wordpress
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.69 2007/01/17 03:53:27 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.70 2007/02/14 14:14:28 beandog Exp $
+
+*wordpress-2.0.8 (14 Feb 2007)
+
+ 14 Feb 2007; Steve Dibb <beandog@gentoo.org> +wordpress-2.0.8.ebuild:
+ Version bump, fix php deps bug 144585, security bug 163817
*wordpress-2.0.7 (17 Jan 2007)
diff --git a/www-apps/wordpress/files/digest-wordpress-2.0.8 b/www-apps/wordpress/files/digest-wordpress-2.0.8
new file mode 100644
index 000000000000..31f09b37a925
--- /dev/null
+++ b/www-apps/wordpress/files/digest-wordpress-2.0.8
@@ -0,0 +1,3 @@
+MD5 b2f3503fee081233a81f5f4903ec3928 wordpress-2.0.8.tar.gz 519755
+RMD160 f776b0dfffa6734558cced294db821e39151fd52 wordpress-2.0.8.tar.gz 519755
+SHA256 86a181e9bd0f5563592d7a64a20772346e39b719fbed052eb648a0b714a72144 wordpress-2.0.8.tar.gz 519755
diff --git a/www-apps/wordpress/wordpress-2.0.8.ebuild b/www-apps/wordpress/wordpress-2.0.8.ebuild
new file mode 100644
index 000000000000..692b49bc18eb
--- /dev/null
+++ b/www-apps/wordpress/wordpress-2.0.8.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/wordpress-2.0.8.ebuild,v 1.1 2007/02/14 14:14:28 beandog Exp $
+
+inherit webapp eutils depend.php
+
+DESCRIPTION="Wordpress php and mysql based CMS system."
+HOMEPAGE="http://wordpress.org/"
+SRC_URI="http://www.wordpress.org/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+need_php
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ require_php_with_any_use mysql mysqli
+ require_php_with_use pcre
+}
+
+src_install() {
+ local docs="license.txt readme.html"
+
+ webapp_src_preinst
+
+ einfo "Installing main files"
+ cp wp-config-sample.php wp-config.php
+ cp -r * ${D}${MY_HTDOCSDIR}
+ einfo "Done"
+
+ ewarn
+ ewarn Please make sure you have register_globals = off set in your /etc/apache2/php.ini file
+ ewarn If this is not an option for your web server and you NEED it set to on, then insert the following in your WordPress .htaccess file:
+ ewarn php_flag register_globals off
+ ewarn
+
+ ewarn
+ ewarn You will need to create a table for your WordPress database. This
+ ewarn assumes you have some knowledge of MySQL, and already have it
+ ewarn installed and configured. If not, please refer to
+ ewarn the Gentoo MySQL guide at the following URL:
+ ewarn http://www.gentoo.org/doc/en/mysql-howto.xml
+ ewarn Log in to MySQL, and create a new database called
+ ewarn "wordpress". From this point, you will need to edit
+ ewarn your wp-config.php file in $DocumentRoot/wordpress/
+ ewarn and point to your database. Once this is done, you can log in to
+ ewarn WordPress at http://localhost/wordpress
+ ewarn
+
+ ewarn
+ ewarn If you are upgrading from a previous version BACK UP your
+ ewarn database. Once you are done with that, browse to
+ ewarn http://localhost/wordpress/wp-admin/upgrade.php and follow
+ ewarn the instructions on the screen.
+ ewarn
+
+ # handle documentation files
+ #
+ # NOTE that doc files go into /usr/share/doc as normal; they do NOT
+ # get installed per vhost!
+
+ dodoc ${docs}
+ for doc in ${docs} INSTALL; do
+ rm -f ${doc}
+ done
+
+ # Identify the configuration files that this app uses
+ # User can want to make changes to these!
+ webapp_serverowned ${MY_HTDOCSDIR}/index.php
+ #webapp_serverowned ${MY_HTDOCSDIR}/wp-layout.css
+ webapp_serverowned ${MY_HTDOCSDIR}/wp-admin/menu.php
+ webapp_serverowned ${MY_HTDOCSDIR}
+ webapp_configfile ${MY_HTDOCSDIR}/wp-config.php
+ # Identify any script files that need #! headers adding to run under
+ # a CGI script (such as PHP/CGI)
+ #
+ # for wordpress, we *assume* that all .php files need to have CGI/BIN
+ # support added
+
+ # post-install instructions
+ #webapp_postinst_txt en ${FILESDIR}/1.2/postinstall-en.txt
+
+ # now strut stuff
+ webapp_src_install
+}