summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-01-05 17:19:05 +0000
committerSteve Dibb <beandog@gentoo.org>2007-01-05 17:19:05 +0000
commit252a4dab49acf06bbec81f69501b5ac16c141ce8 (patch)
tree42dc4160de6e6802cc7d23a819811e4bdb31474b /www-apps/wordpress
parenteinfo converted to elog (diff)
downloadgentoo-2-252a4dab49acf06bbec81f69501b5ac16c141ce8.tar.gz
gentoo-2-252a4dab49acf06bbec81f69501b5ac16c141ce8.tar.bz2
gentoo-2-252a4dab49acf06bbec81f69501b5ac16c141ce8.zip
Version bump, plus security bug release, bug 159229
(Portage version: 2.1.1-r2)
Diffstat (limited to 'www-apps/wordpress')
-rw-r--r--www-apps/wordpress/ChangeLog8
-rw-r--r--www-apps/wordpress/files/digest-wordpress-2.0.63
-rw-r--r--www-apps/wordpress/wordpress-2.0.6.ebuild90
3 files changed, 100 insertions, 1 deletions
diff --git a/www-apps/wordpress/ChangeLog b/www-apps/wordpress/ChangeLog
index 749d2799ef27..4a51657de10c 100644
--- a/www-apps/wordpress/ChangeLog
+++ b/www-apps/wordpress/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/wordpress
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.67 2007/01/04 20:16:57 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.68 2007/01/05 17:19:05 beandog Exp $
+
+*wordpress-2.0.6 (05 Jan 2007)
+
+ 05 Jan 2007; Steve Dibb <beandog@gentoo.org> -wordpress-2.0.5-r1.ebuild,
+ +wordpress-2.0.6.ebuild:
+ Version bump, plus security bug release, bug 159229
*wordpress-2.0.5-r1 (04 Jan 2007)
diff --git a/www-apps/wordpress/files/digest-wordpress-2.0.6 b/www-apps/wordpress/files/digest-wordpress-2.0.6
new file mode 100644
index 000000000000..0bdf1bbb5356
--- /dev/null
+++ b/www-apps/wordpress/files/digest-wordpress-2.0.6
@@ -0,0 +1,3 @@
+MD5 ebe00cee610065bc576bb38db18c792c wordpress-2.0.6.tar.gz 518012
+RMD160 294dcb56148694c937386d4a2cc92a523753a135 wordpress-2.0.6.tar.gz 518012
+SHA256 9c835fb3e72f28ac6babcc4f4159d67d0265ed0b95b33a4fcbcf812b207dfce5 wordpress-2.0.6.tar.gz 518012
diff --git a/www-apps/wordpress/wordpress-2.0.6.ebuild b/www-apps/wordpress/wordpress-2.0.6.ebuild
new file mode 100644
index 000000000000..bbd29115c561
--- /dev/null
+++ b/www-apps/wordpress/wordpress-2.0.6.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/wordpress-2.0.6.ebuild,v 1.1 2007/01/05 17:19:05 beandog Exp $
+
+inherit webapp eutils
+
+#Wordpress releases have a release name tagged on the end of the version on the tar.gz files
+#MY_EXT="mingus"
+
+DESCRIPTION="Wordpress php and mysql based CMS system."
+HOMEPAGE="http://wordpress.org/"
+#Latest version is only available in the format!
+#Download is renamed by HTTP Header as wordpress-<version number>.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="amd64 hppa ppc sparc x86"
+IUSE=""
+RDEPEND="virtual/httpd-php
+ virtual/mysql"
+
+DEPEND="${DEPEND} ${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ local docs="license.txt readme.html"
+
+ webapp_src_preinst
+
+ einfo "Installing main files"
+ cp wp-config-sample.php wp-config.php
+ cp -r * ${D}${MY_HTDOCSDIR}
+ einfo "Done"
+
+ ewarn
+ ewarn Please make sure you have register_globals = off set in your /etc/apache2/php.ini file
+ ewarn If this is not an option for your web server and you NEED it set to on, then insert the following in your WordPress .htaccess file:
+ ewarn php_flag register_globals off
+ ewarn
+
+ ewarn
+ ewarn You will need to create a table for your WordPress database. This
+ ewarn assumes you have some knowledge of MySQL, and already have it
+ ewarn installed and configured. If not, please refer to
+ ewarn the Gentoo MySQL guide at the following URL:
+ ewarn http://www.gentoo.org/doc/en/mysql-howto.xml
+ ewarn Log in to MySQL, and create a new database called
+ ewarn "wordpress". From this point, you will need to edit
+ ewarn your wp-config.php file in $DocumentRoot/wordpress/
+ ewarn and point to your database. Once this is done, you can log in to
+ ewarn WordPress at http://localhost/wordpress
+ ewarn
+
+ ewarn
+ ewarn If you are upgrading from a previous version BACK UP your
+ ewarn database. Once you are done with that, browse to
+ ewarn http://localhost/wordpress/wp-admin/upgrade.php and follow
+ ewarn the instructions on the screen.
+ ewarn
+
+ # handle documentation files
+ #
+ # NOTE that doc files go into /usr/share/doc as normal; they do NOT
+ # get installed per vhost!
+
+ dodoc ${docs}
+ for doc in ${docs} INSTALL; do
+ rm -f ${doc}
+ done
+
+ # Identify the configuration files that this app uses
+ # User can want to make changes to these!
+ webapp_serverowned ${MY_HTDOCSDIR}/index.php
+ #webapp_serverowned ${MY_HTDOCSDIR}/wp-layout.css
+ webapp_serverowned ${MY_HTDOCSDIR}/wp-admin/menu.php
+ webapp_serverowned ${MY_HTDOCSDIR}
+ webapp_configfile ${MY_HTDOCSDIR}/wp-config.php
+ # Identify any script files that need #! headers adding to run under
+ # a CGI script (such as PHP/CGI)
+ #
+ # for wordpress, we *assume* that all .php files need to have CGI/BIN
+ # support added
+
+ # post-install instructions
+ #webapp_postinst_txt en ${FILESDIR}/1.2/postinstall-en.txt
+
+ # now strut stuff
+ webapp_src_install
+
+}