summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-10-28 15:46:18 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-10-28 15:46:18 +0000
commit88e38a5c54b7a699c9a9cde65140e84f11d97607 (patch)
treef2dda8a2b231d0ba0e7d184eff5174f4e3ceb368 /www-apps/tikiwiki
parentAdded ~ppc64; bug #196360 (diff)
downloadgentoo-2-88e38a5c54b7a699c9a9cde65140e84f11d97607.tar.gz
gentoo-2-88e38a5c54b7a699c9a9cde65140e84f11d97607.tar.bz2
gentoo-2-88e38a5c54b7a699c9a9cde65140e84f11d97607.zip
Update to 1.9.8.3 (#195503).
(Portage version: 2.1.3.14)
Diffstat (limited to 'www-apps/tikiwiki')
-rw-r--r--www-apps/tikiwiki/ChangeLog7
-rw-r--r--www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.33
-rw-r--r--www-apps/tikiwiki/tikiwiki-1.9.8.3.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index 97640315abb0..b1f3b0e7e14c 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/tikiwiki
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.48 2007/10/27 11:21:46 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.49 2007/10/28 15:46:17 wrobel Exp $
+
+*tikiwiki-1.9.8.3 (28 Oct 2007)
+
+ 28 Oct 2007; wrobel@gentoo.org +tikiwiki-1.9.8.3.ebuild:
+ Update to 1.9.8.3 (#195503).
27 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
tikiwiki-1.9.8.2.ebuild:
diff --git a/www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.3 b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.3
new file mode 100644
index 000000000000..a7df09e0ab73
--- /dev/null
+++ b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.3
@@ -0,0 +1,3 @@
+MD5 7b8954ec46b42beeffce68106bb71004 tikiwiki-1.9.8.3.tar.bz2 6351864
+RMD160 569d4c9a0649886e512befaa7e9cbc67515118fc tikiwiki-1.9.8.3.tar.bz2 6351864
+SHA256 40e559fdf223ac88741d8956569e5848a397e6d55d84d8bd527e3c52e356d592 tikiwiki-1.9.8.3.tar.bz2 6351864
diff --git a/www-apps/tikiwiki/tikiwiki-1.9.8.3.ebuild b/www-apps/tikiwiki/tikiwiki-1.9.8.3.ebuild
new file mode 100644
index 000000000000..fac2a8b2622e
--- /dev/null
+++ b/www-apps/tikiwiki/tikiwiki-1.9.8.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.8.3.ebuild,v 1.1 2007/10/28 15:46:17 wrobel Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Full-featured Web Content Management System using PHP and Smarty Templates"
+HOMEPAGE="http://tikiwiki.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+IUSE="mysql postgres graphviz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/httpd-cgi
+ graphviz? ( media-gfx/graphviz )
+"
+
+need_php_httpd
+
+pkg_setup () {
+ webapp_pkg_setup
+ use mysql && require_php_with_use mysql
+ use postgres && require_php_with_use postgres
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local DIR
+ local DIRENTRY
+ local DIRS="backups db dump files img/trackers img/wiki
+ img/wiki_up modules/cache temp
+ templates_c templates styles maps whelp mods
+ lib/Galaxia/processes"
+
+ # Ensure that directories exist, some don't.
+ # (part of setup.sh)
+ for DIR in ${DIRS}; do
+ mkdir -p ${DIR}
+ done
+
+ # Remove the execute permission from the setup.sh script
+ # and rename it. Its actions have been incorporated here.
+ chmod a-x setup.sh
+ mv setup.sh setup.sh.done
+
+ # Install the minimal doc (points to web page)
+ #
+ dodoc doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+
+ # The bulk goes into htdocs
+ # but don't copy INSTALL and README
+ cp -pPR [[:lower:]]* "${D}"/"${MY_HTDOCSDIR}"
+
+ # Recursively set server ownership to allow server to write
+ # This is the rough equivalent of the setup.sh script
+ # provided in the distribution.
+ # Note: Cannot use xargs or find -exec here because
+ # these don't work with shell functions.
+ #
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ for DIR in ${DIRS}; do
+ find ${DIR} | while read DIRENTRY; do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${DIRENTRY}
+ done
+ done
+ webapp_serverowned "${MY_HTDOCSDIR}"/tiki-install.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}