summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-03-16 19:15:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-03-16 19:15:32 +0000
commit8e02a743299738c13294dd2986c9a70f9dd2ef87 (patch)
tree0765dc214af7cfb304349322e8403894f7419a66 /www-apps/postfixadmin
parentRemoved old (diff)
downloadgentoo-2-8e02a743299738c13294dd2986c9a70f9dd2ef87.tar.gz
gentoo-2-8e02a743299738c13294dd2986c9a70f9dd2ef87.tar.bz2
gentoo-2-8e02a743299738c13294dd2986c9a70f9dd2ef87.zip
Bump, fixes #291248. Improvements by Allen Brooker and Andreis Vinogradovs.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/postfixadmin')
-rw-r--r--www-apps/postfixadmin/ChangeLog11
-rw-r--r--www-apps/postfixadmin/files/postinstall-en-2.3.txt47
-rw-r--r--www-apps/postfixadmin/metadata.xml4
-rw-r--r--www-apps/postfixadmin/postfixadmin-2.3.ebuild90
4 files changed, 150 insertions, 2 deletions
diff --git a/www-apps/postfixadmin/ChangeLog b/www-apps/postfixadmin/ChangeLog
index f9207dc2f86a..055f013944fa 100644
--- a/www-apps/postfixadmin/ChangeLog
+++ b/www-apps/postfixadmin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/postfixadmin
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/postfixadmin/ChangeLog,v 1.15 2009/10/11 08:39:31 hollow Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/postfixadmin/ChangeLog,v 1.16 2010/03/16 19:15:31 patrick Exp $
+
+*postfixadmin-2.3 (16 Mar 2010)
+
+ 16 Mar 2010; Patrick Lauer <patrick@gentoo.org> +postfixadmin-2.3.ebuild,
+ +files/postinstall-en-2.3.txt, metadata.xml:
+ Bump, fixes #291248. Improvements by Allen Brooker and Andreis
+ Vinogradovs.
11 Oct 2009; Benedikt Böhm <hollow@gentoo.org>
-postfixadmin-2.1.0-r1.ebuild, -postfixadmin-2.2.0.ebuild,
diff --git a/www-apps/postfixadmin/files/postinstall-en-2.3.txt b/www-apps/postfixadmin/files/postinstall-en-2.3.txt
new file mode 100644
index 000000000000..ef6bcf9cf7ea
--- /dev/null
+++ b/www-apps/postfixadmin/files/postinstall-en-2.3.txt
@@ -0,0 +1,47 @@
+You will need to provide a database for your postfixadmin installation.
+
+This assumes you have some knowledge of MySQL, and already have it
+installed and configured. If not, please refer to the Gentoo MySQL
+guide at the following URL:
+
+http://www.gentoo.org/doc/en/mysql-howto.xml
+
+Log in to MySQL, and create a new database as well as a user with full
+access to this database. After that you will need to provide the details
+of this database and the associated user within the file
+
+${MY_INSTALLDIR}/config.inc.php
+
+Make sure you also set
+
+ $CONF['configured'] = true;
+
+in this file.
+
+Finally you should be able to complete the installation of postfixadmin
+by pointing your browser at
+
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/setup.php
+
+
+Updating from older version of Postfix Admin:
+ * When you are upgrading from an older Postfix Admin version, make sure you
+ * backup your database before you run the update script on your database.
+ * mysqldump -a -u root -p > /tmp/postfixadmin-backup.sql
+
+ For update from version 1.5.x of Postfix Admin:
+ 1. Please read the DOCUMENTS/UPGRADE.TXT
+ 2. Run: http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/setup.php
+
+
+To use Virtual Vacation, please read VIRTUAL_VACATION_INSTALL.
+
+Check the config.inc.php file. There you can specify settings that are
+relevant to your setup.
+
+Postfix Admin contains 3 views of administration:
+ 1. Site Admin view, located at http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/admin/.
+ 2. Domain Admin view, located at http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/.
+ 3. User Admin View, located at http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/users/.
+
+In order to do the initial configuration you have to go to the Site Admin view.
diff --git a/www-apps/postfixadmin/metadata.xml b/www-apps/postfixadmin/metadata.xml
index 189c689fbc89..04a95680060f 100644
--- a/www-apps/postfixadmin/metadata.xml
+++ b/www-apps/postfixadmin/metadata.xml
@@ -7,4 +7,8 @@
<name>Gunnar Wrobel</name>
<description>Primary maintainer</description>
</maintainer>
+ <use>
+ <flag name='tests'>Install model unit tests</flag>
+ <flag name='extras'>Install contributed scripts and plugins</flag>
+ </use>
</pkgmetadata>
diff --git a/www-apps/postfixadmin/postfixadmin-2.3.ebuild b/www-apps/postfixadmin/postfixadmin-2.3.ebuild
new file mode 100644
index 000000000000..cdee0a76a863
--- /dev/null
+++ b/www-apps/postfixadmin/postfixadmin-2.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/postfixadmin/postfixadmin-2.3.ebuild,v 1.1 2010/03/16 19:15:31 patrick Exp $
+
+inherit eutils webapp depend.php confutils
+
+DESCRIPTION="Web Based Management tool for Postfix style virtual domains and users."
+HOMEPAGE="http://high5.net/postfixadmin/"
+MY_P="${PN}_${PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="extras mysql postgres tests"
+
+DEPEND="dev-perl/DBI
+ virtual/perl-MIME-Base64
+ dev-perl/Email-Valid
+ dev-perl/Mail-Sender
+ dev-perl/log-dispatch
+ dev-perl/Log-Log4perl
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )"
+RDEPEND="${DEPEND}"
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ confutils_require_any mysql postgres
+
+ if use mysql; then
+ enewgroup vacation
+ enewuser vacation -1 -1 -1 vacation
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ecvs_clean
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # virtual vacation only works with MySQL
+ if use mysql; then
+ diropts -m0770 -o vacation -g vacation
+ dodir /var/spool/vacation
+ keepdir /var/spool/vacation
+ insinto /var/spool/vacation
+ insopts -m770 -o vacation -g vacation
+ doins "${S}"/VIRTUAL_VACATION/vacation.pl
+
+ diropts -m775 -o root -g root
+ insopts -m644 -o root -g root
+
+ mv VIRTUAL_VACATION/INSTALL.TXT VIRTUAL_VACATION_INSTALL.TXT
+ dodoc VIRTUAL_VACATION_INSTALL.TXT
+ rm VIRTUAL_VACATION_INSTALL.TXT
+ fi
+
+ local docs="DOCUMENTS/*.txt CHANGELOG.TXT INSTALL.TXT"
+ dodoc ${docs}
+
+ if ! use extras; then
+ rm -rf ADDITIONS/
+ fi
+
+ if ! use tests; then
+ rm -rf tests
+ fi
+
+ for FILE in DOCUMENTS/ GPL-LICENSE.TXT LICENSE.TXT debian/
+ do
+ rm -rf ${FILE}
+ done
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.inc.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.3.txt
+ webapp_src_install
+}