summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2004-09-08 12:23:16 +0000
committerRenat Lumpau <rl03@gentoo.org>2004-09-08 12:23:16 +0000
commitabe5b59008645e41cb504d9a5bc39396e30d2baf (patch)
treef20297a29d2b04af42951b86a38a2682b1aef110 /www-apps/phpwiki
parentmoved rm's to src_unpack (Manifest recommit) (diff)
downloadgentoo-2-abe5b59008645e41cb504d9a5bc39396e30d2baf.tar.gz
gentoo-2-abe5b59008645e41cb504d9a5bc39396e30d2baf.tar.bz2
gentoo-2-abe5b59008645e41cb504d9a5bc39396e30d2baf.zip
Add new (unstable) version, bug #62951
Diffstat (limited to 'www-apps/phpwiki')
-rw-r--r--www-apps/phpwiki/ChangeLog8
-rw-r--r--www-apps/phpwiki/Manifest7
-rw-r--r--www-apps/phpwiki/files/digest-phpwiki-1.3.101
-rw-r--r--www-apps/phpwiki/files/postinstall-1.3-en.txt3
-rw-r--r--www-apps/phpwiki/phpwiki-1.3.10.ebuild40
5 files changed, 56 insertions, 3 deletions
diff --git a/www-apps/phpwiki/ChangeLog b/www-apps/phpwiki/ChangeLog
index 1984a8a15d7f..883f3ba90bb9 100644
--- a/www-apps/phpwiki/ChangeLog
+++ b/www-apps/phpwiki/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/phpwiki
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/ChangeLog,v 1.4 2004/09/03 17:17:21 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/ChangeLog,v 1.5 2004/09/08 12:23:16 rl03 Exp $
+
+*phpwiki-1.3.10 (08 Sep 2004)
+
+ 08 Sep 2004; Renat Lumpau <rl03@gentoo.org> +files/postinstall-1.3-en.txt,
+ +phpwiki-1.3.10.ebuild:
+ Add new (unstable) version, bug #62951
03 Sep 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
phpwiki-1.2.4.ebuild:
diff --git a/www-apps/phpwiki/Manifest b/www-apps/phpwiki/Manifest
index 0cd2f072386d..af2ee59c8342 100644
--- a/www-apps/phpwiki/Manifest
+++ b/www-apps/phpwiki/Manifest
@@ -1,5 +1,8 @@
-MD5 fb44a9e7de3e56cd86b344e22e674d84 ChangeLog 753
+MD5 884f42364147eb2d68a3718535b8feb0 phpwiki-1.3.10.ebuild 1030
+MD5 1fb3681d7cd00055dcd43c0e6f3d86d1 ChangeLog 929
MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
MD5 59df12ec164dc5e0edc018ff5b723b01 phpwiki-1.2.4.ebuild 805
-MD5 61ddc0899b2191583eb5755c954e5f14 files/digest-phpwiki-1.2.4 65
+MD5 e1cc1101057b18cfb203e30e539d69eb files/digest-phpwiki-1.3.10 67
MD5 c913f380e9beddcca756ea5d0c6fd85f files/postinstall-en.txt 149
+MD5 92c75a61f01013f717a725a91824cd51 files/postinstall-1.3-en.txt 184
+MD5 61ddc0899b2191583eb5755c954e5f14 files/digest-phpwiki-1.2.4 65
diff --git a/www-apps/phpwiki/files/digest-phpwiki-1.3.10 b/www-apps/phpwiki/files/digest-phpwiki-1.3.10
new file mode 100644
index 000000000000..26d9b67c579a
--- /dev/null
+++ b/www-apps/phpwiki/files/digest-phpwiki-1.3.10
@@ -0,0 +1 @@
+MD5 8747352d84836671445a6eb95b2184a7 phpwiki-1.3.10.tar.gz 2072469
diff --git a/www-apps/phpwiki/files/postinstall-1.3-en.txt b/www-apps/phpwiki/files/postinstall-1.3-en.txt
new file mode 100644
index 000000000000..3a4d80a3fdda
--- /dev/null
+++ b/www-apps/phpwiki/files/postinstall-1.3-en.txt
@@ -0,0 +1,3 @@
+The default configuration uses a dbm file in /tmp
+Be sure to read the install notes in /usr/share/doc/${P}/
+You should customise ${MY_INSTALLDIR}/config/config.ini to suit your needs.
diff --git a/www-apps/phpwiki/phpwiki-1.3.10.ebuild b/www-apps/phpwiki/phpwiki-1.3.10.ebuild
new file mode 100644
index 000000000000..a1cafe847d4b
--- /dev/null
+++ b/www-apps/phpwiki/phpwiki-1.3.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/phpwiki-1.3.10.ebuild,v 1.1 2004/09/08 12:23:16 rl03 Exp $
+
+inherit webapp
+
+DESCRIPTION="PhpWiki is a WikiWikiWeb clone in PHP"
+HOMEPAGE="http://phpwiki.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND=">=virtual/php-4.0.6
+ net-www/apache"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm -f Makefile LICENSE
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -a * ${D}/${MY_HTDOCSDIR}
+ rm -rf ${D}/${MY_HTDOCSDIR}/{doc,schemas,README,INSTALL,UPGRADING}
+
+ dodoc README INSTALL UPGRADING doc/* schemas/*
+
+ # Create config file from distribution default, and fix up invalid defaults
+ cd ${D}/${MY_HTDOCSDIR}/config
+ sed "s:;DEBUG = 1:DEBUG = 0:" config-dist.ini > config.ini
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-1.3-en.txt
+ webapp_configfile ${MY_HTDOCSDIR}/config/config.ini
+
+ webapp_src_install
+}