summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-09-16 06:05:08 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-09-16 06:05:08 +0000
commit4e8082fa474e1eb2c58abbc2a1fc14f4a7f09cee (patch)
tree4602d3c12ae6e87725b3b6dda17672b8f85b98ed /www-apps/mythweb
parentMade groups not overwrite. filter --as-needed for now. Clean up commented out... (diff)
downloadgentoo-2-4e8082fa474e1eb2c58abbc2a1fc14f4a7f09cee.tar.gz
gentoo-2-4e8082fa474e1eb2c58abbc2a1fc14f4a7f09cee.tar.bz2
gentoo-2-4e8082fa474e1eb2c58abbc2a1fc14f4a7f09cee.zip
Check for pcre extension in PHP. Work on defaulting some security to MythWeb default install. (masked version)
(Portage version: 2.1.1)
Diffstat (limited to 'www-apps/mythweb')
-rw-r--r--www-apps/mythweb/ChangeLog8
-rw-r--r--www-apps/mythweb/files/postinstall-en-0.20.txt16
-rw-r--r--www-apps/mythweb/mythweb-0.19.ebuild4
-rw-r--r--www-apps/mythweb/mythweb-0.19_p10505.ebuild4
-rw-r--r--www-apps/mythweb/mythweb-0.20_p11188.ebuild8
5 files changed, 32 insertions, 8 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index 64709aa52a3e..be786e533f61 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mythweb
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.22 2006/09/16 02:06:50 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.23 2006/09/16 06:05:08 cardoe Exp $
+
+ 16 Sep 2006; Doug Goldstein <cardoe@gentoo.org>
+ +files/postinstall-en-0.20.txt, mythweb-0.19.ebuild,
+ mythweb-0.19_p10505.ebuild, mythweb-0.20_p11188.ebuild:
+ Check for pcre extension in PHP. Work on defaulting some security to MythWeb
+ default install. (masked version)
16 Sep 2006; Doug Goldstein <cardoe@gentoo.org> mythweb-0.19.ebuild,
mythweb-0.19_p10505.ebuild:
diff --git a/www-apps/mythweb/files/postinstall-en-0.20.txt b/www-apps/mythweb/files/postinstall-en-0.20.txt
new file mode 100644
index 000000000000..e3d7f7962b44
--- /dev/null
+++ b/www-apps/mythweb/files/postinstall-en-0.20.txt
@@ -0,0 +1,16 @@
+You should modify ${MY_INSTALLDIR}/.htaccess to fit your needs.
+
+****************************************************
+In order to prevent unauthorized access to your Myth
+installation, MythWeb has been installed requiring
+authentication by default but with no valid users.
+You can add users by using these instructions:
+
+Run htpasswd2 as follows to set your username and
+password.
+
+# htpasswd2 -c ${MY_INSTALLDIR}/.htpasswd <username>
+
+If you already have an .htpasswd file you'd like to
+use, copy it to ${MY_INSTALLDIR}
+*****************************************************
diff --git a/www-apps/mythweb/mythweb-0.19.ebuild b/www-apps/mythweb/mythweb-0.19.ebuild
index ae04a356ced7..470ac58a9be4 100644
--- a/www-apps/mythweb/mythweb-0.19.ebuild
+++ b/www-apps/mythweb/mythweb-0.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.19.ebuild,v 1.6 2006/09/16 02:06:50 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.19.ebuild,v 1.7 2006/09/16 06:05:08 cardoe Exp $
inherit webapp depend.php
@@ -19,7 +19,7 @@ pkg_setup() {
webapp_pkg_setup
if has_version 'dev-lang/php' ; then
- require_php_with_use session mysql
+ require_php_with_use session mysql pcre
fi
}
diff --git a/www-apps/mythweb/mythweb-0.19_p10505.ebuild b/www-apps/mythweb/mythweb-0.19_p10505.ebuild
index 10a2a0cedf13..f20a24f5a049 100644
--- a/www-apps/mythweb/mythweb-0.19_p10505.ebuild
+++ b/www-apps/mythweb/mythweb-0.19_p10505.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.19_p10505.ebuild,v 1.3 2006/09/16 02:06:50 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.19_p10505.ebuild,v 1.4 2006/09/16 06:05:08 cardoe Exp $
inherit webapp depend.php
@@ -23,7 +23,7 @@ pkg_setup() {
webapp_pkg_setup
if has_version 'dev-lang/php' ; then
- require_php_with_use session mysql
+ require_php_with_use session mysql pcre
fi
}
diff --git a/www-apps/mythweb/mythweb-0.20_p11188.ebuild b/www-apps/mythweb/mythweb-0.20_p11188.ebuild
index 7e8988845830..11445d8105a6 100644
--- a/www-apps/mythweb/mythweb-0.20_p11188.ebuild
+++ b/www-apps/mythweb/mythweb-0.20_p11188.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.20_p11188.ebuild,v 1.1 2006/09/14 21:16:37 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.20_p11188.ebuild,v 1.2 2006/09/16 06:05:08 cardoe Exp $
inherit webapp depend.php
@@ -30,7 +30,7 @@ pkg_setup() {
webapp_pkg_setup
if has_version 'dev-lang/php' ; then
- require_php_with_use session mysql
+ require_php_with_use session mysql pcre
fi
}
@@ -56,7 +56,9 @@ src_install() {
webapp_serverowned ${MY_HTDOCSDIR}/data
webapp_configfile ${MY_HTDOCSDIR}/.htaccess
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_configfile ${MY_HTDOCSDIR}/.htpasswd
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-0.20.txt
webapp_src_install
}