summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-06-11 19:35:12 +0000
committerAlex Legler <a3li@gentoo.org>2009-06-11 19:35:12 +0000
commitdd8f88376ccc963fe09d41e7fa5763dfd133e83c (patch)
tree0bfd0b9e6d57847e084de9e5f301ac4452a5e51f /www-apps/moinmoin
parentalpha/arm/ia64/m68k/s390/sh stable wrt #273037 (diff)
downloadgentoo-2-dd8f88376ccc963fe09d41e7fa5763dfd133e83c.tar.gz
gentoo-2-dd8f88376ccc963fe09d41e7fa5763dfd133e83c.tar.bz2
gentoo-2-dd8f88376ccc963fe09d41e7fa5763dfd133e83c.zip
Non-maintainer commit: Version bumps for Security bug 256621 and 268565.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/moinmoin')
-rw-r--r--www-apps/moinmoin/ChangeLog11
-rw-r--r--www-apps/moinmoin/moinmoin-1.7.3.ebuild75
-rw-r--r--www-apps/moinmoin/moinmoin-1.8.4.ebuild75
3 files changed, 159 insertions, 2 deletions
diff --git a/www-apps/moinmoin/ChangeLog b/www-apps/moinmoin/ChangeLog
index 19b86b6b29d7..3a4398aec611 100644
--- a/www-apps/moinmoin/ChangeLog
+++ b/www-apps/moinmoin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/moinmoin
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moinmoin/ChangeLog,v 1.57 2009/02/01 21:05:58 dertobi123 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moinmoin/ChangeLog,v 1.58 2009/06/11 19:35:12 a3li Exp $
+
+*moinmoin-1.8.4 (11 Jun 2009)
+*moinmoin-1.7.3 (11 Jun 2009)
+
+ 11 Jun 2009; Alex Legler <a3li@gentoo.org> +moinmoin-1.7.3.ebuild,
+ +moinmoin-1.8.4.ebuild:
+ Non-maintainer commit: Version bumps for security bugs 256621 and 268565.
01 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
moinmoin-1.8.1.ebuild:
diff --git a/www-apps/moinmoin/moinmoin-1.7.3.ebuild b/www-apps/moinmoin/moinmoin-1.7.3.ebuild
new file mode 100644
index 000000000000..d03a79f90f52
--- /dev/null
+++ b/www-apps/moinmoin/moinmoin-1.7.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moinmoin/moinmoin-1.7.3.ebuild,v 1.1 2009/06/11 19:35:12 a3li Exp $
+
+MY_PN="moin"
+PYTHON_MODNAME="MoinMoin"
+
+inherit webapp distutils
+
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="Python WikiClone"
+SRC_URI="http://static.moinmo.in/files/${MY_PN}-${PV}.tar.gz"
+HOMEPAGE="http://moinmo.in/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="rss"
+
+DEPEND=">=dev-lang/python-2.3"
+RDEPEND="${DEPEND}
+ >=dev-python/docutils-0.4
+ rss? ( >=dev-python/pyxml-0.8.4 )"
+
+need_httpd_cgi
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+src_install() {
+ webapp_src_preinst
+ distutils_src_install
+
+ dodoc README docs/CHANGES* docs/HACKS docs/README.migration
+ dohtml docs/INSTALL.html
+ rm -rf README docs/
+
+ cd "${D}"/usr/share/moin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r htdocs/* server/moin.cgi
+ fperms +x "${MY_HTDOCSDIR}/moin.cgi"
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}
+ doins -r data underlay config/wikiconfig.py
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}/altconfigs
+ doins -r config
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}/altserver
+ doins -r server
+
+ # data needs to be serverowned per moin devs
+ cd "${D}/${MY_HOSTROOTDIR}"/${PF}
+ for file in $(find data underlay); do
+ webapp_serverowned "${MY_HOSTROOTDIR}/${PF}/${file}"
+ done
+
+ webapp_configfile "${MY_HOSTROOTDIR}"/${PF}/wikiconfig.py
+ webapp_hook_script "${FILESDIR}"/reconfig-3
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are upgrading from 1.3.x, please read"
+ ewarn "README.migration in /usr/share/doc/${PF}"
+ ewarn "and http://moinmoin.wikiwikiweb.de/HelpOnUpdating"
+ ewarn
+
+ distutils_pkg_postinst
+ webapp_pkg_postinst
+}
diff --git a/www-apps/moinmoin/moinmoin-1.8.4.ebuild b/www-apps/moinmoin/moinmoin-1.8.4.ebuild
new file mode 100644
index 000000000000..5dfbc0b681a9
--- /dev/null
+++ b/www-apps/moinmoin/moinmoin-1.8.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moinmoin/moinmoin-1.8.4.ebuild,v 1.1 2009/06/11 19:35:12 a3li Exp $
+
+MY_PN="moin"
+PYTHON_MODNAME="MoinMoin"
+
+inherit webapp distutils
+
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="Python WikiClone"
+SRC_URI="http://static.moinmo.in/files/${MY_PN}-${PV}.tar.gz"
+HOMEPAGE="http://moinmo.in/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="rss"
+
+DEPEND=">=dev-lang/python-2.3"
+RDEPEND="${DEPEND}
+ >=dev-python/docutils-0.4
+ rss? ( >=dev-python/pyxml-0.8.4 )"
+
+need_httpd_cgi
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+src_install() {
+ webapp_src_preinst
+ distutils_src_install
+
+ dodoc README docs/CHANGES* docs/README.migration
+ dohtml docs/INSTALL.html
+ rm -rf README docs/
+
+ cd "${D}"/usr/share/moin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r htdocs/* server/moin.cgi
+ fperms +x "${MY_HTDOCSDIR}/moin.cgi"
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}
+ doins -r data underlay config/wikiconfig.py
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}/altconfigs
+ doins -r config
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}/altserver
+ doins -r server
+
+ # data needs to be serverowned per moin devs
+ cd "${D}/${MY_HOSTROOTDIR}"/${PF}
+ for file in $(find data underlay); do
+ webapp_serverowned "${MY_HOSTROOTDIR}/${PF}/${file}"
+ done
+
+ webapp_configfile "${MY_HOSTROOTDIR}"/${PF}/wikiconfig.py
+ webapp_hook_script "${FILESDIR}"/reconfig-3
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are upgrading from 1.3.x, please read"
+ ewarn "README.migration in /usr/share/doc/${PF}"
+ ewarn "and http://moinmoin.wikiwikiweb.de/HelpOnUpdating"
+ ewarn
+
+ distutils_pkg_postinst
+ webapp_pkg_postinst
+}