summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-10-11 19:42:59 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-10-11 19:42:59 +0000
commitebf6a7d05f48b94124dc4cd7479c0088cece832e (patch)
treed0d825d8da226f677502fa5f162d784c2e984a87 /www-apps/bugzilla
parentVersion bump, removed -j1 as it was fixed upstream. Made installable with gim... (diff)
downloadgentoo-2-ebf6a7d05f48b94124dc4cd7479c0088cece832e.tar.gz
gentoo-2-ebf6a7d05f48b94124dc4cd7479c0088cece832e.tar.bz2
gentoo-2-ebf6a7d05f48b94124dc4cd7479c0088cece832e.zip
Added bugzilla-2.22.5, -3.0.5 in response to sec issue #239564.
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps/bugzilla')
-rw-r--r--www-apps/bugzilla/ChangeLog9
-rw-r--r--www-apps/bugzilla/bugzilla-2.22.5.ebuild77
-rw-r--r--www-apps/bugzilla/bugzilla-3.0.5.ebuild102
3 files changed, 187 insertions, 1 deletions
diff --git a/www-apps/bugzilla/ChangeLog b/www-apps/bugzilla/ChangeLog
index c1c30cd15cb9..bd15ff5b5cfd 100644
--- a/www-apps/bugzilla/ChangeLog
+++ b/www-apps/bugzilla/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/bugzilla
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.118 2008/08/23 04:43:47 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.119 2008/10/11 19:42:59 wrobel Exp $
+
+*bugzilla-3.0.5 (11 Oct 2008)
+*bugzilla-2.22.5 (11 Oct 2008)
+
+ 11 Oct 2008; Gunnar Wrobel <wrobel@gentoo.org> +bugzilla-2.22.5.ebuild,
+ +bugzilla-3.0.5.ebuild:
+ Added bugzilla-2.22.5, -3.0.5 in response to sec issue #239564.
23 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/www-apps/bugzilla/bugzilla-2.22.5.ebuild b/www-apps/bugzilla/bugzilla-2.22.5.ebuild
new file mode 100644
index 000000000000..6f8524c99029
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-2.22.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-2.22.5.ebuild,v 1.1 2008/10/11 19:42:59 wrobel Exp $
+
+inherit webapp depend.apache versionator eutils
+
+MY_PB=$(get_version_component_range 1-2)
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="extras graphviz mysql postgres"
+
+RDEPEND="
+ virtual/httpd-cgi
+ >=dev-lang/perl-5.6.1
+
+ >=dev-perl/AppConfig-1.52
+ >=dev-perl/DBI-1.38
+ >=dev-perl/MailTools-1.67
+ dev-perl/MIME-tools
+ >=dev-perl/Template-Toolkit-2.13
+ >=dev-perl/Text-Tabs+Wrap-2001.0131
+ >=dev-perl/TimeDate-1.16
+ >=virtual/perl-CGI-2.93
+ >=virtual/perl-File-Spec-0.84
+ virtual/perl-File-Temp
+ >=virtual/perl-MIME-Base64-3.01
+ virtual/perl-Storable
+
+ extras? (
+ >=dev-perl/Chart-2.3
+ >=dev-perl/GD-1.20
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil
+ dev-perl/HTML-Scrubber
+ >=dev-perl/PatchReader-0.9.4
+ dev-perl/perl-ldap
+ dev-perl/Template-GD
+ dev-perl/XML-Twig
+ dev-util/patchutils
+ )
+
+ graphviz? ( media-gfx/graphviz )
+ mysql? ( >=dev-perl/DBD-mysql-3.0007 )
+ postgres? ( >=dev-perl/DBD-Pg-1.45 )
+"
+
+need_apache2
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ecvs_clean
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ newins "${FILESDIR}"/${MY_PB}/apache.htaccess .htaccess
+ for f in bugzilla.cron.daily bugzilla.cron.tab; do
+ doins "${FILESDIR}"/${MY_PB}/${f}
+ done
+
+ webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/${MY_PB}/postinstall-en.txt
+ webapp_src_install
+
+ # bug #124282
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+}
diff --git a/www-apps/bugzilla/bugzilla-3.0.5.ebuild b/www-apps/bugzilla/bugzilla-3.0.5.ebuild
new file mode 100644
index 000000000000..5cf9dee522e3
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-3.0.5.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-3.0.5.ebuild,v 1.1 2008/10/11 19:42:59 wrobel Exp $
+
+inherit webapp depend.apache versionator eutils
+
+MY_PB=$(get_version_component_range 1-2)
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz
+ linguas_de? ( http://ganderbay.net/dl/germzilla-${PV}-1.utf-8.tar.gz )"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="modperl extras graphviz mysql postgres linguas_de"
+
+RDEPEND="
+ virtual/httpd-cgi
+ >=dev-lang/perl-5.8.0
+
+ >=dev-perl/DBI-1.41
+ dev-perl/Email-MIME-Modifier
+ >=dev-perl/Email-Send-2.00
+ dev-perl/MIME-tools
+ >=dev-perl/Template-Toolkit-2.13
+ >=dev-perl/TimeDate-1.16
+ >=virtual/perl-CGI-2.93
+ >=virtual/perl-File-Spec-0.84
+ >=virtual/perl-MIME-Base64-3.01
+
+ mysql? ( >=dev-perl/DBD-mysql-3.0007 )
+ postgres? ( >=dev-perl/DBD-Pg-1.45 )
+ graphviz? ( media-gfx/graphviz )
+
+ modperl? (
+ >=dev-perl/Apache-DBI-0.96
+ >=virtual/perl-CGI-3.11
+ =www-apache/mod_perl-2*
+ )
+
+ extras? (
+ >=dev-perl/Chart-2.3
+ dev-perl/Email-MIME-Attachment-Stripper
+ dev-perl/Email-Reply
+ >=dev-perl/GD-1.20
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil
+ >=dev-perl/HTML-Parser-3.40
+ dev-perl/HTML-Scrubber
+ dev-perl/libwww-perl
+ >=dev-perl/PatchReader-0.9.4
+ dev-perl/perl-ldap
+ dev-perl/SOAP-Lite
+ dev-perl/Template-GD
+ dev-perl/XML-Twig
+ )
+"
+
+want_apache modperl
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use extras ; then
+ if ! has_version media-gfx/imagemagick || ! built_with_use media-gfx/imagemagick perl ; then
+ elog "Consider installing media-gfx/imagemagick with USE=\"perl\""
+ elog "to convert BMP attachments to PNG"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ecvs_clean
+
+ if use linguas_de ; then
+ mv ../de template/
+ elog "Installing German translation pack"
+ elog "Be sure to read http://wiki.ganderbay.net/wde/Germzilla-Installation"
+ elog "for installation instructions"
+ fi
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ for f in bugzilla.cron.daily bugzilla.cron.tab; do
+ doins "${FILESDIR}"/${MY_PB}/${f}
+ done
+
+ webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/${MY_PB}/postinstall-en.txt
+ webapp_src_install
+
+ # bug #124282
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+}