summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2007-02-07 03:04:09 +0000
committerRenat Lumpau <rl03@gentoo.org>2007-02-07 03:04:09 +0000
commitc33d0e0557e256abb014044ca77824b27fac7b81 (patch)
tree6d6c8fb60b550f64607a3c4f4dda593a6d7d8a0a /www-apps/bugzilla
parentMasked bleeding edge version of www-apps/bugzilla for testing (diff)
downloadgentoo-2-c33d0e0557e256abb014044ca77824b27fac7b81.tar.gz
gentoo-2-c33d0e0557e256abb014044ca77824b27fac7b81.tar.bz2
gentoo-2-c33d0e0557e256abb014044ca77824b27fac7b81.zip
Added bleeding edge version
(Portage version: 2.1.2-r6)
Diffstat (limited to 'www-apps/bugzilla')
-rw-r--r--www-apps/bugzilla/ChangeLog10
-rw-r--r--www-apps/bugzilla/bugzilla-2.23.4.ebuild91
-rw-r--r--www-apps/bugzilla/files/2.23/postinstall-en.txt12
-rw-r--r--www-apps/bugzilla/files/2.23/reconfig19
-rw-r--r--www-apps/bugzilla/files/bugzilla.cron.daily5
-rw-r--r--www-apps/bugzilla/files/bugzilla.cron.tab1
-rw-r--r--www-apps/bugzilla/files/digest-bugzilla-2.23.43
7 files changed, 140 insertions, 1 deletions
diff --git a/www-apps/bugzilla/ChangeLog b/www-apps/bugzilla/ChangeLog
index 408ca8a22d5f..4f9e03f8a918 100644
--- a/www-apps/bugzilla/ChangeLog
+++ b/www-apps/bugzilla/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/bugzilla
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.77 2007/02/03 23:31:28 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.78 2007/02/07 03:04:09 rl03 Exp $
+
+*bugzilla-2.23.4 (07 Feb 2007)
+
+ 07 Feb 2007; Renat Lumpau <rl03@gentoo.org>
+ +files/2.23/postinstall-en.txt, +files/2.23/reconfig,
+ +files/bugzilla.cron.daily, +files/bugzilla.cron.tab,
+ +bugzilla-2.23.4.ebuild:
+ Added bleeding edge version
*bugzilla-2.22.2 (03 Feb 2007)
*bugzilla-2.20.4 (03 Feb 2007)
diff --git a/www-apps/bugzilla/bugzilla-2.23.4.ebuild b/www-apps/bugzilla/bugzilla-2.23.4.ebuild
new file mode 100644
index 000000000000..aba0e73789e5
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-2.23.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-2.23.4.ebuild,v 1.1 2007/02/07 03:04:09 rl03 Exp $
+
+inherit webapp depend.apache versionator eutils
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+#KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+IUSE="modperl extras graphviz mysql postgres"
+
+RDEPEND="
+ >=dev-lang/perl-5.8.0
+ mysql? ( >=dev-perl/DBD-mysql-3.0007 )
+ postgres? ( >=dev-perl/DBD-Pg-1.45 )
+ graphviz? ( media-gfx/graphviz )
+ >=virtual/perl-CGI-2.93
+ modperl? (
+ >=virtual/perl-CGI-3.11
+ =www-apache/mod_perl-2*
+ >=dev-perl/Apache-DBI-0.96
+ )
+
+ >=dev-perl/TimeDate-1.16
+ >=dev-perl/DBI-1.41
+ >=virtual/perl-File-Spec-0.84
+ >=dev-perl/Template-Toolkit-2.13
+ >=virtual/perl-MIME-Base64-3.01
+ dev-perl/MIME-tools
+ >=dev-perl/Email-Send-2.00
+ dev-perl/Email-MIME-Modifier
+
+ extras? (
+ >=dev-perl/GD-1.20
+ dev-perl/Template-GD
+ >=dev-perl/Chart-2.3
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil
+ dev-perl/XML-Twig
+ dev-perl/libwww-perl
+ >=dev-perl/PatchReader-0.9.4
+ dev-perl/perl-ldap
+ dev-perl/SOAP-Lite
+ >=dev-perl/HTML-Parser-3.40
+ dev-perl/HTML-Scrubber
+ dev-perl/Email-MIME-Attachment-Stripper
+ dev-perl/Email-Reply
+ )
+"
+
+want_apache
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use extras ; then
+ if ! has_version media-gfx/imagemagick || ! built_with_use media-gfx/imagemagick perl ; then
+ elog "Consider installing media-gfx/imagemagick with USE=\"perl\""
+ elog "to convert BMP attachments to PNG"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # remove CVS directories
+ find . -type d -name 'CVS' -print | xargs rm -rf
+}
+
+src_install () {
+ webapp_src_preinst
+
+ cp -r ${S}/* ${D}/${MY_HTDOCSDIR} || die
+
+ local FILE="bugzilla.cron.daily bugzilla.cron.tab"
+ cd ${FILESDIR}
+ cp ${FILE} ${D}/${MY_HTDOCSDIR}
+
+ webapp_hook_script ${FILESDIR}/$(get_version_component_range 1-2)/reconfig
+ webapp_postinst_txt en ${FILESDIR}/$(get_version_component_range 1-2)/postinstall-en.txt
+ webapp_src_install
+
+ # bug #124282
+ chmod -R +x ${D}/${MY_HTDOCSDIR}/*.cgi
+}
diff --git a/www-apps/bugzilla/files/2.23/postinstall-en.txt b/www-apps/bugzilla/files/2.23/postinstall-en.txt
new file mode 100644
index 000000000000..de310ece733a
--- /dev/null
+++ b/www-apps/bugzilla/files/2.23/postinstall-en.txt
@@ -0,0 +1,12 @@
+0. Bugzilla has been installed into ${MY_INSTALLDIR}
+
+1. To finish the installation, please read
+ http://www.bugzilla.org/docs/tip/html/installation.html
+ You will need to run ${MY_INSTALLDIR}/checksetup.pl
+
+2. Please read the Release Notes, especially if you are upgrading:
+ http://www.bugzilla.org/releases/2.23/release-notes.html
+
+3. Please note that Apache2 sets AllowOverride None by default. You may have
+ to edit it to process the .htaccess file provided by Bugzilla. Please see
+ http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride for more info.
diff --git a/www-apps/bugzilla/files/2.23/reconfig b/www-apps/bugzilla/files/2.23/reconfig
new file mode 100644
index 000000000000..71b0acea2585
--- /dev/null
+++ b/www-apps/bugzilla/files/2.23/reconfig
@@ -0,0 +1,19 @@
+#!/bin/bash
+
+FILE="bugzilla.cron.daily bugzilla.cron.tab"
+
+function die ()
+{
+ echo
+ echo "***"
+ echo "*** Fatal error: $*"
+ echo "***"
+ exit 1
+}
+
+if [ $1 = "install" ]; then
+ cd "${MY_INSTALLDIR}" || die "Cannot find install dir ${MY_INSTALLDIR}"
+ sed -e "s|/var/www/bugzilla|${MY_INSTALLDIR}|g" -i ${FILE} || die "sed failed"
+else
+ echo "done."
+fi
diff --git a/www-apps/bugzilla/files/bugzilla.cron.daily b/www-apps/bugzilla/files/bugzilla.cron.daily
new file mode 100644
index 000000000000..e3e86589891d
--- /dev/null
+++ b/www-apps/bugzilla/files/bugzilla.cron.daily
@@ -0,0 +1,5 @@
+#!/bin/sh
+cd /var/www/bugzilla/
+./collectstats.pl
+./whineatnews.pl
+echo "*** Bugzilla nighlty flush has done! ***"
diff --git a/www-apps/bugzilla/files/bugzilla.cron.tab b/www-apps/bugzilla/files/bugzilla.cron.tab
new file mode 100644
index 000000000000..0ac2ef6d65a6
--- /dev/null
+++ b/www-apps/bugzilla/files/bugzilla.cron.tab
@@ -0,0 +1 @@
+0 0 * * * /var/www/bugzilla/bugzilla.cron.daily
diff --git a/www-apps/bugzilla/files/digest-bugzilla-2.23.4 b/www-apps/bugzilla/files/digest-bugzilla-2.23.4
new file mode 100644
index 000000000000..1c1fb01ff2f7
--- /dev/null
+++ b/www-apps/bugzilla/files/digest-bugzilla-2.23.4
@@ -0,0 +1,3 @@
+MD5 9f024e5c893806b0046c63801d1d379c bugzilla-2.23.4.tar.gz 2152724
+RMD160 8a95613a249c534f0291be58a738f6eca09a134e bugzilla-2.23.4.tar.gz 2152724
+SHA256 f9474799f3fd962877244bc269ef9b78dab312eaca0f179738dc443af8f1e460 bugzilla-2.23.4.tar.gz 2152724