summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2004-09-21 16:15:11 +0000
committerRenat Lumpau <rl03@gentoo.org>2004-09-21 16:15:11 +0000
commita436197db3fc5c85ba14f5433e8b079ad73062bf (patch)
tree7db650d6038d478b389386d134430bf286ce96e2 /www-apps/Apache-Gallery
parentnew release, mark .16 stable (Manifest recommit) (diff)
downloadgentoo-2-a436197db3fc5c85ba14f5433e8b079ad73062bf.tar.gz
gentoo-2-a436197db3fc5c85ba14f5433e8b079ad73062bf.tar.bz2
gentoo-2-a436197db3fc5c85ba14f5433e8b079ad73062bf.zip
0.8 is now alive again. See bug #52020
Diffstat (limited to 'www-apps/Apache-Gallery')
-rw-r--r--www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild77
-rw-r--r--www-apps/Apache-Gallery/ChangeLog8
-rw-r--r--www-apps/Apache-Gallery/Manifest7
-rw-r--r--www-apps/Apache-Gallery/files/76_apache-gallery.conf40
-rw-r--r--www-apps/Apache-Gallery/files/apache-gallery.conf11
-rw-r--r--www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.8-r11
-rw-r--r--www-apps/Apache-Gallery/metadata.xml5
7 files changed, 139 insertions, 10 deletions
diff --git a/www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild b/www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild
new file mode 100644
index 000000000000..19dfd832e49f
--- /dev/null
+++ b/www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild,v 1.1 2004/09/21 16:15:11 rl03 Exp $
+
+inherit perl-module webapp
+
+DESCRIPTION="Apache gallery for mod_perl"
+SRC_URI="http://cpan.org/modules/by-module/Apache/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/author/LEGART/${P}"
+
+LICENSE="Artistic | GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha ~sparc"
+IUSE="apache2"
+
+DEPEND="${DEPEND}
+ >=dev-perl/libapreq-1.0
+ >=media-libs/imlib2-1.0.6-r1
+ >=dev-perl/mod_perl-1.27-r1
+ >=dev-perl/ImageInfo-1.04-r2
+ >=dev-perl/ImageSize-2.99-r1
+ dev-perl/Image-Imlib2
+ >=dev-perl/CGI-2.93
+ >=dev-perl/CGI-FastTemplate-1.09
+ >=dev-perl/Parse-RecDescent-1.80-r3
+ dev-perl/URI
+ dev-perl/text-template
+ >=dev-perl/Inline-0.43-r1
+ virtual/x11
+ !apache2? ( >=net-www/apache-1.3.26-r2 )
+ apache2? ( >=net-www/apache-2.0.43-r1 ) "
+
+src_install() {
+ webapp_src_preinst
+ mydoc="INSTALL"
+
+ perl-module_src_install
+
+ insinto ${MY_ICONSDIR}
+ doins htdocs/*.png
+
+ dodir ${MY_HOSTROOTDIR}/${PN}/templates/default
+ dodir ${MY_HOSTROOTDIR}/${PN}/templates/new
+
+ insinto ${MY_HOSTROOTDIR}/${PN}/templates/default
+ doins templates/default/*.tpl
+ insinto ${MY_HOSTROOTDIR}/${PN}/templates/new
+ doins templates/default/*.tpl
+
+ if use apache2; then
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/76_apache-gallery.conf
+ else
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/apache-gallery.conf
+ fi
+ webapp_src_install
+}
+
+pkg_postinst() {
+ if use apache2; then
+ einfo
+ einfo "You should edit your /etc/apache2/conf/modules.d/76_apache-gallery.conf file to suit."
+ else
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated."
+ einfo "You should then edit your /etc/apache/conf/addon-modules/apache-gallery.conf file to suit."
+ einfo
+ fi
+ webapp_pkg_postinst
+}
+
+pkg_config() {
+ use apache2 || \
+ echo "Include /etc/apache/conf/addon-modules/apache-gallery.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}
diff --git a/www-apps/Apache-Gallery/ChangeLog b/www-apps/Apache-Gallery/ChangeLog
index 8a723b9b4d99..ee8b9014687f 100644
--- a/www-apps/Apache-Gallery/ChangeLog
+++ b/www-apps/Apache-Gallery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/Apache-Gallery
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/ChangeLog,v 1.4 2004/09/20 14:22:16 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/ChangeLog,v 1.5 2004/09/21 16:15:11 rl03 Exp $
+
+*Apache-Gallery-0.8-r1 (21 Sep 2004)
+
+ 21 Sep 2004; Renat Lumpau <rl03@gentoo.org> metadata.xml,
+ files/apache-gallery.conf, +Apache-Gallery-0.8-r1.ebuild:
+ Version bump, this time done right. Resolves bug #52020.
20 Sep 2004; Michael Cummings <mcummings@gentoo.org>
Apache-Gallery-0.8.ebuild:
diff --git a/www-apps/Apache-Gallery/Manifest b/www-apps/Apache-Gallery/Manifest
index faeb1c0d52e4..76359a4b9e56 100644
--- a/www-apps/Apache-Gallery/Manifest
+++ b/www-apps/Apache-Gallery/Manifest
@@ -1,7 +1,10 @@
MD5 3cf94c60bc26a088941c247b3abcbaf7 Apache-Gallery-0.6.ebuild 1450
MD5 50358c94d1a1ea514ffd007933cc8ce2 Apache-Gallery-0.8.ebuild 1515
+MD5 43cfaa77cdebc2866bb1a6195356f313 Apache-Gallery-0.8-r1.ebuild 2006
MD5 c0482cd2c9339278805f5a32e95db7aa ChangeLog 1630
-MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
-MD5 d7306e4a4568b0c242ef3b73d3ad0e4e files/apache-gallery.conf 719
+MD5 2a5bdc93be7720976d88be5034a17df2 metadata.xml 444
+MD5 3c77fe3e38d06f53fca962becfe10d81 files/digest-Apache-Gallery-0.8-r1 69
MD5 f372bf3342f63c4d3a680051e80b5571 files/digest-Apache-Gallery-0.6 69
MD5 3c77fe3e38d06f53fca962becfe10d81 files/digest-Apache-Gallery-0.8 69
+MD5 d9a1361f6d0f1dac9def27a0b57cf30c files/apache-gallery.conf 757
+MD5 862b7db14e194f66c345bdaee71e0d00 files/76_apache-gallery.conf 1461
diff --git a/www-apps/Apache-Gallery/files/76_apache-gallery.conf b/www-apps/Apache-Gallery/files/76_apache-gallery.conf
new file mode 100644
index 000000000000..8ce0eb0c3c3d
--- /dev/null
+++ b/www-apps/Apache-Gallery/files/76_apache-gallery.conf
@@ -0,0 +1,40 @@
+##### Apache::Gallery configuration
+#
+# This is actually a virtual host definition with mod_perl directives
+# It might be a very good idea to disable mod_autoindex in apache[2].conf
+#
+
+#<VirtualHost 123.123.123.123>
+# ServerName gallery.yourdomain.org
+# DocumentRoot /var/www/localhost/htdocs/data/pictures/
+# ErrorLog /var/log/gallery-error_log
+# TransferLog /var/log/gallery-access_log
+# <IfDefine MODPERL2>
+# PerlSetVar GalleryTemplateDir '/var/www/localhost/Apache-Gallery/templates/default'
+# PerlSetVar GalleryInfo 'Picture Taken => DateTimeOriginal, Flash => Flash'
+# PerlSetVar GallerySizes '640 1024 1600 2272'
+# PerlSetVar GalleryThumbnailSize '100x75'
+## If you have a copyright overlay image set the location of it
+# PerlSetVar GalleryCopyrightImage 'htdocs/c.png'
+## If you use Apache2 set the following "PerlOptions" too
+# PerlOptions +GlobalRequest
+# <Location />
+# SetHandler modperl
+# PerlResponseHandler Apache::Gallery
+# Options -Indexes
+# AllowOverride AuthConfig
+# Order deny,allow
+# Allow from all
+# </Location>
+# </IfDefine>
+## Allow access to cache
+# <Directory /var/tmp/Apache-Gallery>
+# Options -ALL
+# AllowOverride None
+# Order deny,allow
+# Allow from all
+# </Directory>
+## Give Apache an idea of where to find icons and css
+# Alias /icons /var/www/localhost/icons
+# Alias /gallery.css /var/www/localhost/Apache-Gallery/templates/default/gallery.css
+#</VirtualHost>
diff --git a/www-apps/Apache-Gallery/files/apache-gallery.conf b/www-apps/Apache-Gallery/files/apache-gallery.conf
index 364635d512c9..dfa55426b31c 100644
--- a/www-apps/Apache-Gallery/files/apache-gallery.conf
+++ b/www-apps/Apache-Gallery/files/apache-gallery.conf
@@ -1,5 +1,3 @@
-
-
##### Apache::Gallery configuration
#
# This is actually a virtual host definition with mod_perl directives
@@ -7,10 +5,10 @@
#<VirtualHost 123.123.123.123>
# ServerName gallery.yourdomain.org
-# DocumentRoot /data/pictures/
-# ErrorLog logs/gallery-error_log
-# TransferLog logs/gallery-access_log
-# PerlSetVar GalleryTemplateDir '/etc/apache/gallery/templates'
+# DocumentRoot /var/www/localhost/htdocs/data/pictures/
+# ErrorLog /var/log/gallery-error_log
+# TransferLog /var/log/gallery-access_log
+# PerlSetVar GalleryTemplateDir '/var/www/localhost/Apache-Gallery/templates'
# PerlSetVar GalleryInfo 'Picture Taken => DateTimeOriginal, Flash => Flash'
# PerlSetVar GallerySizes '640 1024 1600 2272'
# PerlSetVar GalleryThumbnailSize '100x75'
@@ -20,4 +18,3 @@
# PerlHandler Apache::Gallery
# </Location>
#</VirtualHost>
-
diff --git a/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.8-r1 b/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.8-r1
new file mode 100644
index 000000000000..751d21f9d580
--- /dev/null
+++ b/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.8-r1
@@ -0,0 +1 @@
+MD5 c04d7d8edc90982eae68a431077f9413 Apache-Gallery-0.8.tar.gz 77184
diff --git a/www-apps/Apache-Gallery/metadata.xml b/www-apps/Apache-Gallery/metadata.xml
index 86672fe64c10..867de5ad9ad5 100644
--- a/www-apps/Apache-Gallery/metadata.xml
+++ b/www-apps/Apache-Gallery/metadata.xml
@@ -6,5 +6,10 @@
<email>perl@gentoo.org</email>
<description>Primary Maintainer</description>
</maintainer>
+ <herd>web-apps</herd>
+ <maintainer>
+ <email>web-apps@gentoo.org</email>
+ <description>Secondary Maintainer</description>
+ </maintainer>
<longdescription></longdescription>
</pkgmetadata>