summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-03-07 13:57:38 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-03-07 13:57:38 +0000
commit3a6518eafeeb559a05d43078c87da7829fcf3f35 (patch)
tree801b744df6e015dda7142becf8276ab8d13ecd7a /www-apps/Apache-Gallery
parentChanged hardcoded /opt/soldieroffortune to dir variable and closing bug #84361. (diff)
downloadgentoo-2-3a6518eafeeb559a05d43078c87da7829fcf3f35.tar.gz
gentoo-2-3a6518eafeeb559a05d43078c87da7829fcf3f35.tar.bz2
gentoo-2-3a6518eafeeb559a05d43078c87da7829fcf3f35.zip
Bug 71196
(Portage version: 2.0.51-r13)
Diffstat (limited to 'www-apps/Apache-Gallery')
-rw-r--r--www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild4
-rw-r--r--www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild10
-rw-r--r--www-apps/Apache-Gallery/Apache-Gallery-0.8-r2.ebuild77
-rw-r--r--www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild4
-rw-r--r--www-apps/Apache-Gallery/ChangeLog9
-rw-r--r--www-apps/Apache-Gallery/Manifest12
-rw-r--r--www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.8-r21
7 files changed, 101 insertions, 16 deletions
diff --git a/www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild b/www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild
index 6a258e720425..4c2da0290cbe 100644
--- a/www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild
+++ b/www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild,v 1.3 2004/11/08 08:41:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild,v 1.4 2005/03/07 13:57:38 mcummings Exp $
inherit perl-module
diff --git a/www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild b/www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild
index cd0ebdb44bbf..a22733862b78 100644
--- a/www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild
+++ b/www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild,v 1.2 2004/11/08 08:41:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/Apache-Gallery-0.8-r1.ebuild,v 1.3 2005/03/07 13:57:38 mcummings Exp $
inherit perl-module webapp
@@ -35,16 +35,16 @@ src_install() {
perl-module_src_install
- insinto ${MY_ICONSDIR}
+ insinto ${MY_ICONSDIR}/gallery
doins htdocs/*.png
dodir ${MY_HOSTROOTDIR}/${PN}/templates/default
dodir ${MY_HOSTROOTDIR}/${PN}/templates/new
insinto ${MY_HOSTROOTDIR}/${PN}/templates/default
- doins templates/default/*.tpl
+ doins templates/default/*
insinto ${MY_HOSTROOTDIR}/${PN}/templates/new
- doins templates/default/*.tpl
+ doins templates/new/*
if use apache2; then
insinto /etc/apache2/conf/modules.d
diff --git a/www-apps/Apache-Gallery/Apache-Gallery-0.8-r2.ebuild b/www-apps/Apache-Gallery/Apache-Gallery-0.8-r2.ebuild
new file mode 100644
index 000000000000..a0722f5525b9
--- /dev/null
+++ b/www-apps/Apache-Gallery/Apache-Gallery-0.8-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/Apache-Gallery-0.8-r2.ebuild,v 1.1 2005/03/07 13:57:38 mcummings Exp $
+
+inherit perl-module webapp
+
+DESCRIPTION="Apache gallery for mod_perl"
+SRC_URI="http://cpan.org/modules/by-module/Apache/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/author/LEGART/${P}"
+
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha ~sparc"
+IUSE="apache2"
+
+DEPEND="${DEPEND}
+ >=dev-perl/libapreq-1.0
+ >=media-libs/imlib2-1.0.6-r1
+ >=dev-perl/mod_perl-1.27-r1
+ >=dev-perl/ImageInfo-1.04-r2
+ >=dev-perl/ImageSize-2.99-r1
+ dev-perl/Image-Imlib2
+ >=dev-perl/CGI-2.93
+ >=dev-perl/CGI-FastTemplate-1.09
+ >=dev-perl/Parse-RecDescent-1.80-r3
+ dev-perl/URI
+ dev-perl/text-template
+ >=dev-perl/Inline-0.43-r1
+ virtual/x11
+ !apache2? ( >=net-www/apache-1.3.26-r2 )
+ apache2? ( >=net-www/apache-2.0.43-r1 ) "
+
+src_install() {
+ webapp_src_preinst
+ mydoc="INSTALL"
+
+ perl-module_src_install
+
+ insinto ${MY_ICONSDIR}/gallery
+ doins htdocs/*.png
+
+ dodir ${MY_HOSTROOTDIR}/${PN}/templates/default
+ dodir ${MY_HOSTROOTDIR}/${PN}/templates/new
+
+ insinto ${MY_HOSTROOTDIR}/${PN}/templates/default
+ doins templates/default/*
+ insinto ${MY_HOSTROOTDIR}/${PN}/templates/new
+ doins templates/new/*
+
+ if use apache2; then
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/76_apache-gallery.conf
+ else
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/apache-gallery.conf
+ fi
+ webapp_src_install
+}
+
+pkg_postinst() {
+ if use apache2; then
+ einfo
+ einfo "You should edit your /etc/apache2/conf/modules.d/76_apache-gallery.conf file to suit."
+ else
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated."
+ einfo "You should then edit your /etc/apache/conf/addon-modules/apache-gallery.conf file to suit."
+ einfo
+ fi
+ webapp_pkg_postinst
+}
+
+pkg_config() {
+ use apache2 || \
+ echo "Include /etc/apache/conf/addon-modules/apache-gallery.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}
diff --git a/www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild b/www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild
index ca7ace096ae1..7712b1e8fbfe 100644
--- a/www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild
+++ b/www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild,v 1.3 2004/11/08 08:41:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild,v 1.4 2005/03/07 13:57:38 mcummings Exp $
inherit perl-module
diff --git a/www-apps/Apache-Gallery/ChangeLog b/www-apps/Apache-Gallery/ChangeLog
index ee8b9014687f..703d28e46d52 100644
--- a/www-apps/Apache-Gallery/ChangeLog
+++ b/www-apps/Apache-Gallery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/Apache-Gallery
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/ChangeLog,v 1.5 2004/09/21 16:15:11 rl03 Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/ChangeLog,v 1.6 2005/03/07 13:57:38 mcummings Exp $
+
+ 07 Mar 2005; Michael Cummings <mcummings@gentoo.org>
+ Apache-Gallery-0.8-r1.ebuild:
+ Modified what's installed from templates [ bug 71196 - thanks to Wayne Love
+ <wayne@wslove.org> ]. Also corrected default vs new ins's.
*Apache-Gallery-0.8-r1 (21 Sep 2004)
diff --git a/www-apps/Apache-Gallery/Manifest b/www-apps/Apache-Gallery/Manifest
index bbff569739da..bbe538738db6 100644
--- a/www-apps/Apache-Gallery/Manifest
+++ b/www-apps/Apache-Gallery/Manifest
@@ -1,10 +1,12 @@
-MD5 63a5498ffffd77982c47f3815e8b73c5 Apache-Gallery-0.6.ebuild 1456
-MD5 2102a3f67e5bacb198da4ad115a07e41 Apache-Gallery-0.8.ebuild 1520
-MD5 c0c26af618dba357a87975c267d118fe ChangeLog 1843
+MD5 8c9ab7bd397f3cbc2c00c6a537b7f319 Apache-Gallery-0.6.ebuild 1456
+MD5 63c829746447ae49d60a044379616e03 Apache-Gallery-0.8-r1.ebuild 2120
+MD5 5f96ea180b6f3d3b990f3ce5b3dd6400 Apache-Gallery-0.8.ebuild 1520
+MD5 0bab2a38fc51423128637c82c7cc486b ChangeLog 2070
MD5 2a5bdc93be7720976d88be5034a17df2 metadata.xml 444
-MD5 47ac442329d44db7f16d50a1f7500083 Apache-Gallery-0.8-r1.ebuild 2124
+MD5 53db80488be453b09c0d6e48d518a6c7 Apache-Gallery-0.8-r2.ebuild 2003
+MD5 862b7db14e194f66c345bdaee71e0d00 files/76_apache-gallery.conf 1461
MD5 d9a1361f6d0f1dac9def27a0b57cf30c files/apache-gallery.conf 757
MD5 f372bf3342f63c4d3a680051e80b5571 files/digest-Apache-Gallery-0.6 69
MD5 3c77fe3e38d06f53fca962becfe10d81 files/digest-Apache-Gallery-0.8 69
-MD5 862b7db14e194f66c345bdaee71e0d00 files/76_apache-gallery.conf 1461
MD5 3c77fe3e38d06f53fca962becfe10d81 files/digest-Apache-Gallery-0.8-r1 69
+MD5 3c77fe3e38d06f53fca962becfe10d81 files/digest-Apache-Gallery-0.8-r2 69
diff --git a/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.8-r2 b/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.8-r2
new file mode 100644
index 000000000000..751d21f9d580
--- /dev/null
+++ b/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.8-r2
@@ -0,0 +1 @@
+MD5 c04d7d8edc90982eae68a431077f9413 Apache-Gallery-0.8.tar.gz 77184