summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-16 17:34:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-16 17:34:52 +0000
commit9eacf655eed8003e84aa484453ad3c9706a392cf (patch)
tree01b3f6729aefe0b5f303df588c00e8191f88cdbb /www-apache
parentalpha/ia64/sparc stable wrt #412983 (diff)
downloadgentoo-2-9eacf655eed8003e84aa484453ad3c9706a392cf.tar.gz
gentoo-2-9eacf655eed8003e84aa484453ad3c9706a392cf.tar.bz2
gentoo-2-9eacf655eed8003e84aa484453ad3c9706a392cf.zip
Version bump; remove old; fix 2.6.3 to use only automake 1.11 (since 1.12 will fail); do not rebuild autotools on the new versions.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_security/ChangeLog10
-rw-r--r--www-apache/mod_security/mod_security-2.6.1.ebuild96
-rw-r--r--www-apache/mod_security/mod_security-2.6.3.ebuild4
-rw-r--r--www-apache/mod_security/mod_security-2.6.6.ebuild (renamed from www-apache/mod_security/mod_security-2.6.5.ebuild)6
4 files changed, 14 insertions, 102 deletions
diff --git a/www-apache/mod_security/ChangeLog b/www-apache/mod_security/ChangeLog
index 686d4299cdde..87f1568d8d8e 100644
--- a/www-apache/mod_security/ChangeLog
+++ b/www-apache/mod_security/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apache/mod_security
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.72 2012/04/01 15:39:12 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.73 2012/06/16 17:34:52 flameeyes Exp $
+
+*mod_security-2.6.6 (16 Jun 2012)
+
+ 16 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +mod_security-2.6.6.ebuild, -mod_security-2.6.1.ebuild,
+ -mod_security-2.6.5.ebuild, mod_security-2.6.3.ebuild:
+ Version bump; remove old; fix 2.6.3 to use only automake 1.11 (since 1.12 will
+ fail); do not rebuild autotools on the new versions.
01 Apr 2012; Raúl Porcel <armin76@gentoo.org> mod_security-2.6.3.ebuild:
sparc stable wrt #409199
diff --git a/www-apache/mod_security/mod_security-2.6.1.ebuild b/www-apache/mod_security/mod_security-2.6.1.ebuild
deleted file mode 100644
index 8eeeda330a99..000000000000
--- a/www-apache/mod_security/mod_security-2.6.1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.6.1.ebuild,v 1.4 2011/12/18 17:30:24 armin76 Exp $
-
-EAPI=4
-
-inherit apache-module autotools
-
-MY_PN=modsecurity-apache
-MY_PV=${PV/_rc/-rc}
-MY_P=${MY_PN}_${MY_PV}
-
-DESCRIPTION="Web application firewall and Intrusion Detection System for Apache."
-HOMEPAGE="http://www.modsecurity.org/"
-SRC_URI="mirror://sourceforge/project/mod-security/${MY_PN}/${MY_PV}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~ppc sparc x86"
-IUSE="geoip curl lua"
-
-DEPEND=">=dev-libs/libxml2-2.7.8
- dev-libs/libpcre
- lua? ( >=dev-lang/lua-5.1 )
- curl? ( >=net-misc/curl-7.15.1 )
- www-servers/apache[apache2_modules_unique_id]"
-RDEPEND="${DEPEND}
- geoip? ( dev-libs/geoip )"
-PDEPEND="www-apache/modsecurity-crs"
-
-S="${WORKDIR}/${MY_P}"
-
-APACHE2_MOD_FILE="apache2/.libs/${PN}2.so"
-APACHE2_MOD_DEFINE="SECURITY"
-
-# Tests require symbols only defined within the Apache binary.
-RESTRICT=test
-
-need_apache2
-
-src_prepare() {
- cp "${FILESDIR}"/modsecurity.conf "${T}"/79_modsecurity.conf || die
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-shared --disable-static \
- --with-apxs="${APXS}" \
- $(use_enable curl mlogc) \
- $(use_with lua) \
- || die "econf failed"
-}
-
-src_compile() {
- if ! use geoip; then
- sed -i -e '/SecGeoLookupDb/s:^:#:' \
- "${T}"/79_modsecurity.conf || die
- fi
-
- emake || die
-}
-
-src_test() {
- emake check || die
-}
-
-src_install() {
- apache-module_src_install
-
- # install manually rather than by using the APACHE2_MOD_CONF
- # variable since we have to edit it to set things up properly.
- insinto "${APACHE_MODULES_CONFDIR}"
- doins "${T}"/79_modsecurity.conf
-
- dodoc CHANGES
-
- keepdir /var/cache/modsecurity
- fowners apache:apache /var/cache/modsecurity
- fperms 0770 /var/cache/modsecurity
-}
-
-pkg_postinst() {
- if [[ -f "${ROOT}"/etc/apache/modules.d/99_mod_security.conf ]]; then
- ewarn "You still have the configuration file 99_mod_security.conf."
- ewarn "Please make sure to remove that and keep only 79_modsecurity.conf."
- ewarn ""
- fi
- elog "The base configuration file has been renamed 79_modsecurity.conf"
- elog "so that you can put your own configuration as 90_modsecurity_local.conf or"
- elog "equivalent."
- elog ""
- elog "That would be the correct place for site-global security rules."
- elog "Note: 80_modsecurity_crs.conf is used by www-apache/modsecurity-crs"
-}
diff --git a/www-apache/mod_security/mod_security-2.6.3.ebuild b/www-apache/mod_security/mod_security-2.6.3.ebuild
index d3aace5d4d71..e087084578ae 100644
--- a/www-apache/mod_security/mod_security-2.6.3.ebuild
+++ b/www-apache/mod_security/mod_security-2.6.3.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.6.3.ebuild,v 1.5 2012/04/01 15:39:12 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.6.3.ebuild,v 1.6 2012/06/16 17:34:52 flameeyes Exp $
EAPI=4
+WANT_AUTOMAKE=1.11
+
inherit apache-module autotools
MY_PN=modsecurity-apache
diff --git a/www-apache/mod_security/mod_security-2.6.5.ebuild b/www-apache/mod_security/mod_security-2.6.6.ebuild
index 4e209b840289..41173a57cca0 100644
--- a/www-apache/mod_security/mod_security-2.6.5.ebuild
+++ b/www-apache/mod_security/mod_security-2.6.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.6.5.ebuild,v 1.1 2012/03/21 16:29:24 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.6.6.ebuild,v 1.1 2012/06/16 17:34:52 flameeyes Exp $
EAPI=4
-inherit apache-module autotools
+inherit apache-module
MY_PN=modsecurity-apache
MY_PV=${PV/_rc/-rc}
@@ -40,8 +40,6 @@ need_apache2
src_prepare() {
cp "${FILESDIR}"/modsecurity.conf "${T}"/79_modsecurity.conf || die
-
- eautoreconf
}
src_configure() {