summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-09-08 17:04:33 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-09-08 17:04:33 +0000
commitfc290a08eca5720575724c4fd05449b8631329d1 (patch)
treefb687acf3e41216417f4b6a3c1395b71db2e9abc /www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild
parentremove vulnerable version (diff)
downloadgentoo-2-fc290a08eca5720575724c4fd05449b8631329d1.tar.gz
gentoo-2-fc290a08eca5720575724c4fd05449b8631329d1.tar.bz2
gentoo-2-fc290a08eca5720575724c4fd05449b8631329d1.zip
initial version
(Portage version: 2.1.3.7)
Diffstat (limited to 'www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild')
-rw-r--r--www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild b/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild
new file mode 100644
index 000000000000..9143f047be2d
--- /dev/null
+++ b/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild,v 1.1 2007/09/08 17:04:32 hollow Exp $
+
+inherit apache-module eutils toolchain-funcs
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Apache2 modules to debug segmentation faults in threads"
+HOMEPAGE="http://people.apache.org/~trawick/exception_hook.html"
+SRC_URI="mirror://gentoo/${P}.c"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="WHATKILLEDUS"
+
+need_apache2
+
+src_unpack() {
+ mkdir -p "${S}" || die "mkdir S failed"
+ cp -f "${DISTDIR}/${P}.c" "${S}/${PN}.c" || die "source copy failed"
+}
+
+src_compile() {
+ $(tc-getCC) \
+ $($(apr_config) --includes) \
+ $($(apr_config) --cppflags) \
+ -o "${S}"/gen_test_char \
+ "${FILESDIR}"/gen_test_char.c
+ "${S}"/gen_test_char > "${S}"/test_char.h
+ apache-module_src_compile
+}