summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-05-26 05:27:45 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-05-26 05:27:45 +0000
commit89f368dc222b37fb6c48590ec450ceec5ed278e7 (patch)
treebdd6696db23db510568f3cbadd6f9985626da816 /www-apache/mod_auth_openid
parentRemove ruby18 fragments. (diff)
downloadgentoo-2-89f368dc222b37fb6c48590ec450ceec5ed278e7.tar.gz
gentoo-2-89f368dc222b37fb6c48590ec450ceec5ed278e7.tar.bz2
gentoo-2-89f368dc222b37fb6c48590ec450ceec5ed278e7.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'www-apache/mod_auth_openid')
-rw-r--r--www-apache/mod_auth_openid/ChangeLog10
-rw-r--r--www-apache/mod_auth_openid/mod_auth_openid-0.8.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/www-apache/mod_auth_openid/ChangeLog b/www-apache/mod_auth_openid/ChangeLog
index 1e92267a5327..42d6076527e8 100644
--- a/www-apache/mod_auth_openid/ChangeLog
+++ b/www-apache/mod_auth_openid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_auth_openid
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/ChangeLog,v 1.8 2012/12/09 16:49:44 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/ChangeLog,v 1.9 2014/05/26 05:27:45 polynomial-c Exp $
+
+*mod_auth_openid-0.8 (26 May 2014)
+
+ 26 May 2014; Lars Wendler <polynomial-c@gentoo.org>
+ +mod_auth_openid-0.8.ebuild:
+ non-maintainer commit: Version bump.
09 Dec 2012; Ulrich Müller <ulm@gentoo.org> mod_auth_openid-0.6.ebuild:
Fix LICENSE, MIT (Expat) license according to COPYING.
diff --git a/www-apache/mod_auth_openid/mod_auth_openid-0.8.ebuild b/www-apache/mod_auth_openid/mod_auth_openid-0.8.ebuild
new file mode 100644
index 000000000000..864543934168
--- /dev/null
+++ b/www-apache/mod_auth_openid/mod_auth_openid-0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/mod_auth_openid-0.8.ebuild,v 1.1 2014/05/26 05:27:45 polynomial-c Exp $
+
+EAPI=5
+
+inherit apache-module
+
+DESCRIPTION="An OpenID authentication module for the apache webserver"
+HOMEPAGE="http://findingscience.com/mod_auth_openid/"
+SRC_URI="https://github.com/bmuller/mod_auth_openid/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/sqlite-3
+ dev-libs/libpcre
+ >=net-libs/libopkele-2.0
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTH_OPENID"
+
+need_apache2_2
+
+src_configure() {
+ econf --with-apxs="${APXS}" \
+ --with-sqlite3=/usr \
+ --with-apr-config=/usr/bin/apr-1-config
+}
+
+src_compile() {
+ # default src_compile fails
+ emake
+}