summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-05-08 19:13:27 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-05-08 19:13:27 +0000
commit68d245163caf2c47c456c97196b68b402ac072d6 (patch)
treef2c637d41b32687f2782f821dafdb678ea7b4829 /www-apache/mod_auth_openid
parentVersion bump by Thomas Beierlein from #-sunrise. (diff)
downloadgentoo-2-68d245163caf2c47c456c97196b68b402ac072d6.tar.gz
gentoo-2-68d245163caf2c47c456c97196b68b402ac072d6.tar.bz2
gentoo-2-68d245163caf2c47c456c97196b68b402ac072d6.zip
fix #220595
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'www-apache/mod_auth_openid')
-rw-r--r--www-apache/mod_auth_openid/ChangeLog8
-rw-r--r--www-apache/mod_auth_openid/mod_auth_openid-0.2-r1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/www-apache/mod_auth_openid/ChangeLog b/www-apache/mod_auth_openid/ChangeLog
index 840f34f9e37f..8081f283c677 100644
--- a/www-apache/mod_auth_openid/ChangeLog
+++ b/www-apache/mod_auth_openid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_auth_openid
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/ChangeLog,v 1.1 2008/03/22 19:20:30 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/ChangeLog,v 1.2 2008/05/08 19:13:27 hollow Exp $
+
+*mod_auth_openid-0.2-r1 (08 May 2008)
+
+ 08 May 2008; Benedikt Böhm <hollow@gentoo.org>
+ +mod_auth_openid-0.2-r1.ebuild:
+ fix #220595
*mod_auth_openid-0.2 (22 Mar 2008)
diff --git a/www-apache/mod_auth_openid/mod_auth_openid-0.2-r1.ebuild b/www-apache/mod_auth_openid/mod_auth_openid-0.2-r1.ebuild
new file mode 100644
index 000000000000..3e3f21c29526
--- /dev/null
+++ b/www-apache/mod_auth_openid/mod_auth_openid-0.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/mod_auth_openid-0.2-r1.ebuild,v 1.1 2008/05/08 19:13:27 hollow Exp $
+
+inherit eutils apache-module autotools
+
+DESCRIPTION="an OpenID authentication module for the apache webserver"
+HOMEPAGE="http://trac.butterfat.net/public/mod_auth_openid"
+SRC_URI="http://butterfat.net/releases/mod_auth_openid/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/apr
+ net-libs/libopkele
+ >=dev-db/sqlite-3"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTH_OPENID"
+
+need_apache2
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e '/^ACLOCAL_AMFLAGS=/d' Makefile.am
+
+ AT_M4DIR="acinclude.d"
+ eautoreconf
+}
+
+src_compile() {
+ econf --with-apxs="${APXS}" \
+ --without-bdb-dir \
+ --with-sqlite3=/usr \
+ --with-apr-config=/usr/bin/apr-1-config \
+ || die "econf failed"
+ emake || die "emake failed"
+}