summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-30 12:24:48 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-30 12:24:48 +0000
commitd4a618cdb257121680a588b82be5d5722124e8e9 (patch)
tree47db77d3f5845a417f7a46122bbb2fa0efc7fd13 /virtual/ruby-ssl
parentBump eapi, update to current gnome2.eclass policies, fix tests and HOMEPAGE (... (diff)
downloadgentoo-2-d4a618cdb257121680a588b82be5d5722124e8e9.tar.gz
gentoo-2-d4a618cdb257121680a588b82be5d5722124e8e9.tar.bz2
gentoo-2-d4a618cdb257121680a588b82be5d5722124e8e9.zip
Add a version for ruby22.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'virtual/ruby-ssl')
-rw-r--r--virtual/ruby-ssl/ChangeLog7
-rw-r--r--virtual/ruby-ssl/ruby-ssl-5.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/virtual/ruby-ssl/ChangeLog b/virtual/ruby-ssl/ChangeLog
index e2e597cc92b5..92253a0156c9 100644
--- a/virtual/ruby-ssl/ChangeLog
+++ b/virtual/ruby-ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for virtual/ruby-ssl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-ssl/ChangeLog,v 1.31 2014/10/10 09:02:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-ssl/ChangeLog,v 1.32 2014/12/30 12:24:48 graaff Exp $
+
+*ruby-ssl-5 (30 Dec 2014)
+
+ 30 Dec 2014; Hans de Graaff <graaff@gentoo.org> +ruby-ssl-5.ebuild:
+ Add a version for ruby22.
10 Oct 2014; Hans de Graaff <graaff@gentoo.org> -ruby-ssl-2.ebuild:
Remove masked jruby 1.6 version.
diff --git a/virtual/ruby-ssl/ruby-ssl-5.ebuild b/virtual/ruby-ssl/ruby-ssl-5.ebuild
new file mode 100644
index 000000000000..6f9760b6eaaa
--- /dev/null
+++ b/virtual/ruby-ssl/ruby-ssl-5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-ssl/ruby-ssl-5.ebuild,v 1.1 2014/12/30 12:24:48 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby22"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for the Ruby OpenSSL bindings"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-lang/ruby:2.2[ssl]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.