summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-05-29 22:48:18 +0000
committerMike Frysinger <vapier@gentoo.org>2009-05-29 22:48:18 +0000
commitd893f6998c871a5962272179f2dcef1e5925f555 (patch)
treeb044d863e1417238215154e9ff5cba5e4a3b574a /sys-process
parentold (diff)
downloadgentoo-2-d893f6998c871a5962272179f2dcef1e5925f555.tar.gz
gentoo-2-d893f6998c871a5962272179f2dcef1e5925f555.tar.bz2
gentoo-2-d893f6998c871a5962272179f2dcef1e5925f555.zip
Version bump #269429 by Lars Wendler.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/procps/ChangeLog7
-rw-r--r--sys-process/procps/procps-3.2.8.ebuild81
2 files changed, 86 insertions, 2 deletions
diff --git a/sys-process/procps/ChangeLog b/sys-process/procps/ChangeLog
index dd27d5482f00..9d2d2e085bb8 100644
--- a/sys-process/procps/ChangeLog
+++ b/sys-process/procps/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-process/procps
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.28 2008/08/16 03:41:37 cardoe Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.29 2009/05/29 22:48:18 vapier Exp $
+
+ 29 May 2009; Mike Frysinger <vapier@gentoo.org> ChangeLog:
+ Version bump #269429 by Lars Wendler.
16 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/sys-process/procps/procps-3.2.8.ebuild b/sys-process/procps/procps-3.2.8.ebuild
new file mode 100644
index 000000000000..c610c3cede63
--- /dev/null
+++ b/sys-process/procps/procps-3.2.8.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.2.8.ebuild,v 1.1 2009/05/29 22:48:18 vapier Exp $
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="Standard informational utilities and process-handling tools"
+HOMEPAGE="http://procps.sourceforge.net/"
+SRC_URI="http://procps.sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="n32"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/3.2.5-top-sort.patch
+ epatch "${FILESDIR}"/procps-3.2.7-proc-mount.patch
+ epatch "${FILESDIR}"/procps-3.2.3-noproc.patch
+
+ # Clean up the makefile
+ # - we do stripping ourselves
+ # - punt fugly gcc flags
+ sed -i \
+ -e '/install/s: --strip : :' \
+ -e '/ALL_CFLAGS += $(call check_gcc,-fweb,)/d' \
+ -e '/ALL_CFLAGS += $(call check_gcc,-Wstrict-aliasing=2,)/s,=2,,' \
+ -e "/^lib64/s:=.*:=$(get_libdir):" \
+ -e 's:-m64::g' \
+ Makefile || die "sed Makefile"
+
+ # mips 2.4.23 headers (and 2.6.x) don't allow PAGE_SIZE to be defined in
+ # userspace anymore, so this patch instructs procps to get the
+ # value from sysconf().
+ epatch "${FILESDIR}"/${PN}-mips-define-pagesize.patch
+
+ # n32 isn't completly reliable of an ABI on mips64 at the current
+ # time. Eventually, it will be, but for now, we need to make sure
+ # procps doesn't try to force it on us.
+ if ! use n32 ; then
+ epatch "${FILESDIR}"/${PN}-3.2.6-mips-n32_isnt_usable_on_mips64_yet.patch
+ fi
+}
+
+src_compile() {
+ replace-flags -O3 -O2
+ emake \
+ CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ emake \
+ ln_f="ln -sf" \
+ ldconfig="true" \
+ DESTDIR="${D}" \
+ install \
+ || die "install failed"
+
+ insinto /usr/include/proc
+ doins proc/*.h || die "doins include"
+
+ dodoc sysctl.conf BUGS NEWS TODO ps/HACKING
+
+ # compat symlink so people who shouldnt be using libproc can #170077
+ dosym libproc-${PV}.so /$(get_libdir)/libproc.so
+}
+
+pkg_postinst() {
+ einfo "NOTE: With NPTL \"ps\" and \"top\" no longer"
+ einfo "show threads. You can use any of: -m m -L -T H"
+ einfo "in ps or the H key in top to show them"
+}