summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-18 06:24:25 +0000
committerJustin Lecher <jlec@gentoo.org>2013-06-18 06:24:25 +0000
commitc8540f0618ac2813d7452985d703ae23534e1ccb (patch)
tree1442fd48270b1ffda33a9fff6f2ed30b557eb3fb /sys-process
parentadd doc build & install, symlink to include folder on install, revbump declined (diff)
downloadgentoo-2-c8540f0618ac2813d7452985d703ae23534e1ccb.tar.gz
gentoo-2-c8540f0618ac2813d7452985d703ae23534e1ccb.tar.bz2
gentoo-2-c8540f0618ac2813d7452985d703ae23534e1ccb.zip
sys-process/iotop: Version Bump, #473528
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/iotop/ChangeLog8
-rw-r--r--sys-process/iotop/files/iotop-0.6-setup.py3.patch31
-rw-r--r--sys-process/iotop/iotop-0.6.ebuild28
3 files changed, 66 insertions, 1 deletions
diff --git a/sys-process/iotop/ChangeLog b/sys-process/iotop/ChangeLog
index d7c4d8fb10b4..982b6b5b286f 100644
--- a/sys-process/iotop/ChangeLog
+++ b/sys-process/iotop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/iotop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/ChangeLog,v 1.59 2013/02/06 20:22:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/ChangeLog,v 1.60 2013/06/18 06:24:25 jlec Exp $
+
+*iotop-0.6 (18 Jun 2013)
+
+ 18 Jun 2013; Justin Lecher <jlec@gentoo.org> +iotop-0.6.ebuild,
+ +files/iotop-0.6-setup.py3.patch:
+ Version Bump, #473528
*iotop-0.5-r1 (06 Feb 2013)
diff --git a/sys-process/iotop/files/iotop-0.6-setup.py3.patch b/sys-process/iotop/files/iotop-0.6-setup.py3.patch
new file mode 100644
index 000000000000..5844d86cb1ba
--- /dev/null
+++ b/sys-process/iotop/files/iotop-0.6-setup.py3.patch
@@ -0,0 +1,31 @@
+From 98a5985e52e7041eb96c80dd95fd5c70634f5ee7 Mon Sep 17 00:00:00 2001
+Message-Id: <98a5985e52e7041eb96c80dd95fd5c70634f5ee7.1371536396.git.jlec@gentoo.org>
+From: Justin Lecher <jlec@gentoo.org>
+Date: Tue, 18 Jun 2013 08:19:28 +0200
+Subject: [PATCH] Make setp.py compatible with python3
+
+Dictionaries in python 3 do not contain the itervalues() method anymore.
+The values() method should be used and can also safely applied for
+python 2.
+
+Signed-off-by: Justin Lecher <jlec@gentoo.org>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 7150102..9de6068 100755
+--- a/setup.py
++++ b/setup.py
+@@ -7,7 +7,7 @@ from iotop.version import VERSION
+ # Dirty hack to make setup.py install the iotop script to sbin/ instead of bin/
+ # while still honoring the choice of installing into local/ or not.
+ if hasattr(distutils_install, 'INSTALL_SCHEMES'):
+- for d in distutils_install.INSTALL_SCHEMES.itervalues():
++ for d in distutils_install.INSTALL_SCHEMES.values():
+ if d.get('scripts', '').endswith('/bin'):
+ d['scripts'] = d['scripts'][:-len('/bin')] + '/sbin'
+
+--
+1.8.2.1
+
diff --git a/sys-process/iotop/iotop-0.6.ebuild b/sys-process/iotop/iotop-0.6.ebuild
new file mode 100644
index 000000000000..11f75b5d1156
--- /dev/null
+++ b/sys-process/iotop/iotop-0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.6.ebuild,v 1.1 2013/06/18 06:24:25 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 linux-info
+
+DESCRIPTION="Top-like UI used to show which process is using the I/O"
+HOMEPAGE="http://guichaz.free.fr/iotop/"
+SRC_URI="http://guichaz.free.fr/iotop//files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+DOCS=( NEWS README THANKS ChangeLog )
+
+PATCHES=( "${FILESDIR}"/${P}-setup.py3.patch )
+
+pkg_setup() {
+ linux-info_pkg_setup
+}