summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-21 20:57:51 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-21 20:57:51 +0000
commit61cbfc65bb4c626361107c8aebf7a7685a19f4b1 (patch)
treefdc2c5aeaaa40d5a8d534248db3d7d58dab5f209 /sys-process/htop/htop-0.8.3.ebuild
parentFix cross compiling wrt #328971 by Johannes Krude (diff)
downloadgentoo-2-61cbfc65bb4c626361107c8aebf7a7685a19f4b1.tar.gz
gentoo-2-61cbfc65bb4c626361107c8aebf7a7685a19f4b1.tar.bz2
gentoo-2-61cbfc65bb4c626361107c8aebf7a7685a19f4b1.zip
old
(Portage version: 2.2.0_alpha92/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/htop/htop-0.8.3.ebuild')
-rw-r--r--sys-process/htop/htop-0.8.3.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sys-process/htop/htop-0.8.3.ebuild b/sys-process/htop/htop-0.8.3.ebuild
deleted file mode 100644
index ba0fecb2a9cd..000000000000
--- a/sys-process/htop/htop-0.8.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.8.3.ebuild,v 1.10 2011/07/08 10:24:22 ssuominen Exp $
-
-EAPI=3
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="interactive process viewer"
-HOMEPAGE="http://htop.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-IUSE="debug"
-
-RDEPEND="sys-libs/ncurses[unicode]"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use elibc_FreeBSD && ! [[ -f ${ROOT}/proc/stat && -f ${ROOT}/proc/meminfo ]]; then
- eerror
- eerror "htop needs /proc mounted to compile and work, to mount it type"
- eerror "mount -t linprocfs none /proc"
- eerror "or uncomment the example in /etc/fstab"
- eerror
- die "htop needs /proc mounted"
- fi
-
- if ! has_version sys-process/lsof; then
- ewarn "To use lsof features in htop(what processes are accessing"
- ewarn "what files), you must have sys-process/lsof installed."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.8.1-non-printable-char-filter.patch
-}
-
-src_configure() {
- use debug && append-flags -DDEBUG
- econf \
- --enable-taskstats \
- --enable-unicode
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README ChangeLog TODO || die
- rmdir "${ED}"/usr/{include,$(get_libdir)} || die
-}