summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2005-08-08 07:52:25 +0000
committerWolfram Schlich <wschlich@gentoo.org>2005-08-08 07:52:25 +0000
commit7e431ffd4d2c7c06ff46bb669a075d2870d93164 (patch)
tree43964243ff47f5d52fe25b2a1de2f936b3b7e44b /sys-process/htop/htop-0.5.2.ebuild
parentInitial commit for modular X. (diff)
downloadgentoo-2-7e431ffd4d2c7c06ff46bb669a075d2870d93164.tar.gz
gentoo-2-7e431ffd4d2c7c06ff46bb669a075d2870d93164.tar.bz2
gentoo-2-7e431ffd4d2c7c06ff46bb669a075d2870d93164.zip
fix USE=debug behavior
(Portage version: 2.0.51-r14)
Diffstat (limited to 'sys-process/htop/htop-0.5.2.ebuild')
-rw-r--r--sys-process/htop/htop-0.5.2.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/sys-process/htop/htop-0.5.2.ebuild b/sys-process/htop/htop-0.5.2.ebuild
index 68cda697ddc3..75818e068765 100644
--- a/sys-process/htop/htop-0.5.2.ebuild
+++ b/sys-process/htop/htop-0.5.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.5.2.ebuild,v 1.6 2005/07/31 21:28:16 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.5.2.ebuild,v 1.7 2005/08/08 07:52:25 wschlich Exp $
-inherit flag-o-matic
+inherit debug flag-o-matic
DESCRIPTION="interactive process viewer"
HOMEPAGE="http://htop.sourceforge.net"
@@ -10,14 +10,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-IUSE="debug"
DEPEND="sys-libs/ncurses"
src_compile() {
- use debug && {
- append-flags -O -ggdb -DDEBUG
- RESTRICT="${RESTRICT} nostrip"
- }
+ useq debug && append-flags -O -ggdb -DDEBUG
econf || die "configure failed"
emake || die "make failed"
}