summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-12-01 00:21:50 +0000
committerThilo Bangert <bangert@gentoo.org>2009-12-01 00:21:50 +0000
commit55e3d9572ce25b4a07ddb7493a8085b1531cffef (patch)
treed26d6c664af8cef28b0f1f3ff1b6f4b37e16b14c /sys-process/cronie
parentstable sparc, bug 289857 (diff)
downloadgentoo-2-55e3d9572ce25b4a07ddb7493a8085b1531cffef.tar.gz
gentoo-2-55e3d9572ce25b4a07ddb7493a8085b1531cffef.tar.bz2
gentoo-2-55e3d9572ce25b4a07ddb7493a8085b1531cffef.zip
add version bump to push pam fix to users - requested by pacho
(Portage version: 2.2_rc53/cvs/Linux i686)
Diffstat (limited to 'sys-process/cronie')
-rw-r--r--sys-process/cronie/ChangeLog7
-rw-r--r--sys-process/cronie/cronie-1.4.3-r1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-process/cronie/ChangeLog b/sys-process/cronie/ChangeLog
index abd96b4f3845..e7e5897cc4a4 100644
--- a/sys-process/cronie/ChangeLog
+++ b/sys-process/cronie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/cronie
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.8 2009/11/29 13:18:21 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.9 2009/12/01 00:21:50 bangert Exp $
+
+*cronie-1.4.3-r1 (01 Dec 2009)
+
+ 01 Dec 2009; Thilo Bangert <bangert@gentoo.org> +cronie-1.4.3-r1.ebuild:
+ add version bump to push pam fix to users
29 Nov 2009; Thilo Bangert <bangert@gentoo.org> files/cronie-1.4.3-pamd:
fix PAM - bug #294631
diff --git a/sys-process/cronie/cronie-1.4.3-r1.ebuild b/sys-process/cronie/cronie-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..1d63d9c81567
--- /dev/null
+++ b/sys-process/cronie/cronie-1.4.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.3-r1.ebuild,v 1.1 2009/12/01 00:21:50 bangert Exp $
+
+EAPI="2"
+
+inherit cron eutils pam
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
+SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
+HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+
+LICENSE="ISC BSD BSD-2"
+KEYWORDS="~x86"
+IUSE="inotify pam"
+
+DEPEND="pam? ( virtual/pam )"
+RDEPEND="${DEPEND}"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+src_configure() {
+ SPOOL_DIR="/var/spool/cron/crontabs" econf \
+ $(use_with inotify ) \
+ $(use_with pam ) \
+ --with-daemon_username=cron \
+ --with-daemon_groupname=cron \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+
+ docrondir
+ fowners root:cron /usr/bin/crontab
+ fperms 2750 /usr/bin/crontab
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-1.2-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ keepdir /etc/cron.d
+ newinitd "${FILESDIR}/${PN}-1.2-initd" cronie
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+
+ dodoc NEWS AUTHORS README
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+}