summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-02-07 04:25:16 +0000
committerMike Frysinger <vapier@gentoo.org>2007-02-07 04:25:16 +0000
commit3fd6f22f671c2bb5087b4b95d7c9bc40ffaf46b5 (patch)
tree4be36d360486434b33ecec835c0df790829e5a94 /sys-power
parentmake sure we link against local gdbm rather than system one #165263 (diff)
downloadgentoo-2-3fd6f22f671c2bb5087b4b95d7c9bc40ffaf46b5.tar.gz
gentoo-2-3fd6f22f671c2bb5087b4b95d7c9bc40ffaf46b5.tar.bz2
gentoo-2-3fd6f22f671c2bb5087b4b95d7c9bc40ffaf46b5.zip
Add new ebuild to fetch updated motherboard definitions from upstream svn #165567 by Sebastian.
(Portage version: 2.1.2-r8)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/nvram-wakeup/ChangeLog11
-rw-r--r--sys-power/nvram-wakeup/files/digest-nvram-wakeup-0.97-r12
-rw-r--r--sys-power/nvram-wakeup/files/digest-nvram-wakeup-0.97_p8636
-rw-r--r--sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild69
4 files changed, 86 insertions, 2 deletions
diff --git a/sys-power/nvram-wakeup/ChangeLog b/sys-power/nvram-wakeup/ChangeLog
index 1cc100aa5a92..caeeec71910c 100644
--- a/sys-power/nvram-wakeup/ChangeLog
+++ b/sys-power/nvram-wakeup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/nvram-wakeup
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nvram-wakeup/ChangeLog,v 1.3 2005/12/13 23:14:19 zzam Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nvram-wakeup/ChangeLog,v 1.4 2007/02/07 04:25:16 vapier Exp $
+
+*nvram-wakeup-0.97_p863 (07 Feb 2007)
+
+ 07 Feb 2007; Mike Frysinger <vapier@gentoo.org>
+ +nvram-wakeup-0.97_p863.ebuild:
+ Add new ebuild to fetch updated motherboard definitions from upstream svn
+ #165567 by Sebastian.
13 Dec 2005; Matthias Schwarzott <zzam@gentoo.org>
nvram-wakeup-0.97-r1.ebuild:
diff --git a/sys-power/nvram-wakeup/files/digest-nvram-wakeup-0.97-r1 b/sys-power/nvram-wakeup/files/digest-nvram-wakeup-0.97-r1
index 9079f32a59c8..a9fb0c448b84 100644
--- a/sys-power/nvram-wakeup/files/digest-nvram-wakeup-0.97-r1
+++ b/sys-power/nvram-wakeup/files/digest-nvram-wakeup-0.97-r1
@@ -1 +1,3 @@
MD5 004626e0ae33b3b59b9320da9434c673 nvram-wakeup-0.97.tar.bz2 55853
+RMD160 a3feccc49361f2512e213fbfefc2865cce2e187f nvram-wakeup-0.97.tar.bz2 55853
+SHA256 f2d8e0bf6d0199b45849ff4fe94426d83a198e5c33cf0a2651ec2a8d96ab054b nvram-wakeup-0.97.tar.bz2 55853
diff --git a/sys-power/nvram-wakeup/files/digest-nvram-wakeup-0.97_p863 b/sys-power/nvram-wakeup/files/digest-nvram-wakeup-0.97_p863
new file mode 100644
index 000000000000..ea787407186b
--- /dev/null
+++ b/sys-power/nvram-wakeup/files/digest-nvram-wakeup-0.97_p863
@@ -0,0 +1,6 @@
+MD5 004626e0ae33b3b59b9320da9434c673 nvram-wakeup-0.97.tar.bz2 55853
+RMD160 a3feccc49361f2512e213fbfefc2865cce2e187f nvram-wakeup-0.97.tar.bz2 55853
+SHA256 f2d8e0bf6d0199b45849ff4fe94426d83a198e5c33cf0a2651ec2a8d96ab054b nvram-wakeup-0.97.tar.bz2 55853
+MD5 77710334e1c95bb0788bce3075e96c1f nvram-wakeup-mb.c?revision=863 152785
+RMD160 1291dec309c968eec7a64fdd081607b4ed1ff8c0 nvram-wakeup-mb.c?revision=863 152785
+SHA256 0f166f567b37b09ee71949f4b036c5722b692cb6cc1ceba08837180c46331731 nvram-wakeup-mb.c?revision=863 152785
diff --git a/sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild b/sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild
new file mode 100644
index 000000000000..81791e59400c
--- /dev/null
+++ b/sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild,v 1.1 2007/02/07 04:25:16 vapier Exp $
+
+inherit flag-o-matic
+
+MY_P=${P%_p*}
+REV=${P#*_p}
+DESCRIPTION="read and write the WakeUp time in the BIOS"
+HOMEPAGE="http://sourceforge.net/projects/nvram-wakeup"
+SRC_URI="mirror://sourceforge/nvram-wakeup/${MY_P}.tar.bz2"
+[[ -n ${REV} ]] && SRC_URI="${SRC_URI}
+ http://nvram-wakeup.svn.sourceforge.net/viewvc/*checkout*/nvram-wakeup/trunk/nvram-wakeup/nvram-wakeup-mb.c?revision=${REV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ if [[ -n ${REV} ]] ; then
+ cp "${DISTDIR}"/nvram-wakeup-mb.c?revision=${REV} "${S}"/nvram-wakeup-mb.c || die
+ fi
+ cd "${S}"
+ use nls || epatch "${FILESDIR}"/${P}-nonls.patch
+ # Need to be careful with CFLAGS since this could eat your bios
+ strip-flags
+ sed -i \
+ -e "s:-O2 -Wall -Wstrict-prototypes -g -mcpu=i686:${CFLAGS}:" \
+ Makefile || die "setting CFLAGS"
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ MANDIR="${D}"/usr/share/man \
+ DOCDIR="${D}"/usr/share/doc/${PF} \
+ install || die
+
+ dodoc "${D}"/usr/bin/vdrshutdown
+ rm -f "${D}"/usr/bin/vdrshutdown
+ dodoc set_timer
+
+ rm -f "${D}"/usr/sbin/time
+ rm -f "${D}"/usr/share/man/man*/time.8*
+
+ prepalldocs
+}
+
+pkg_postinst() {
+ echo
+ ewarn "WARNING:"
+ ewarn "This program writes into the NVRAM (used by BIOS to store the CMOS"
+ ewarn "settings). This is DANGEROUS. Do it at your own risk. Neither the"
+ ewarn "author of this program (nvram-wakeup) nor anyone else can be made"
+ ewarn "responsible to any damage made by this program in any way."
+ ewarn "(The worst case happened to me is that on reboot the BIOS noticed the"
+ ewarn "illegal contents of the nvram and set everything to default values."
+ ewarn "But this doesn't mean that you can't destroy even your whole computer.)"
+ echo
+ ewarn " YOU HAVE BEEN WARNED, HAVE A NICE DAY"
+ echo
+}