summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-01-31 15:51:12 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-01-31 15:51:12 +0000
commit32219e743ff66febb7196a05bbcd55fc3d95375c (patch)
treef7ccc7fc81f5df23ebc50c076d5d8c0179faa6fd /sys-power
parentMarked ~hppa (bug #499900). (diff)
downloadgentoo-2-32219e743ff66febb7196a05bbcd55fc3d95375c.tar.gz
gentoo-2-32219e743ff66febb7196a05bbcd55fc3d95375c.tar.bz2
gentoo-2-32219e743ff66febb7196a05bbcd55fc3d95375c.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpid/ChangeLog7
-rw-r--r--sys-power/acpid/acpid-2.0.21.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index a0c1f80b43f9..715a8c895758 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/acpid
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.111 2014/01/15 10:04:09 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.112 2014/01/31 15:51:12 ssuominen Exp $
+
+*acpid-2.0.21 (31 Jan 2014)
+
+ 31 Jan 2014; Samuli Suominen <ssuominen@gentoo.org> +acpid-2.0.21.ebuild:
+ Version bump.
15 Jan 2014; Agostino Sarubbo <ago@gentoo.org> acpid-2.0.19.ebuild:
Stable for ia64, wrt bug #482252
diff --git a/sys-power/acpid/acpid-2.0.21.ebuild b/sys-power/acpid/acpid-2.0.21.ebuild
new file mode 100644
index 000000000000..8601c95f57f6
--- /dev/null
+++ b/sys-power/acpid/acpid-2.0.21.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.21.ebuild,v 1.1 2014/01/31 15:51:12 ssuominen Exp $
+
+EAPI=5
+inherit systemd
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://sourceforge.net/projects/acpid2"
+SRC_URI="mirror://sourceforge/${PN}2/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 -ppc ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-apm )"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-3"
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newdoc kacpimon/README README.kacpimon
+ dodoc -r samples
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING || die
+
+ exeinto /etc/acpi
+ newexe "${FILESDIR}"/${PN}-1.0.6-default.sh default.sh
+ exeinto /etc/acpi/actions
+ newexe samples/powerbtn/powerbtn.sh powerbtn.sh
+ insinto /etc/acpi/events
+ newins "${FILESDIR}"/${PN}-1.0.4-default default
+
+ newinitd "${FILESDIR}"/${PN}-2.0.16-init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}-2.0.16-conf.d ${PN}
+
+ systemd_dounit "${FILESDIR}"/systemd/${PN}.{service,socket}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "You may wish to read the Gentoo Linux Power Management Guide,"
+ elog "which can be found online at:"
+ elog "http://www.gentoo.org/doc/en/power-management-guide.xml"
+ elog
+ fi
+
+ # files/systemd/acpid.socket -> ListenStream=/run/acpid.socket
+ mkdir -p "${ROOT}"/run
+
+ if ! grep -qs "^tmpfs.*/run " "${ROOT}"/proc/mounts ; then
+ echo
+ ewarn "You should reboot the system now to get /run mounted with tmpfs!"
+ fi
+}