summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-04-05 15:58:10 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-04-05 15:58:10 +0000
commit34b62a35f32c796b59a02ced76bfc3dc0e73c52e (patch)
tree8644a0ba8bc8e9638e7b5452d19978e88a15fb2b /sys-power/hibernate-script
parentVersion bump. (diff)
downloadgentoo-2-34b62a35f32c796b59a02ced76bfc3dc0e73c52e.tar.gz
gentoo-2-34b62a35f32c796b59a02ced76bfc3dc0e73c52e.tar.bz2
gentoo-2-34b62a35f32c796b59a02ced76bfc3dc0e73c52e.zip
Version bump
(Portage version: 2.1.5_rc1)
Diffstat (limited to 'sys-power/hibernate-script')
-rw-r--r--sys-power/hibernate-script/ChangeLog8
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.98.1.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index 401bb7d8df9a..b74319814d30 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.76 2008/01/26 22:11:48 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.77 2008/04/05 15:58:10 alonbl Exp $
+
+*hibernate-script-1.98.1 (05 Apr 2008)
+
+ 05 Apr 2008; Alon Bar-Lev <alonbl@gentoo.org>
+ +hibernate-script-1.98.1.ebuild:
+ Version bump
*hibernate-script-1.97-r5 (26 Jan 2008)
diff --git a/sys-power/hibernate-script/hibernate-script-1.98.1.ebuild b/sys-power/hibernate-script/hibernate-script-1.98.1.ebuild
new file mode 100644
index 000000000000..c38094b3040c
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.98.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.98.1.ebuild,v 1.1 2008/04/05 15:58:10 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="1"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="!<media-gfx/splashutils-1.5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Our patches
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate suspend"
+ elog "images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}