summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-24 22:01:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-24 22:01:18 +0000
commit0adae915e8566b2c5fe3008fc53167fe58129583 (patch)
treeee8ab741bd7b5ac802e7074a0b4be98a5758264d /sys-power/cpufreqd
parentstable amd64, bug 323757 (diff)
downloadgentoo-2-0adae915e8566b2c5fe3008fc53167fe58129583.tar.gz
gentoo-2-0adae915e8566b2c5fe3008fc53167fe58129583.tar.bz2
gentoo-2-0adae915e8566b2c5fe3008fc53167fe58129583.zip
old
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/cpufreqd')
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.1.1.ebuild6
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild78
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.2.1.ebuild77
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.3.4.ebuild82
4 files changed, 3 insertions, 240 deletions
diff --git a/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild b/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild
index b32f2e982dc0..56578d3199ec 100644
--- a/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild
+++ b/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild,v 1.8 2009/10/20 10:21:33 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild,v 1.9 2010/06/24 22:01:18 ssuominen Exp $
inherit eutils
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc ~sparc x86"
+KEYWORDS="ppc"
IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
RDEPEND=">=sys-power/cpufrequtils-002
diff --git a/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild b/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild
deleted file mode 100644
index 28c20ab36269..000000000000
--- a/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild,v 1.4 2009/10/16 13:22:12 bangert Exp $
-
-inherit eutils autotools
-
-NVCLOCK_VERSION="0.8b"
-
-DESCRIPTION="CPU Frequency Daemon"
-HOMEPAGE="http://cpufreqd.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- nvidia? ( http://www.linuxhardware.org/nvclock/nvclock${NVCLOCK_VERSION}.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
-RDEPEND=">=sys-power/cpufrequtils-002
- lm_sensors? ( <sys-apps/lm_sensors-3 )"
-DEPEND="sys-apps/sed
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i -e "s:acpi_event:acpi:" "${S}"/cpufreqd.conf
- epatch "${FILESDIR}"/${PN}-conf.d.patch
-
- if use nvidia; then
- cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
- epatch "${FILESDIR}"/nvclock${NVCLOCK_VERSION}-fpic.patch
- fi
-}
-
-src_compile() {
- local config
-
- if use nvidia; then
- cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
- econf \
- --disable-gtk \
- --disable-qt \
- --disable-nvcontrol \
- || die "econf nvclock failed"
- emake -j1 || die "emake nvclock failed"
- config="--enable-nvclock=${WORKDIR}/nvclock${NVCLOCK_VERSION}"
- fi
-
- cd "${S}"
- econf \
- $(use_enable acpi) \
- $(use_enable apm) \
- $(use_enable lm_sensors sensors) \
- $(use_enable nforce2) \
- $(use_enable pmu) \
- ${config} \
- || die "econf failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS ChangeLog NEWS README TODO
-
- newinitd "${FILESDIR}"/${PN}-init.d ${PN}
-}
-
-pkg_postinst() {
- if [ -f "${ROOT}"/etc/conf.d/cpufreqd ] ; then
- ewarn "Please make sure, you remove \"/etc/conf.d/cpufreqd\". It breaks"
- ewarn "the init-script! (#152096)"
- ewarn
- ewarn "Use this if you don't know how to do it:"
- ewarn "# rm /etc/conf.d/cpufreqd"
- fi
-}
diff --git a/sys-power/cpufreqd/cpufreqd-2.2.1.ebuild b/sys-power/cpufreqd/cpufreqd-2.2.1.ebuild
deleted file mode 100644
index 4e7812085ab7..000000000000
--- a/sys-power/cpufreqd/cpufreqd-2.2.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.2.1.ebuild,v 1.6 2009/10/16 13:22:12 bangert Exp $
-
-inherit eutils autotools
-
-NVCLOCK_VERSION="0.8b"
-
-DESCRIPTION="CPU Frequency Daemon"
-HOMEPAGE="http://cpufreqd.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- nvidia? ( http://www.linuxhardware.org/nvclock/nvclock${NVCLOCK_VERSION}.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-
-IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
-RDEPEND=">=sys-power/cpufrequtils-002
- lm_sensors? ( <sys-apps/lm_sensors-3 )"
-DEPEND="sys-apps/sed
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-conf.d.patch
-
- if use nvidia; then
- cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
- epatch "${FILESDIR}"/nvclock${NVCLOCK_VERSION}-fpic.patch
- fi
-}
-
-src_compile() {
- local config
-
- if use nvidia; then
- cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
- econf \
- --disable-gtk \
- --disable-qt \
- --disable-nvcontrol \
- || die "econf nvclock failed"
- emake -j1 || die "emake nvclock failed"
- config="--enable-nvclock=${WORKDIR}/nvclock${NVCLOCK_VERSION}"
- fi
-
- cd "${S}"
- econf \
- $(use_enable acpi) \
- $(use_enable apm) \
- $(use_enable lm_sensors sensors) \
- $(use_enable nforce2) \
- $(use_enable pmu) \
- ${config} \
- || die "econf failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS ChangeLog NEWS README TODO
-
- newinitd "${FILESDIR}"/${PN}-init.d ${PN}
-}
-
-pkg_postinst() {
- if [ -f "${ROOT}"/etc/conf.d/cpufreqd ] ; then
- ewarn "Please make sure, you remove \"/etc/conf.d/cpufreqd\". It breaks"
- ewarn "the init-script! (#152096)"
- ewarn
- ewarn "Use this if you don't know how to do it:"
- ewarn "# rm /etc/conf.d/cpufreqd"
- fi
-}
diff --git a/sys-power/cpufreqd/cpufreqd-2.3.4.ebuild b/sys-power/cpufreqd/cpufreqd-2.3.4.ebuild
deleted file mode 100644
index 305682943814..000000000000
--- a/sys-power/cpufreqd/cpufreqd-2.3.4.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.3.4.ebuild,v 1.1 2009/10/20 13:06:45 bangert Exp $
-
-EAPI="2"
-
-inherit eutils
-
-NVCLOCK_VERSION="0.8b"
-
-DESCRIPTION="CPU Frequency Daemon"
-HOMEPAGE="http://www.linux.it/~malattia/wiki/index.php/Cpufreqd"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- nvidia? ( http://www.linuxhardware.org/nvclock/nvclock${NVCLOCK_VERSION}.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-
-IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
-RDEPEND=">=sys-power/cpufrequtils-002
- lm_sensors? ( <sys-apps/lm_sensors-3 )"
-DEPEND="sys-apps/sed
- ${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-conf.d.patch
-
- if use nvidia; then
- cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
- epatch "${FILESDIR}"/nvclock${NVCLOCK_VERSION}-fpic.patch
- fi
-}
-
-src_configure() {
- local config
-
- if use nvidia; then
- cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
- econf \
- --disable-gtk \
- --disable-qt \
- --disable-nvcontrol \
- || die "econf nvclock failed"
- emake -j1 || die "emake nvclock failed"
- config="--enable-nvclock=${WORKDIR}/nvclock${NVCLOCK_VERSION}"
- fi
-
- cd "${S}"
- econf \
- $(use_enable acpi) \
- $(use_enable apm) \
- $(use_enable lm_sensors sensors) \
- $(use_enable nforce2) \
- $(use_enable pmu) \
- ${config} \
- || die "econf failed"
-}
-
-src_compile() {
- if use nvidia; then
- cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
- fi
-
- cd "${S}"
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- rm -rf "${D}"/usr/$(get_libdir)/*.la
- dodoc AUTHORS ChangeLog NEWS README TODO
- newinitd "${FILESDIR}"/${PN}-init.d ${PN}
-}
-
-pkg_postinst() {
- if [ -f "${ROOT}"/etc/conf.d/cpufreqd ] ; then
- ewarn "An old \"/etc/conf.d/cpufreqd\" file was found. It breaks"
- ewarn "the new init script! Please remove it."
- ewarn "# rm /etc/conf.d/cpufreqd"
- fi
-}